[MODDB] ACP Announcement Centre 1.0.1

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
User avatar
mitthoo
Registered User
Posts: 253
Joined: Tue Oct 03, 2006 12:34 pm

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by mitthoo »

nope.. not working 8-)
User avatar
mitthoo
Registered User
Posts: 253
Joined: Tue Oct 03, 2006 12:34 pm

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by mitthoo »

do i need to add it in overall header or index_body. i mean the html code.
User avatar
mitthoo
Registered User
Posts: 253
Joined: Tue Oct 03, 2006 12:34 pm

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by mitthoo »

i think some modification needs to be done in viewtopic and viewforum .php as well.
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by lefty74 »

mitthoo wrote:do i need to add it in overall header or index_body. i mean the html code.
you delete the previous code in index_body.html and add it to overall_header.html. (prosilver) in subsilver2, you do not need to do anything.
mitthoo wrote:i think some modification needs to be done in viewtopic and viewforum .php as well.
can you be a little more specific what is not working as with the information you provided so far I am afraid i cant be of much help?

i will have another look tonight but i was pretty sure it worked fine on my board in viewtopic and viewforum.

if u want u can post me the following files
index.php,
includes/functions.php,
index_body.html
and overall_header.html

cheers
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
mitthoo
Registered User
Posts: 253
Joined: Tue Oct 03, 2006 12:34 pm

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by mitthoo »

you delete the previous code in index_body.html and add it to overall_header.html. (prosilver) in subsilver2,
can you be a little more specific what is not working as with the information you provided so far I am afraid i cant be of much help?
thats what i did.

ok leme explain it agiain.
I used your mod, which only displays the announcements on index page. i wanted that on all the pages(viewforum,viewtopic) as well. so i added the code in overall header instead of index_body .

it didn't work.

then u said change the code which u mentioned in 3-4 posts before. i did that.. didn't work again( at this point of time i was using ur code in overall header. i changed it to index body as well. but no improvements.)

i can't explain it in more clarity.

All i want it the announcements to come on all the pages.

At the moment i have the code in overall header and all modifications are as per you said.


Now what to do ? :D
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by lefty74 »

thanks for the additional info.

i am going to have a look later when i am home.

if u could sent me ur modified pages of
index.php,
includes/functions.php,
index_body.html
and overall_header.html

I will put them on my testboard to see whether I have the same output.
thanks :)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by lefty74 »

thanks, looking at functions.php and index.php it looks like you did not follow the change instructions from here
lefty74 wrote:
mitthoo wrote: 2. how do i get it on all the pages. i mean i added it on overall_header but it didn't work. it was only coming on index page.
Would you mind testing this?
Did you notice that there was a link on the word 'this' leading you to the change instructions?
grateful if you could try again.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
MattJG77
Registered User
Posts: 98
Joined: Wed Feb 08, 2006 10:04 pm

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by MattJG77 »

WheelGuy wrote:What I done was manually edited the datbase. for that value 'announcement_enable' , i just deleted the intial value so there would not be one and everything worked fine.
YAY. this fixed it! :) many thanks



NOTE. the download 0.0.1a currently has NO reference to editing index_body.html

i have solved this missing code by copping it from link in previous post. (Would you mind testing this?)

download fix required!








p.s. grate little MOD! ;) keep up the good work!
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by lefty74 »

MattJG77 wrote:
WheelGuy wrote:What I done was manually edited the datbase. for that value 'announcement_enable' , i just deleted the intial value so there would not be one and everything worked fine.
YAY. this fixed it! :) many thanks



NOTE. the download 0.0.1a currently has NO reference to editing index_body.html

i have solved this missing code by copping it from link in previous post. (Would you mind testing this?)

download fix required!
many thanks to wheelguy :D

btw, i just looked at the download and the instruction for prosilver and subsilver are in there, did you look at the templates folder?
p.s. grate little MOD! ;) keep up the good work!
cheers :)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
MattJG77
Registered User
Posts: 98
Joined: Wed Feb 08, 2006 10:04 pm

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by MattJG77 »

lefty74 wrote:
MattJG77 wrote:
WheelGuy wrote:What I done was manually edited the datbase. for that value 'announcement_enable' , i just deleted the intial value so there would not be one and everything worked fine.
YAY. this fixed it! :) many thanks



NOTE. the download 0.0.1a currently has NO reference to editing index_body.html

i have solved this missing code by copping it from link in previous post. (Would you mind testing this?)

download fix required!
many thanks to wheelguy :D

btw, i just looked at the download and the instruction for prosilver and subsilver are in there, did you look at the templates folder?
p.s. grate little MOD! ;) keep up the good work!
cheers :)
dam, your right. :oops:

but there should of been a reference to it in ACP_Announcement_Centre.xml so i knew to go look for template editing! :P

edit:
eather, Open: styles/prosilver/template/index_body.html
or something in DIY Instructions
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by lefty74 »

thanks, will keep this in mind although all the mods are built like this in accordance with the modx instructions (afaik)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
Big4wheeler
Registered User
Posts: 15
Joined: Sat May 05, 2007 7:24 pm

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by Big4wheeler »

I have followed all install instructions, when I make the announcement everything seems okay, but it does not show up on the index page, any help?
notaloafer
Registered User
Posts: 56
Joined: Fri Jun 08, 2007 5:02 am

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by notaloafer »

VERY nice simplistic mod, installed flawlessly. Thanks a bunch man! Good job on it!
WheelGuy
Registered User
Posts: 201
Joined: Tue Jan 30, 2007 4:07 pm
Contact:

Re: [BETA] ACP Announcement Centre 0.0.1a

Post by WheelGuy »

Big4wheeler wrote:I have followed all install instructions, when I make the announcement everything seems okay, but it does not show up on the index page, any help?
In the ACP where you type your "announcement etc", you do have the "Show Announcements" one checked?
Locked

Return to “[3.0.x] MODs in Development”