[BETA] ACP HTTP Proxy 0.5.2

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
Locked
User avatar
don-vip
Registered User
Posts: 14
Joined: Thu Nov 30, 2006 10:23 am
Location: Toulouse, France

[BETA] ACP HTTP Proxy 0.5.2

Post by don-vip »

MOD Title: ACP HTTP Proxy
MOD Description: A mod that allows phpBB administration panel to use an HTTP proxy to download remote files (especially for the update feature).
MOD Version: 0.5.2
phpBB3 Version: RC4

MOD Format:
Image

MOD Download: http://www.etud.insa-toulouse.fr/~vpriv ... -0.5.2.zip

This is my first mod for phpBB, and it works well now :)

08/11: First alpha, with two major bugs (strings not displayed + SQL error)
08/12: I solved the second bug (SQL error) and released Alpha 2.
08/13: First bug resolved, 0.5.2 released, with proxy authentication support :)
Last edited by don-vip on Sun Aug 12, 2007 10:58 pm, edited 5 times in total.

User avatar
thelinx
Registered User
Posts: 230
Joined: Sat May 26, 2007 9:17 am
Name: Linus

Re: [ALPHA] ACP HTTP Proxy

Post by thelinx »

don-vip wrote:- In my ACP module, the language strings are not displayed. All I have are the languages keys, like ACP_HTTP_PROXY_SETTINGS, etc.
You haven´t assigned them as template variables.
I don´t know if you have to, but try to put them in the template->assign_vars section.

User avatar
don-vip
Registered User
Posts: 14
Joined: Thu Nov 30, 2006 10:23 am
Location: Toulouse, France

Re: [ALPHA] ACP HTTP Proxy

Post by don-vip »

The documentation says:
Language variables are automatically assigned. You can use them by prefixing their name with 'L_'.
Maybe there's a condition to make them "automatically" assigned ?

User avatar
cheater512
Registered User
Posts: 296
Joined: Sat Mar 05, 2005 11:27 pm
Location: Brisbane, Australia
Contact:

Re: [ALPHA] ACP HTTP Proxy

Post by cheater512 »

Your putting the variables in the admin common language file?

User avatar
don-vip
Registered User
Posts: 14
Joined: Thu Nov 30, 2006 10:23 am
Location: Toulouse, France

Re: [ALPHA] ACP HTTP Proxy

Post by don-vip »

I tried in acp/board, then in acp/common, yes, and it doesn't change anything :(

EDIT: I've solved the second bug (SQL error) and released Alpha 2 (I've added SQL statements to initialize configuration, and commented lines concerning username/password).

User avatar
don-vip
Registered User
Posts: 14
Joined: Thu Nov 30, 2006 10:23 am
Location: Toulouse, France

Re: [BETA] ACP HTTP Proxy 0.5.2

Post by don-vip »

Yeah it works ! :D

I've added proxy authentication support, I think I'm going to start RC phase very soon :)

Locked

Return to “[3.0.x] MODs in Development”