[BETA] Account Links

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Ideas Centre
Drakkim
Registered User
Posts: 176
Joined: Thu Feb 05, 2004 5:48 am
Contact:

Re: [BETA] Linked Accounts

Post by Drakkim » Mon Dec 17, 2007 12:39 am

Oops! I left a very important note out of 0.5.4. You need to add the following code wherever you want it in any template (most likely overall_header.html) This will be fixed in the next version.

Code: Select all

<!-- INCLUDE linked_acct_form.html -->
--or--

Code: Select all

<!-- IF S_USER_LOGGED_IN --><!-- INCLUDE linked_acct_form.html --><!-- ENDIF -->

User avatar
Rotsblok
Registered User
Posts: 648
Joined: Fri Nov 11, 2005 12:47 pm
Location: Upper north of Holland
Name: Rikkert Westa
Contact:

Re: [BETA] Linked Accounts

Post by Rotsblok » Wed Jan 23, 2008 11:17 am

dutch lang. translation

Code: Select all

<?php
/**
*@ dutch translation by Rotsblok of http://www.phpbbservice.nl
* DO NOT CHANGE
*/
if (empty($lang) || !is_array($lang))
{
	$lang = array();
}

$lang = array_merge($lang, array(
	'LINKED_ACCT_EXPLAIN'	=> 'Link accounts zo dat je makkelijk tussen de accounts kan schakelen zonder dat je hoeft uit te loggen',

// Buttons and modes
	'SWITCH_USER'	=> 'Gebruiker Overschakelen',
	'LINK_USERS'	=> 'Gebruikers Linken',
	'UNLINK_USERS'	=> 'Gebruikers De-linken',

// Field labels
	'MASTER_NAME'	=> 'Hoofd Gebruikersnaam',
	'MASTER_PASS'	=> 'Hoofd Wachtwoord',
	'LINKED_NAME'	=> 'Gelinkte Gebruikersnaam',
	'LINKED_PASS'	=> 'Gelinkte Gebruikers Wachtwoord',

	'LINKED_ACCT'	=> 'Gelinkte Accounts',

// Messages
	'LINK_SUCCESS'	=> 'Link succesvol',
	'LINK_BROKEN'	=> 'Link Gebroken',

// Errors
	'NO_LINKED_ACCTS'	=> 'Er zijn geen accounts gelinkte voor dez',
	'BAD_MASTER_PASSWORD'	=> 'Ongeldige hoofd account wachtwoord',
	'BAD_LINKED_PASSWORD'	=> 'Gelinkte gebruikersnaam of wachtwoord ongeldig',
	'ACCT_NOT_LINKED'	=> 'Die account is niet gelinkt met deze. Goeie poging.',
	
	'NOT_MASTER'	=> 'Dit account is gelinkt met een andere. Schakel over naar de hoofd account om links toe te voegen of te verwijderen.',					
));
			
?>
Nederlandse Support site
Several dutch translations for 3.1 extensions if you need one or there is an update of an extension feel free to notify me.

gd106
Registered User
Posts: 36
Joined: Mon Mar 03, 2008 12:25 am

Re: [BETA] Linked Accounts

Post by gd106 » Tue Apr 01, 2008 7:49 am

can we get a repost please? the link isn't workin

User avatar
Scriptmaster10
Registered User
Posts: 107
Joined: Mon Aug 29, 2005 5:47 pm
Location: The Heart of England

Re: [BETA] Linked Accounts

Post by Scriptmaster10 » Sat Apr 26, 2008 7:25 pm

[phpBB Debug] PHP Notice: in file /includes/functions_linked_acct.php on line 128: Undefined variable: sql_where


I get that error on the homepage and it ruins all my template.

Drakkim
Registered User
Posts: 176
Joined: Thu Feb 05, 2004 5:48 am
Contact:

Re: [BETA] Linked Accounts

Post by Drakkim » Tue Apr 29, 2008 2:09 am

Scriptmaster10 wrote:[phpBB Debug] PHP Notice: in file /includes/functions_linked_acct.php on line 128: Undefined variable: sql_where
Quick fix:
Open '/includes/functions_linked_acct.php'
Find:

Code: Select all

	$master_id=0;
Add After:

Code: Select all

	$sql_where='';
That should fix it!

-Drakkim

User avatar
Scriptmaster10
Registered User
Posts: 107
Joined: Mon Aug 29, 2005 5:47 pm
Location: The Heart of England

Re: [BETA] Linked Accounts

Post by Scriptmaster10 » Sun May 04, 2008 10:22 am

That fixed that but I have another error:
[phpBB Debug] PHP Notice: in file /includes/ucp/ucp_linked_acct.php on line 112: Undefined variable: s_hidden_fields
On the UCP page.

User avatar
Scriptmaster10
Registered User
Posts: 107
Joined: Mon Aug 29, 2005 5:47 pm
Location: The Heart of England

Re: [BETA] Linked Accounts

Post by Scriptmaster10 » Sun May 04, 2008 10:34 am

Ok, I "fixed" that error with:

Code: Select all

$s_hidden_fields ='';

But now its just not linking accounts, the page just refreshes...

eDIT: NOW FULLY WORKING.

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: [BETA] Linked Accounts

Post by MydnyteSyn » Mon May 12, 2008 1:52 am

I realize this mod is in its beta stage of development, but should it work on a 3.0.1 board that is currently being used to test out mods?

Drakkim
Registered User
Posts: 176
Joined: Thu Feb 05, 2004 5:48 am
Contact:

Re: [BETA] Linked Accounts

Post by Drakkim » Mon May 12, 2008 2:26 am

I honestly haven't moved up to 3.0.1 yet, but it should work.

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: [BETA] Linked Accounts

Post by MydnyteSyn » Sat May 24, 2008 12:33 pm

(PhPBB 3.0.1) - I've uploaded the files to their respective directories. I added the SQL query as indicated at the beginning of the instructions. I refreshed the template and I purged the cache. I must be missing something because, even after reading through this thread, nothing appears in the user cp for linking accounts, nothing appears in the admin cp for adding this to the .MODS. Is something missing from the instructions? I even copied the instructions and pasted them into my forum to view to see if there was anything that wasn't appearing when I opened them, and it all read the exact same.

I added the drop down box for this to my portal page beneath the user info. The box appears with my current name in it, but since there isn't a way to link the accounts, I can't change to another. I'm using a drop down menu in the overall header and can't add the account switch box there.

Drakkim
Registered User
Posts: 176
Joined: Thu Feb 05, 2004 5:48 am
Contact:

Re: [BETA] Linked Accounts

Post by Drakkim » Sun May 25, 2008 1:51 am

I just updated to 3.0.1 with no problems. However, I'll set up a clean test install in the next couple days and see if I have any problems....

-Drakkim

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: [BETA] Linked Accounts

Post by MydnyteSyn » Sun May 25, 2008 12:06 pm

Great, I appreciate your help. I'm still wondering if I'm not missing something. Also, I use firefox. Does that have anything to do with it? Is it possible that perhaps one of the other mods I'm using is interfering?

Duvessa
Registered User
Posts: 2
Joined: Wed May 28, 2008 9:36 pm

Re: [BETA] Linked Accounts

Post by Duvessa » Wed May 28, 2008 9:39 pm

MydnyteSyn wrote:(PhPBB 3.0.1) - I've uploaded the files to their respective directories. I added the SQL query as indicated at the beginning of the instructions. I refreshed the template and I purged the cache. I must be missing something because, even after reading through this thread, nothing appears in the user cp for linking accounts, nothing appears in the admin cp for adding this to the .MODS.
I'm having the exact same problem in an otherwise unmodded install of PHPBB 3.0.1

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: [BETA] Linked Accounts

Post by MydnyteSyn » Wed May 28, 2008 10:33 pm

Thank you for sharing that. Now I'm sure I wasn't missing anything or didn't mess anything up. Hopefully Drakkim will be able to share a solution for us :)

Drakkim
Registered User
Posts: 176
Joined: Thu Feb 05, 2004 5:48 am
Contact:

Re: [BETA] Linked Accounts

Post by Drakkim » Thu May 29, 2008 3:02 am

Sorry about the long wait time, guys... Time's hard to come by lately...

Anyway... I did a fresh install and had no problems... On the other hand I can't find the documentation on phpBB.com now that clearly explains HOW to install a UCP Module.... (Which I thought I linked to early on in the topic... :| )
  1. Go into the Admin Panel
  2. Click the "System" tab
  3. Under "Module Management" click "User Control Panel"
  4. In the bottom right, there's a drop down with an "Add Module" button... Select "Edit Linked Accounts"
  5. Click "Add Module"
Let me know if that helps... I'll add this into the instructions for the next version...

Locked

Return to “[3.0.x] MODs in Development”

cron