[BETA] phPKG - MOD installer with repositories & packages

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Suggested Hosts
vpgtd
Registered User
Posts: 1
Joined: Thu Feb 14, 2008 5:42 am

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by vpgtd » Thu Feb 14, 2008 5:43 am

after going from page 1 all the way to 10 i saw only one other person with this error and i didn't find any info on it

Fatal error: Class 'SimpleXMLElement' not found in /var/www/localhost/htdocs/pkg/bb3phpkg.php on line 371


plz help

manofgames
Registered User
Posts: 36
Joined: Mon Mar 19, 2007 9:02 pm

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by manofgames » Thu Feb 14, 2008 1:29 pm

bearsaj99 wrote:About the safe mode thing. Is there a way to get around it and still have the mod working?

Also if this isn't possible do you know of any free hosts with php safe mode off?
I don't know about getting around it, I haven't looked at the code for the mod :-/
Though I know http://www.frihost.com is a good free host, and they don't have safe mode enabled :)
vpgtd wrote:
after going from page 1 all the way to 10 i saw only one other person with this error and i didn't find any info on it

Fatal error: Class 'SimpleXMLElement' not found in /var/www/localhost/htdocs/pkg/bb3phpkg.php on line 371


plz help
I'm guessing you don't have PHP5 on your webhost?
According to the author, this mod requires PHP5

User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by Renodil » Wed Feb 20, 2008 6:52 am

OK. I got this thing working on my off line test board, but for some reason I don't understand I get this error when placing it on my online one.

Code: Select all

Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/content/P/i/k/Pikachu1/html/forum/pkg/bb3phpkg.php on line 27
Any help would be appreciated. Thanks.

Incidentally. When I try to visit http://pkg.phpbb2.pl/rep.php?mode=show I get the following message and I have no idea what it says. "Usuñ wpisy wymuszaj±ce wersjê php z pliku .htaccess"

One more thing. I just attempted to install a couple of mods on my off line board using it and got the following errors. And yes there is a valid xml file in them.

Code: Select all

[phpBB Debug] PHP Notice: in file /pkg/bb3phpkg.php on line 317: opendir(./../cache/phpkg/pkg/../dir/local_c739508eb1f7a389d493f5e1e8b667fa) [function.opendir]: failed to open dir: Invalid argument
[phpBB Debug] PHP Notice: in file /pkg/bb3phpkg.php on line 319: readdir(): supplied argument is not a valid Directory resource
[phpBB Debug] PHP Notice: in file /pkg/bb3phpkg.php on line 329: opendir(./../cache/phpkg/pkg/../dir/local_c739508eb1f7a389d493f5e1e8b667fa) [function.opendir]: failed to open dir: Invalid argument
[phpBB Debug] PHP Notice: in file /pkg/bb3phpkg.php on line 330: readdir(): supplied argument is not a valid Directory resource
{ pL_KernelPanic }

No valid XML was found!

    * 02:34:09(3): [tar] Unpacking zipfile ./../cache/phpkg/pkg/local_c739508eb1f7a389d493f5e1e8b667fa.zip
    * 02:34:09(3): [sys] SYSTEM CALL:
      cd ./../cache/phpkg/pkg && mkdir ../dir/local_c739508eb1f7a389d493f5e1e8b667fa && cd ../dir/local_c739508eb1f7a389d493f5e1e8b667fa && cp ../../pkg/local_c739508eb1f7a389d493f5e1e8b667fa.zip . && unzip local_c739508eb1f7a389d493f5e1e8b667fa.zip
    * 02:34:10(3): [sys] System reply:
    * 02:34:10(3): [xml] Searching for a XML file in ./../cache/phpkg/pkg/../dir/local_c739508eb1f7a389d493f5e1e8b667fa
Update: Wed Feb 20, 2008 4:50 am
I went ahead and installed the board on a new test MySQL server and without doing anything, but installing the board I went ahead and uploaded the phPKG stuff and added the module and I still get the parse error, so it's nothing to do with any of the mods I already got on there which is what I was hoping was the problem.

User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by Renodil » Sun Mar 02, 2008 3:43 am

Renodil wrote:OK. I got this thing working on my off line test board, but for some reason I don't understand I get this error when placing it on my online one.

Code: Select all

Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/content/P/i/k/Pikachu1/html/forum/pkg/bb3phpkg.php on line 27
Any help would be appreciated. Thanks.

Incidentally. When I try to visit http://pkg.phpbb2.pl/rep.php?mode=show I get the following message and I have no idea what it says. "Usuñ wpisy wymuszaj±ce wersjê php z pliku .htaccess"

One more thing. I just attempted to install a couple of mods on my off line board using it and got the following errors. And yes there is a valid xml file in them.

Code: Select all

[phpBB Debug] PHP Notice: in file /pkg/bb3phpkg.php on line 317: opendir(./../cache/phpkg/pkg/../dir/local_c739508eb1f7a389d493f5e1e8b667fa) [function.opendir]: failed to open dir: Invalid argument
[phpBB Debug] PHP Notice: in file /pkg/bb3phpkg.php on line 319: readdir(): supplied argument is not a valid Directory resource
[phpBB Debug] PHP Notice: in file /pkg/bb3phpkg.php on line 329: opendir(./../cache/phpkg/pkg/../dir/local_c739508eb1f7a389d493f5e1e8b667fa) [function.opendir]: failed to open dir: Invalid argument
[phpBB Debug] PHP Notice: in file /pkg/bb3phpkg.php on line 330: readdir(): supplied argument is not a valid Directory resource
{ pL_KernelPanic }

No valid XML was found!

    * 02:34:09(3): [tar] Unpacking zipfile ./../cache/phpkg/pkg/local_c739508eb1f7a389d493f5e1e8b667fa.zip
    * 02:34:09(3): [sys] SYSTEM CALL:
      cd ./../cache/phpkg/pkg && mkdir ../dir/local_c739508eb1f7a389d493f5e1e8b667fa && cd ../dir/local_c739508eb1f7a389d493f5e1e8b667fa && cp ../../pkg/local_c739508eb1f7a389d493f5e1e8b667fa.zip . && unzip local_c739508eb1f7a389d493f5e1e8b667fa.zip
    * 02:34:10(3): [sys] System reply:
    * 02:34:10(3): [xml] Searching for a XML file in ./../cache/phpkg/pkg/../dir/local_c739508eb1f7a389d493f5e1e8b667fa
Update: Wed Feb 20, 2008 4:50 am
I went ahead and installed the board on a new test MySQL server and without doing anything, but installing the board I went ahead and uploaded the phPKG stuff and added the module and I still get the parse error, so it's nothing to do with any of the mods I already got on there which is what I was hoping was the problem.
Why isn't anyone help me? :cry:

manofgames
Registered User
Posts: 36
Joined: Mon Mar 19, 2007 9:02 pm

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by manofgames » Sun Mar 02, 2008 4:15 pm

Renodil wrote:
Renodil wrote:OK. I got this thing working on my off line test board, but for some reason I don't understand I get this error when placing it on my online one.

Code: Select all

Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/content/P/i/k/Pikachu1/html/forum/pkg/bb3phpkg.php on line 27
If you read the author's first post, you would see that they have already answered this question - your host does not have PHP 5, and this mod needs php 5.
The line in question has a PHP keyword which is only available in PHP 5 + .

The second problem seems to be related to the script not being able to access the PHPKG cache files (Out of interest, are you uploading the mod files :? ).
Check that there is a folder called phpkg in your /cache folder, that would be a good place to start.

devinliao
Registered User
Posts: 92
Joined: Wed Jun 29, 2005 1:58 am

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by devinliao » Mon Mar 03, 2008 6:50 am

WoW, I've just tried it, it worked, just need to test out other mods.
Too bad not all work.

nalioth
Registered User
Posts: 7
Joined: Wed Mar 05, 2008 3:22 am

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by nalioth » Wed Mar 05, 2008 3:29 am

Howdy

I'm using PHPBB3 v 3.0.0 and I've followed
Dabroz wrote:You have to add phPKG module. Go to ACP :arrow: “SYSTEM” tab :arrow: Module management :arrow: Administration Control Panel. Then add phPKG (ACP_PHPKG) to desired page (I think that it best fits into SYSTEM/AUTOMATION). Then you will have to enable it (by clicking “Enable” ;) ). It's all.
and I have yet to see ACP_PHPKG as a module to choose. I've verified that I've copied all the files correctly.

Can someone help me out?

User avatar
Highway of Life
Former Team Member
Posts: 6048
Joined: Wed Feb 02, 2005 5:41 pm
Location: Spokane, WA
Name: David Lewis
Contact:

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by Highway of Life » Sun Mar 23, 2008 4:33 am

nalioth wrote:Howdy

I'm using PHPBB3 v 3.0.0 and I've followed
Dabroz wrote:You have to add phPKG module. Go to ACP :arrow: “SYSTEM” tab :arrow: Module management :arrow: Administration Control Panel. Then add phPKG (ACP_PHPKG) to desired page (I think that it best fits into SYSTEM/AUTOMATION). Then you will have to enable it (by clicking “Enable” ;) ). It's all.
and I have yet to see ACP_PHPKG as a module to choose. I've verified that I've copied all the files correctly.

Can someone help me out?
As long as you copied a file to the /includes/acp/info/ directory, it should show up in the top of the two drop down menus on the Module Management Screen.
Look through there and it may be something like ACP_PHPKG but maybe not exactly due to it being a language variable. (phPKG)
The phpBB Weekly Podcast - Discussing the developments of phpBB4 and beyond.

New to phpBB3? Want to learn about programing?
Visit phpBB Academy at StarTrekGuide to learn how.

nalioth
Registered User
Posts: 7
Joined: Wed Mar 05, 2008 3:22 am

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by nalioth » Thu Mar 27, 2008 7:13 am

It's me again, Margaret.

I have verified that all the files are in place, and have found the module thingy I was overlooking in my previous post.

I am not sure why, but I don't see any sign of this mod being enabled after I set it up and enable it. Is there some way to 'restart the forum' or something?

I can't see the phPKG link on my ACP anywhere (like is shown in this picture). http://upload.scythe.pl/files/php-pkg3-001.jpg

Thanks

P.S. Does anyone ever go to irc?

User avatar
Highway of Life
Former Team Member
Posts: 6048
Joined: Wed Feb 02, 2005 5:41 pm
Location: Spokane, WA
Name: David Lewis
Contact:

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by Highway of Life » Thu Mar 27, 2008 6:49 pm

Check to see where you added the module in the Module Management, then be sure it’s enabled.
As long as it’s enabled, it will be visible, but only in the location where you added it. :)

I’m always available on Freenode channel #phpbb-mod (not #phpbb) as Highway_of_Life :)
The phpBB Weekly Podcast - Discussing the developments of phpBB4 and beyond.

New to phpBB3? Want to learn about programing?
Visit phpBB Academy at StarTrekGuide to learn how.

aix59
Registered User
Posts: 6
Joined: Mon Jan 21, 2008 1:35 am

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by aix59 » Sun Apr 13, 2008 8:57 pm

This mod looks really nice. I have one suggestion. Sometimes, mods have template specific template changes, and they have different modx xml files for each supported template in the /templates folder of the archive. Will there be an option to pick the modx file to install from the archive?

This is like the "EasyMod" of phpBB3 but with more features ;)

User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by Renodil » Mon Apr 21, 2008 11:10 pm

I got my host to update my php to 5 and now I get this error.

[phpBB Debug] PHP Notice: in file /includes/acp/acp_phpkg.php on line 51: acp_phpkg::include(./../pkg/bb3phpkg.php) [function.acp-phpkg-include]: failed to open stream: No such file or directory
[phpBB Debug] PHP Notice: in file /includes/acp/acp_phpkg.php on line 51: acp_phpkg::include() [function.include]: Failed opening './../pkg/bb3phpkg.php' for inclusion (include_path='.:/usr/local/php5/lib/php')

Fatal error: Class 'BB3phPKG' not found in /home/content/P/i/k/Pikachu1/html/forum/includes/acp/acp_phpkg.php on line 52

User avatar
PCGUY112887
Registered User
Posts: 499
Joined: Thu Apr 01, 2004 12:39 am
Location: Illinois
Contact:

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by PCGUY112887 » Thu Apr 24, 2008 3:19 am

I'm getting this error when I try to update the repository...
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: Entity: line 1: parser error : Opening and ending tag mismatch: META line 1 and head
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: ml><head><META http-equiv="content-type" content="text/html; ISO-8859-2"></head>
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: ^
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: Entity: line 1: parser error : Input is not proper UTF-8, indicate encoding ! Bytes: 0xF1 0x20 0x77 0x70
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: <META http-equiv="content-type" content="text/html; ISO-8859-2"></head><body>Usu
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: ^
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: Entity: line 1: parser error : Opening and ending tag mismatch: head line 1 and html
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: "></head><body>Usuñ wpisy wymuszaj±ce wersjê php z pliku .htaccess</body></html>
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: ^
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: Entity: line 1: parser error : Premature end of data in tag html line 1
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: "></head><body>Usuñ wpisy wymuszaj±ce wersjê php z pliku .htaccess</body></html>
[phpBB Debug] PHP Notice: in file /pkg/phpkg.php on line 540: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: ^

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /home/theopiac/public_html/secret/pkg/phpkg.php:540 Stack trace: #0 /home/theopiac/public_html/secret/pkg/phpkg.php(540): SimpleXMLElement->__construct('<html><head><ME...') #1 /home/theopiac/public_html/secret/includes/acp/acp_phpkg.php(549): phPKG->pkg_update(1, 'http://pkg.phpb...', '0', NULL, 0, 0) #2 /home/theopiac/public_html/secret/includes/acp/acp_phpkg.php(84): acp_phpkg->action_update(1) #3 /home/theopiac/public_html/secret/includes/functions_module.php(471): acp_phpkg->main('phpkg', 'main') #4 /home/theopiac/public_html/secret/adm/index.php(74): p_master->load_active() #5 {main} thrown in /home/theopiac/public_html/secret/pkg/phpkg.php on line 540

User avatar
PCGUY112887
Registered User
Posts: 499
Joined: Thu Apr 01, 2004 12:39 am
Location: Illinois
Contact:

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by PCGUY112887 » Fri Apr 25, 2008 4:26 am

Also, a bug found.

In this mod
http://www.phpbb.com/community/viewtopi ... 0&t=780735

There are 2 edits that happen to includes/acp/acp_board.php both of these edits screw up what should/should not be commented out (it moves text onto the wrong lines), thus breaking the mod. The rest of it seemed to work however!

starwar
Registered User
Posts: 99
Joined: Tue Nov 21, 2006 7:22 pm

Re: [BETA] phPKG - MOD installer with repositories & packages

Post by starwar » Fri Apr 25, 2008 11:55 am

File Copy

Copy: root/adm/style/acp_phpkg_main.html
To: adm/style/acp_phpkg_main.html

Copy: root/pkg/bb3phpkg.php
To: pkg/bb3phpkg.php

Copy: root/pkg/class/log.php
To: pkg/class/log.php

Copy: root/pkg/class/fgc.php
To: pkg/class/fgc.php

Copy: root/pkg/class/bb3lang.php
To: pkg/class/bb3lang.php

Copy: root/pkg/class/tar_command.php
To: pkg/class/tar_command.php

Copy: root/pkg/class/ftp.php
To: pkg/class/ftp.php

Copy: root/pkg/class/tar_class.php
To: pkg/class/tar_class.php

Copy: root/pkg/phpkg.php
To: pkg/phpkg.php

Copy: root/includes/acp/info/acp_phpkg.php
To: includes/acp/info/acp_phpkg.php

Copy: root/includes/acp/acp_phpkg.php
To: includes/acp/acp_phpkg.php

Copy: root/language/en/acp/phpkg.php
To: language/en/acp/phpkg.php

Copy: root/pkg/images2/stock_internet.png
To: pkg/images2/stock_internet.png

Copy: root/pkg/images2/stock_history.png
To: pkg/images2/stock_history.png

Copy: root/pkg/images2/stock_search.png
To: pkg/images2/stock_search.png

Copy: root/pkg/images2/stock_mailto.png
To: pkg/images2/stock_mailto.png

Copy: root/pkg/images2/stock_accessories.png
To: pkg/images2/stock_accessories.png

Copy: root/pkg/images2/stock_convert.png
To: pkg/images2/stock_convert.png

Copy: root/pkg/images2/stock_about.png
To: pkg/images2/stock_about.png

Copy: root/pkg/sql/default.sql
To: pkg/sql/default.sql

Copy: root/pkg/sql/mysql41.sql
To: pkg/sql/mysql41.sql
i did all these steps
but it don't appear anything in my ACP
I also refresh templates,prosilver

please help me

Locked

Return to “[3.0.x] MODs in Development”