[RC] lastRSS agregator 2.0.0RC

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Ideas Centre
Locked
User avatar
deanandeva
Registered User
Posts: 138
Joined: Fri May 30, 2008 12:11 pm
Location: Australia
Contact:

Re: [RC] lastRSS agregator 2.0.0RC

Post by deanandeva »

Hi Smix,

Thanks again,

I replaced my overall_header.html with a backup version, I could not see any RSS edits in it anyway ?

The problem still persists, I have refreshed the templates.

Your link to Validator.w3.org show errors in http://www.discussuc.com/viewforum.php?f=12, how is this related to over header ?

So now that we have completely removed all edits, what should I try next.
Remove all files related to RSS?
What does the contrib/install.php do, does it create changes that I need to undo?


Thanks for your help, below is Overall_header.html

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">
<head>

<meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />
<meta http-equiv="content-style-type" content="text/css" />
<meta http-equiv="content-language" content="{S_USER_LANG}" />
<meta http-equiv="imagetoolbar" content="no" />
<meta name="resource-type" content="document" />
<meta name="distribution" content="global" />
<meta name="copyright" content="2000, 2002, 2005, 2007 phpBB Group" />
<meta name="keywords" content="" />
<meta name="description" content="" />
{META}
<title>{SITENAME} &bull; <!-- IF S_IN_MCP -->{L_MCP} &bull; <!-- ELSEIF S_IN_UCP -->{L_UCP} &bull; <!-- ENDIF -->{PAGE_TITLE}</title>

<!--
	phpBB style name: prosilver
	Based on style:   prosilver (this is the default phpBB3 style)
	Original author:  Tom Beddard ( http://www.subBlue.com/ )
	Modified by:      
	
	NOTE: This page was generated by phpBB, the free open-source bulletin board package.
	      The phpBB Group is not responsible for the content of this page and forum. For more information
	      about phpBB please visit http://www.phpbb.com
-->

<script type="text/javascript">
// <![CDATA[
	var jump_page = '{LA_JUMP_PAGE}:';
	var on_page = '{ON_PAGE}';
	var per_page = '{PER_PAGE}';
	var base_url = '{A_BASE_URL}';
	var style_cookie = 'phpBBstyle';
	var onload_functions = new Array();
	var onunload_functions = new Array();

	<!-- IF S_USER_PM_POPUP -->
		if ({S_NEW_PM})
		{
			var url = '{UA_POPUP_PM}';
			window.open(url.replace(/&/g, '&'), '_phpbbprivmsg', 'height=225,resizable=yes,scrollbars=yes, width=400');
		}
	<!-- ENDIF -->

	/**
	* Find a member
	*/
	function find_username(url)
	{
		popup(url, 760, 570, '_usersearch');
		return false;
	}

	/**
	* New function for handling multiple calls to window.onload and window.unload by pentapenguin
	*/
	window.onload = function()
	{
		for (var i = 0; i < onload_functions.length; i++)
		{
			eval(onload_functions[i]);
		}
	}

	window.onunload = function()
	{
		for (var i = 0; i < onunload_functions.length; i++)
		{
			eval(onunload_functions[i]);
		}
	}

// ]]>
</script>
<script type="text/javascript" src="{T_TEMPLATE_PATH}/styleswitcher.js"></script>
<script type="text/javascript" src="{T_TEMPLATE_PATH}/forum_fn.js"></script>

<link href="{T_THEME_PATH}/print.css" rel="stylesheet" type="text/css" media="print" title="printonly" />
<link href="{T_STYLESHEET_LINK}" rel="stylesheet" type="text/css" media="screen, projection" />

<link href="{T_THEME_PATH}/normal.css" rel="stylesheet" type="text/css" title="A" />
<link href="{T_THEME_PATH}/medium.css" rel="alternate stylesheet" type="text/css" title="A+" />
<link href="{T_THEME_PATH}/large.css" rel="alternate stylesheet" type="text/css" title="A++" />

<!-- IF S_CONTENT_DIRECTION eq 'rtl' -->
	<link href="{T_THEME_PATH}/bidi.css" rel="stylesheet" type="text/css" media="screen, projection" />
<!-- ENDIF -->

</head>
<!-- INCLUDE ads/ads.js -->
<body id="phpbb" class="section-{SCRIPT_NAME} {S_CONTENT_DIRECTION}">

<div id="wrap">
	<a id="top" name="top" accesskey="t"></a>
	<div id="page-header">
{ADS_1}
		<div class="headerbar">
			<div class="inner"><span class="corners-top"><span></span></span>
    <div style="height: 170px ;">
			<div id="site-description">
			
			
				<p style="display: none;"><a href="#start_here">{L_SKIP}</a></p>
			</div>
     		

			<span class="corners-bottom"><span></span></span></div>
		</div>
		</div>
<!-- IF not $S_IN_PORTAL or not S_DISPLAY_MAINMENU -->

		<div class="navbar">
			<div class="inner"><span class="corners-top"><span></span></span>

			<ul class="linklist navlinks">
				<li class="icon-home"><a href="{U_PORTAL}">{L_PORTAL}</a> &#187; 
<a href="{U_INDEX}" accesskey="h">{L_INDEX}</a> <!-- BEGIN navlinks --> <strong>&#8249;</strong> <a href="{navlinks.U_VIEW_FORUM}">{navlinks.FORUM_NAME}</a><!-- END navlinks --></li>

				<li class="rightside"><a href="#" onclick="fontsizeup(); return false;" onkeypress="fontsizeup(); return false;" class="fontsize" title="{L_CHANGE_FONT_SIZE}">{L_CHANGE_FONT_SIZE}</a></li>

				<!-- IF U_EMAIL_TOPIC --><li class="rightside"><a href="{U_EMAIL_TOPIC}" title="{L_EMAIL_TOPIC}" class="sendemail">{L_EMAIL_TOPIC}</a></li><!-- ENDIF -->
				<!-- IF U_EMAIL_PM --><li class="rightside"><a href="{U_EMAIL_PM}" title="{L_EMAIL_PM}" class="sendemail">{L_EMAIL_PM}</a></li><!-- ENDIF -->
				<!-- IF U_PRINT_TOPIC --><li class="rightside"><a href="{U_PRINT_TOPIC}" title="{L_PRINT_TOPIC}" accesskey="p" class="print">{L_PRINT_TOPIC}</a></li><!-- ENDIF -->
				<!-- IF U_PRINT_PM --><li class="rightside"><a href="{U_PRINT_PM}" title="{L_PRINT_PM}" accesskey="p" class="print">{L_PRINT_PM}</a></li><!-- ENDIF -->
			</ul>

			<!-- IF not S_IS_BOT and S_USER_LOGGED_IN -->
			<ul class="linklist leftside">
				<li class="icon-ucp">
					<a href="{U_PROFILE}" title="{L_PROFILE}" accesskey="u">{L_PROFILE}</a>
						<!-- IF S_DISPLAY_PM --> (<a href="{U_PRIVATEMSGS}">{PRIVATE_MESSAGE_INFO}</a>)<!-- ENDIF --> &bull; 
					<a href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a>
					<!-- IF U_RESTORE_PERMISSIONS --> &bull;
					<a href="{U_RESTORE_PERMISSIONS}">{L_RESTORE_PERMISSIONS}</a>
					<!-- ENDIF -->
				</li>
			</ul>
			<!-- ENDIF -->

			<ul class="linklist rightside">
				<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
				<!-- IF not S_IS_BOT -->
					<!-- IF S_DISPLAY_MEMBERLIST --><li class="icon-members"><a href="{U_MEMBERLIST}" title="{L_MEMBERLIST_EXPLAIN}">{L_MEMBERLIST}</a></li><!-- ENDIF -->
					<!-- IF not S_USER_LOGGED_IN and S_REGISTER_ENABLED --><li class="icon-register"><a href="{U_REGISTER}">{L_REGISTER}</a></li><!-- ENDIF -->
					<li class="icon-logout"><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="l">{L_LOGIN_LOGOUT}</a></li>
				<!-- ENDIF -->
			</ul>

			<span class="corners-bottom"><span></span></span></div>
		</div>
<!-- ENDIF -->

	</div>

<!-- IF not S_IN_PORTAL -->
{ADS_2}
    
	<a name="start_here"></a>
	<div id="page-body">
		
		 <!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) --> 
		<div id="message" class="rules">
			<div class="inner"><span class="corners-top"><span></span></span>
				<strong>{L_INFORMATION}:</strong> {L_BOARD_DISABLED}
			<span class="corners-bottom"><span></span></span></div>
		</div>
		<!-- ENDIF -->
		<!-- ENDIF -->

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [RC] lastRSS agregator 2.0.0RC

Post by Smix »

If your xHTML code is not valid, it´s very hard or almost impossible to find the problem - because it can be related to the xHTML code invalidity ... I already saw many very similar problems like that, which was caused by xHTML invalidity and browser´s core was not able to fix it ...

I really don´t know, why you have problems after installing my mod, but there is nothing changed in the style and it´s (IMHO) unrelated to my mod :( . Try to fix the xHTML code invalidity and than we´ll have a look again.

User avatar
deanandeva
Registered User
Posts: 138
Joined: Fri May 30, 2008 12:11 pm
Location: Australia
Contact:

Re: [RC] lastRSS agregator 2.0.0RC

Post by deanandeva »

Hi Smix,
I have had a look again at validator.w3.org / http://www.discussuc.com/viewforum.php?f=12 but when I open viewforum.php the lines / errors don't appear to be there, is there a particular files I should be trying to trace the errors to?

What does the contrib/install.php do, does it create changes that I need to undo?

Sorry I just dont know where to strat short of reloading a new board

Thnaks


Dean

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [RC] lastRSS agregator 2.0.0RC

Post by Smix »

Hello,

contrib/install.php makes necessary SQL queries for installing/updating the mod. There is nothing necessary to remove if you wan´t to reinstall the mod and no more run of contrib/install.php is required - it´s unable to run the install file again - it stops at the beginning ;)

And about your style problems - you are searching the HTML errors shown by validator in the viewforum.php file? You have to edit the templates in /styles/your_style_name/template_file.html ;)
You may ask your webdesigner (author of your specific discussUC style - I know it´s prosilver based, but prosilver is valid xHTML so your problems are not related to original prosilver style) for help.

User avatar
deanandeva
Registered User
Posts: 138
Joined: Fri May 30, 2008 12:11 pm
Location: Australia
Contact:

Re: [RC] lastRSS agregator 2.0.0RC

Post by deanandeva »

Hi Smix,

Replaced my whole template folder with one I had backed up a month ago, thankfully it worked !!!,

Appreciate your help, I'm very relieved.

zelnik44
Registered User
Posts: 40
Joined: Fri May 30, 2008 4:53 pm

Re: [RC] lastRSS agregator 2.0.0RC

Post by zelnik44 »

Smix wrote:Hello,

4 zelnik44 :
I was battling with this since the mod was released, please try RC2 pre-release files ...
Just thought I'd update you,installed new files, flushed cache and some of the characters are now working!!!

There are a few that are not I think one being either ' or ` but a lot of the other ones that were not are now working, thanks!

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [RC] lastRSS agregator 2.0.0RC

Post by Smix »

Thanks for your report ;-) I´ll fix it before releasing the RC2 version and I´ll contact you with PM with more info - and you can check it first ;-)

User avatar
deanandeva
Registered User
Posts: 138
Joined: Fri May 30, 2008 12:11 pm
Location: Australia
Contact:

Re: [RC] lastRSS agregator 2.0.0RC

Post by deanandeva »

Hi Smix,

Now that everything is working again I have re-installed autoposting bot. Hopefully al wil go well this time.

I have a question for you.

Do you know of site where you can get a custom feed generated for you?, i have seen some such as Rssground.com. But wondering if you have used these before and any recommendations. I need a feed on a very niche industry and may need to have one specifically made.

Appreciate your thoughts

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [RC] lastRSS agregator 2.0.0RC

Post by Smix »

Hello,

good to hear that works :) ...

And about your question - no, I didn´t used any special feeds generators that you are speaking about ...

joebart72
Registered User
Posts: 743
Joined: Thu Feb 01, 2007 5:54 am

Re: [RC] lastRSS agregator 2.0.0RC

Post by joebart72 »

Hello,

I've a trouble with PrototypeV2 (SubSilver 2 style) :

Look :

Image

Impossible to see the title...

All is flattened...

Edit : Ok, you forgot to include ton include the part with {LASTRSS_TITLE}

And there is a javascript error in root/javascript :

Code: Select all

this.messages  = $A(this.container.getElementsByTagName("li"));
I learn English with phpbb.com :)

Fridge
Registered User
Posts: 307
Joined: Sat Nov 11, 2006 1:41 am
Location: Rotterdam, The Netherlands
Name: Martin
Contact:

Re: [RC] lastRSS agregator 2.0.0RC

Post by Fridge »

I'm using this mod for quite a while now and still lovin' it :)

The version used on my board is 2.0.BETA1 and works without any problem on phpBB v3.0.2, so what i really want to know is.....do i need to upgrade the mod and are there upgrade instructions for my version to current ?

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [RC] lastRSS agregator 2.0.0RC

Post by Smix »

Hello,

4 JoeBart72 :

:oops: oopsie :roll: ... I´ll check it :!: Thank you for report ... ;)


4 Fridge :

:) You are the lucky "one" (as at least 90% of users of my mod I think), because it´s working on your server ...
From Beta 1 there is many changes (in core) and possible update can be done by simple copying new files over the old ones ( but for sure check the edits again please ) and run the update script ... The only visible changes are in style (prosilver/subsilver2) - marquee has been replaced by javascript newsticker ...

I´m giving support only for the latest version of the mod ... (so update is recommended ;) )
Last edited by Smix on Wed Jul 23, 2008 8:19 am, edited 1 time in total.

Fridge
Registered User
Posts: 307
Joined: Sat Nov 11, 2006 1:41 am
Location: Rotterdam, The Netherlands
Name: Martin
Contact:

Re: [RC] lastRSS agregator 2.0.0RC

Post by Fridge »

Smix wrote:I´m giving support only for the latest version of the mod ... (so update is recommended ;) )
Thnx for your answer.....will look into it asap ;)

User avatar
soaknfused
Registered User
Posts: 134
Joined: Wed Apr 26, 2006 9:02 pm
Location: WI

Re: [RC] lastRSS agregator 2.0.0RC

Post by soaknfused »

just installed this MOD... install went well, only problem I have is when I enable the mod and try to go to my forum index page I just get a blank, completely empty screen... Anyone had this happen before? I have checked my edits a dozen times and all that, database entries seem to be in order... disabling it makes everything operate normally. I also have your lastrss autopost mod installed as well. I'm open to ideas...

PS. I tried removing the edits from index_body.html, viewforum_body.html, and viewtopic_body.html and still get the same issue

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [RC] lastRSS agregator 2.0.0RC

Post by Smix »

Hello,

if you´ve got both mods installed, please check out that all edits done while installing the bot mod are placed after the agregator´s edits ... Also check phpinfo() if you´ve got CURL/FOPEN available on your server ...

Locked

Return to “[3.0.x] MODs in Development”