[RC] phpBB Gallery 1.0.4 (including TS Gallery converter)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Ideas Centre
shahinavthal
Registered User
Posts: 277
Joined: Fri Sep 19, 2008 6:53 am

Re: [Beta] phpBB Gallery 0.4.1

Post by shahinavthal »

^^ Looks like a permission issue..please check if the group your user id belongs have been given proper permissions (to view images and/or to upload images.number of images etc)...If your userid belongs to multiple groups(like admin,mod etc) make sure that the permissions are set to either to " Yes/NO" and not "NEVER"
primetime33
Registered User
Posts: 66
Joined: Sat Nov 15, 2008 6:15 am

Re: [Beta] phpBB Gallery 0.4.1

Post by primetime33 »

If I can view, post pics in the forums/topics, shouldnt I be able to view them in the gallery?

the album permissions are also set for registered users to allow to view, upload, comment, rate etc.
primetime33
Registered User
Posts: 66
Joined: Sat Nov 15, 2008 6:15 am

Re: [Beta] phpBB Gallery 0.4.1

Post by primetime33 »

I think I will just uninstall this "MOD" until its more stable and/or has better support. It is BETA after all.
wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: [Beta] phpBB Gallery 0.4.1

Post by wolfman24 »

primetime33 wrote:I think I will just uninstall this "MOD" until its more stable and/or has better support. It is BETA after all.
More stable? Better Support? Come on, you are joking. This is one of the stablest complex mods out there and the support from nickvergessen ist very good. But he may also take some days off, so what?
primetime33
Registered User
Posts: 66
Joined: Sat Nov 15, 2008 6:15 am

Re: [Beta] phpBB Gallery 0.4.1

Post by primetime33 »

wolfman24 wrote:
primetime33 wrote:I think I will just uninstall this "MOD" until its more stable and/or has better support. It is BETA after all.
More stable? Better Support? Come on, you are joking. This is one of the stablest complex mods out there and the support from nickvergessen ist very good. But he may also take some days off, so what?
And your point is?
User avatar
grotevoet
Registered User
Posts: 32
Joined: Wed Apr 19, 2006 7:56 pm

Re: [Beta] phpBB Gallery 0.4.1

Post by grotevoet »

primetime33 wrote:And your point is?
I think Wolfmans point is that you reported an issue just 2 days ago, during a normal school/work week, and without a response from the creator you're already complaining that the MOD is bad. Please note that a large group of people is very happy with the MOD in it's current state, and the support NickVergessen is giving *for free* both here and on his own site is very good.

Solving your issue may be a simple task, but there is not much we can do for you with some more data; I had a quick look at you forum + gallery; for me (as guest) it shows with "no images in this album" - do you have a test account I could use so I could see what a registered user would see, or (temporarely) allow Guests to view the images? That might help in identifying possible causes.

BTW: I noticed that you have the load statements for both LightBox and Lytebox before the <head> statement, and these should be on lines somewhere between the <head> and </head> tags.

Regards,
Marc
Image
primetime33
Registered User
Posts: 66
Joined: Sat Nov 15, 2008 6:15 am

Re: [Beta] phpBB Gallery 0.4.1

Post by primetime33 »

grotevoet wrote:
primetime33 wrote:And your point is?
I think Wolfmans point is that you reported an issue just 2 days ago, during a normal school/work week, and without a response from the creator you're already complaining that the MOD is bad. Please note that a large group of people is very happy with the MOD in it's current state, and the support NickVergessen is giving *for free* both here and on his own site is very good.

Solving your issue may be a simple task, but there is not much we can do for you with some more data; I had a quick look at you forum + gallery; for me (as guest) it shows with "no images in this album" - do you have a test account I could use so I could see what a registered user would see, or (temporarely) allow Guests to view the images? That might help in identifying possible causes.

BTW: I noticed that you have the load statements for both LightBox and Lytebox before the <head> statement, and these should be on lines somewhere between the <head> and </head> tags.

Regards,
Marc
Thank you Mark for the reply. I will uninstall this MOD and do a reinstall first. After the reinstallation, I will post a reply. I am not saying that this MOD is bad at all. As I stated in my original post, I DO understand that this is a BETA Release.

Thank you,
Prime
primetime33
Registered User
Posts: 66
Joined: Sat Nov 15, 2008 6:15 am

Re: [Beta] phpBB Gallery 0.4.1

Post by primetime33 »

I also get this error when accessing the gallery/index.php

Code: Select all

[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 127: Undefined offset: 0
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 127: Undefined index: album_images
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 128: Undefined index: album_images_real
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 130: Undefined index: album_last_image_time
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 159: Undefined index: parent_id
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 159: Undefined index: album_type
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 163: Undefined index: album_id
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 164: Undefined index: album_name
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 165: Undefined index: album_desc
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 165: Undefined index: album_desc_uid
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 165: Undefined index: album_desc_bitfield
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 165: Undefined index: album_desc_options
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 168: Undefined index: album_image
[phpBB Debug] PHP Notice: in file /gallery/includes/functions_display.php on line 169: Undefined index: album_id
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3873: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3202)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3875: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3202)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3876: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3202)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3877: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3202)
primetime33
Registered User
Posts: 66
Joined: Sat Nov 15, 2008 6:15 am

Re: [Beta] phpBB Gallery 0.4.1

Post by primetime33 »

Alright!!! I think I have it installed ok now. Thank you for pointing out the lightbox error. That was the problem and also did a reinstall of the tables and looks like all is ok now.
shahinavthal
Registered User
Posts: 277
Joined: Fri Sep 19, 2008 6:53 am

Re: [Beta] phpBB Gallery 0.4.1

Post by shahinavthal »

Also please remember that there is Nick's dedicated support site for all his MODs ... You can avail free & quicker support at http://www.flying-bits.org
catwalkchaos
Registered User
Posts: 34
Joined: Fri Jan 02, 2009 2:51 am

Re: [Beta] phpBB Gallery 0.4.1

Post by catwalkchaos »

I didn't realise this was a beta until after I attempted to install this :o is this bad?

www.catwalkchaos.com/forum is the site

I have just tried to install this but get this error:

Parse error: syntax error, unexpected T_DOUBLE_ARROW in /home/catwalk/public_html/forum/includes/session.php on line 134

I took a look at it on line 134 and I had made a mistake but fixed it, reuploaded but its still coming up as that.

This is my line 134:
'album' => (isset($_REQUEST['album_id']) && $_REQUEST['album_id'] > 0) ? (int) $_REQUEST['album_id'] : 0,

whats wrong with it?
catwalkchaos
Registered User
Posts: 34
Joined: Fri Jan 02, 2009 2:51 am

Re: [Beta] phpBB Gallery 0.4.1

Post by catwalkchaos »

Ignore that, works now i cleared my cache ;)
Spyroboy
Registered User
Posts: 14
Joined: Fri Dec 12, 2008 9:24 pm

Re: [Beta] phpBB Gallery 0.4.1

Post by Spyroboy »

Fatal error: Call to a member function bbcode_second_pass() on a non-object in /home/a8868506/public_html/forum/gallery/image_page.php on line 409


I can view the images just fine, but after someone comments and you click on the image to view the comments this pops up? I have no idea on how to fix it. I use gallery v0.4.0 (Link on download page- phpbb_gallery_0_4_0.zip)


Can someone please help me :cry:
wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: [Beta] phpBB Gallery 0.4.1

Post by wolfman24 »

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by nickvergessen »

Spyroboy wrote:Fatal error: Call to a member function bbcode_second_pass() on a non-object in /home/a8868506/public_html/forum/gallery/image_page.php on line 409


I can view the images just fine, but after someone comments and you click on the image to view the comments this pops up? I have no idea on how to fix it. I use gallery v0.4.0 (Link on download page- phpbb_gallery_0_4_0.zip)


Can someone please help me :cry:
You should update to 0.4.1!
No Support via PM
Locked

Return to “[3.0.x] MODs in Development”