[RC] phpBB Gallery 1.0.4 (including TS Gallery converter)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
User avatar
novanilla
Registered User
Posts: 332
Joined: Wed Jul 02, 2008 1:08 pm
Location: Colorado
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by novanilla »

I am updating from 0.4.0 RC2 to 0.4.1.

I am doing all the file updates for the three steps, uploading ALL files (edited and new), and running the install script in update mode. I get through the writeability checks (step 1). I get through the update files step (step 2). I click to update database, and get this error:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Column 'config_value' cannot be null [1048]

SQL

INSERT INTO phpbb3_gallery_config (config_name, config_value) VALUES ('link_imagepage', NULL)

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: install/install_functions.php
LINE: 190
CALL: dbal_mysqli->sql_query()

FILE: install/install_update.php
LINE: 738
CALL: set_gallery_config()

FILE: install/install_update.php
LINE: 77
CALL: install_update->update_db_data()

FILE: install/index.php
LINE: 188
CALL: install_update->main()

FILE: install/index.php
LINE: 60
CALL: module->load()
 
Please help! Every time I do this, I have to restore my database and replace all my files again. It's getting tiresome. I'll ask again - do I have to do all three update steps one at a time? Where do I find three separate sets of updated files, if that's what I do?

:(
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by nickvergessen »

No Support via PM
User avatar
novanilla
Registered User
Posts: 332
Joined: Wed Jul 02, 2008 1:08 pm
Location: Colorado
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by novanilla »

NV - That's EXCELLENT, I'm sure. Looking at it, it looks like that's my problem... Trouble is, I don't understand German, and I need a little more help.

Can ANYBODY here translate "ersetz die mal mit" for me? I know it's a replace instruction, but what exactly? Specifically, NV said:
nickvergessen wrote:FILE: install/install_update.php
LINE: 738

ersetz die mal mit:

Code: Select all

				if ($gallery_config['link_thumbnail'])
				{
					set_gallery_config('link_imagepage', $gallery_config['link_thumbnail']);
				}
				else
				{
					set_gallery_config('link_imagepage', 'lytebox');
				}
And I don't want to screw this up again. Somebody?

Thanks!
roBBx
Registered User
Posts: 287
Joined: Fri Feb 15, 2008 3:00 am
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by roBBx »

line 738 is:

Code: Select all

set_gallery_config('link_imagepage', $gallery_config['link_thumbnail']);
replace with:

Code: Select all

                if ($gallery_config['link_thumbnail'])
                {
                   set_gallery_config('link_imagepage', $gallery_config['link_thumbnail']);
                }
                else
                {
                   set_gallery_config('link_imagepage', 'lytebox');
                }
;)
User avatar
novanilla
Registered User
Posts: 332
Joined: Wed Jul 02, 2008 1:08 pm
Location: Colorado
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by novanilla »

Thank you, roBBx - I've made enough errors lately to want to be positive. NV helped me on flying-bits.org, as well. Thanks again, NV, for a very slick mod.
axel13
Registered User
Posts: 21
Joined: Tue Jun 03, 2008 7:19 pm

Re: [Beta] phpBB Gallery 0.4.1

Post by axel13 »

Papp wrote:
In step 3, (Copy database-tables), I get this error:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Unknown column 'album_left_id' in 'order clause' [1054]

SQL

SELECT * FROM phpbb_gallery_albums ORDER BY album_user_id, album_left_id ASC

BACKTRACE


FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: install/install_convert_ts.php
LINE: 227
CALL: dbal_mysql->sql_query()

FILE: install/install_convert_ts.php
LINE: 67
CALL: install_convert_ts->copy_schema()

FILE: install/index.php
LINE: 188
CALL: install_convert_ts->main()

FILE: install/index.php
LINE: 60
CALL: module->load()
Any ideas?

Thanks
I have the same problem.

After I run install, it drop my 'phpbb_gallery_albums' and create new.
In new table album_left_id doesn't exist.

What should i do?

And one more question:

Code: Select all

File Copy

Copy: phpBB2-Installation/album_mod/upload/*.* 
To: gallery/images/upload/*.* 
In Ts Gallery album_mod/upload/ have folders: adm, pics, cache. And structure of php gallery not the same. Should I copy files

Code: Select all

Copy: phpBB2-Installation/album_mod/upload/*.* 
To: gallery/images/upload/*.* 
[/code]anyway or pics->upload, etc.
Sorry for my english. It's too bad... :oops:
Papp
Registered User
Posts: 52
Joined: Tue Mar 20, 2007 9:46 am

Re: [Beta] phpBB Gallery 0.4.1

Post by Papp »

I have only tested this in my test forum. I ran up a copy of my TS database tables from my original forum to my test forum / database with the same prefix as your forum. Go not to install, but you should go directly to convert from TS Gallery first, http://www.YOURBOARD.com/install and select convert from TS. After that it worked for me.
axel13 wrote:And one more question:
In Ts Gallery album_mod/upload/ have folders: adm, pics, cache. And structure of php gallery not the same. Should I copy files

Code: Select all

Copy: phpBB2-Installation/album_mod/upload/*.* 
To: gallery/images/upload/*.* 
Yes
I hope you understand my English :-)
axel13
Registered User
Posts: 21
Joined: Tue Jun 03, 2008 7:19 pm

Re: [Beta] phpBB Gallery 0.4.1

Post by axel13 »

Thanks!
But i tried this:
rename my TS tables phpbb3_ -> phpbb_ (change prefix). It doesn't work too...

I'll try it one more...

Oh, my english... :oops:
Papp
Registered User
Posts: 52
Joined: Tue Mar 20, 2007 9:46 am

Re: [Beta] phpBB Gallery 0.4.1

Post by Papp »

About a couple of days, I have plans to install and convert phpBB Gallery 0.4.1 from TS Gallery 2.1 on my live board. Provide feedback after I have finished with it, and what I did. Maybe I translate the language files first, and then it may take a couple of days before I'm done.
I hope you understand my English :-)
axel13
Registered User
Posts: 21
Joined: Tue Jun 03, 2008 7:19 pm

Re: [Beta] phpBB Gallery 0.4.1

Post by axel13 »

Papp wrote:I have only tested this in my test forum. I ran up a copy of my TS database tables from my original forum to my test forum / database with the same prefix as your forum. Go not to install, but you should go directly to convert from TS Gallery first, http://www.YOURBOARD.com/install and select convert from TS. After that it worked for me.
axel13 wrote:And one more question:
In Ts Gallery album_mod/upload/ have folders: adm, pics, cache. And structure of php gallery not the same. Should I copy files

Code: Select all

Copy: phpBB2-Installation/album_mod/upload/*.* 
To: gallery/images/upload/*.* 
Yes
Ok, i tried this and the conversion seemed ok, but in gallery there no images. In ACP in statistic 150 images.... :(


Oo! My mistake..... Permissions for albums....
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by nickvergessen »

axel13 wrote:Thanks!
But i tried this:
rename my TS tables phpbb3_ -> phpbb_ (change prefix). It doesn't work too...

I'll try it one more...

Oh, my english... :oops:
You shouldn't rename them... just leave everything as it is.,..
No Support via PM
flat_webb
Registered User
Posts: 80
Joined: Mon May 12, 2008 4:31 pm
Location: UK

Re: [Beta] phpBB Gallery 0.4.1

Post by flat_webb »

I need a little help please. For some reason my gallery won't allow uploads of image files either to personal albums or albums created via the ACP. I've tried the import function in the ACP and that works for any album as long as it isn't a personal album.

When using the upload button via the gallery (in any album) when I click submit there's a brief pause tehn only a plain white page is displayed (this is using Firefox).

I imagine the issue might permissions related but I can't seem to narrow down where exactly. Any ideas please?

thanks :)
shahinavthal
Registered User
Posts: 277
Joined: Fri Sep 19, 2008 6:53 am

Re: [Beta] phpBB Gallery 0.4.1

Post by shahinavthal »

Please set the permissions of uploadable images for the albums to more than 0.

Also Check if your permissions are conflicting with any of your other group permissions (if you belong to multiple groups)
flat_webb
Registered User
Posts: 80
Joined: Mon May 12, 2008 4:31 pm
Location: UK

Re: [Beta] phpBB Gallery 0.4.1

Post by flat_webb »

shahinavthal wrote:Please set the permissions of uploadable images for the albums to more than 0.
Which directory are you referring to please?
User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by DragonMaster1 »

Just got a BIG error when I check “Take filename as Image-name (the insert-field has no function)“ and then submit:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Duplicate entry '54' for key 1 [1062]

SQL

INSERT INTO phpbb_gallery_users (user_id, user_images) VALUES (54, 0)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: includes/acp/acp_gallery.php
LINE: 396
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_gallery.php
LINE: 90
CALL: acp_gallery->import()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_gallery->main()

FILE: adm/index.php
LINE: 75
CALL: p_master->load_active()
Locked

Return to “[3.0.x] MODs in Development”