[RC] phpBB Gallery 1.0.4 (including TS Gallery converter)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Ideas Centre
retry-later
Registered User
Posts: 3
Joined: Sat May 16, 2009 6:25 pm

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by retry-later »

obiewan wrote:@ retry later:


Did you set the hotlink protection on?
Ah i did yes :( I feel such an idiot.

How do i hotlink protect it to stop other websites from being able to use it apart from mine?
Do i have to add http://subdomain(ifany).domainname.com or can i just add the domainname.com.?
obiewan
Registered User
Posts: 39
Joined: Fri Aug 04, 2006 6:55 pm
Location: The netherlands
Contact:

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by obiewan »

:mrgreen: I haven't figured that out myself... but the hotlinkprotection isn't working correct
retry-later
Registered User
Posts: 3
Joined: Sat May 16, 2009 6:25 pm

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by retry-later »

obiewan wrote::mrgreen: I haven't figured that out myself... but the hotlinkprotection isn't working correct
edit: okay, now its stopped working, i must of not refreshed the page, but yes, hotlinking doesn't work as intended :\

edit: okay, now it works! Just use your main domain. e.g. google.com and it should work.
User avatar
Frejer Stolz
Registered User
Posts: 19
Joined: Wed Jan 07, 2009 11:22 pm

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by Frejer Stolz »

Hallo!

How can I sort the personal albums in gallery 0.4.1?
I'd like to sort them by date (last album update).

I know, you will help me ;)

Thanks for answers!
wreilly
Registered User
Posts: 39
Joined: Thu May 04, 2006 1:02 pm

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by wreilly »

Heads up on getting the "Loading" but nothing happens issue with HighSlide.

This works fine in Prosilver but not in Getaway_Darkblue. Haven’t investigate why yet but to fix it in Getaway

In highslide.css you have these:

url("{T_THEME_PATH}/highslide/graphics/loader.white.gif");

For some reason the {T_THEME_PATH} is not being translated to the actual theme path. "Fix" is to replace {T_THEME_PATH} with the actual path.

It's being read as %7B% T_THEME_PATH %7D%
nomad077
Registered User
Posts: 25
Joined: Sat Mar 28, 2009 7:36 pm

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by nomad077 »

nomad077 wrote:
nickvergessen wrote: I'm not sure, whether a bug like this occured in 0.4.1 but it is not happening in the next version which will come right after 3.0.5
Hi Nick,

thanks for replying.
I did a bit of sleuthing on the codes and somehow manage to get the pagination working.

I checked the ..gallery/includes/function_display.php and found that the pagination was pointing to the personal_number in the album config which i assume is being used to calculate the number of pages.

In my case it was stuck to 3 no matter how much I tried clicking on the resync button for "personal id" in the acp. Somehow it's not updating.

so I manually override the value of "personal_number" in the database to the actual number of personal user albums.

then i can see the pagination now.

a little hitch though,the last user album row in the previous page is always repeated as the first user album row in the next page.

so i'm stuck again but at least solved my first problem, though its manual but it would do for now.

I'll keep checking but would be glad if this will be solved in the next version.

Again thanks for this great mod.

;)
Got it sorted now everything works just right! thanks for this great mod. if the members are happy i am happy :lol:
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by nickvergessen »

nomad077 wrote:I'll keep checking but would be glad if this will be solved in the next version.
like already said, that problem won't happen in the next version
Frejer Stolz wrote:Hallo!

How can I sort the personal albums in gallery 0.4.1?
I'd like to sort them by date (last album update).

I know, you will help me ;)

Thanks for answers!
this is not possible so far
No Support via PM
sTimulated
Registered User
Posts: 91
Joined: Fri Mar 27, 2009 4:16 pm
Contact:

Possible to rename .mod tab in acp?

Post by sTimulated »

Cracking mod,thanks :)

Is it possible to rename the .mod tab in ACP to Gallery?
If so how?

Many thanks

p.s
I did do a search but not find.
Lord Phobos
Registered User
Posts: 616
Joined: Tue May 18, 2004 11:41 pm

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by Lord Phobos »

Hi

I just did the update, and everything was fine.

I have only two problems:

1) I can't see the recent pics in the index. Red crosses. I see them in the Gallery, they are there. But are not showing in the recent pics block in the index. Yes, I have correctly moved the files. I think I can solve this, but...

2) MAJOR problem: it is impossibile to access the Gallery module in ACP. The module is installed and in the right position, enabled. I can see it in the System, in the .Mods section. It simply cannot be viewev nor accessed in any way.

EDIT:

3) The "Gallery" tab in the UCP goes to a blank screen.

Can someone please help?
wreilly
Registered User
Posts: 39
Joined: Thu May 04, 2006 1:02 pm

Re: Possible to rename .mod tab in acp?

Post by wreilly »

sTimulated wrote:Cracking mod,thanks :)

Is it possible to rename the .mod tab in ACP to Gallery?
If so how?

Many thanks

p.s
I did do a search but not find.

It's in the info_acp_gallery.php under language/en/mods
Lord Phobos
Registered User
Posts: 616
Joined: Tue May 18, 2004 11:41 pm

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by Lord Phobos »

Lord Phobos wrote:Hi

I just did the update, and everything was fine.

I have only two problems:

1) I can't see the recent pics in the index. Red crosses. I see them in the Gallery, they are there. But are not showing in the recent pics block in the index. Yes, I have correctly moved the files. I think I can solve this, but...

2) MAJOR problem: it is impossibile to access the Gallery module in ACP. The module is installed and in the right position, enabled. I can see it in the System, in the .Mods section. It simply cannot be viewev nor accessed in any way.

EDIT:

3) The "Gallery" tab in the UCP goes to a blank screen.

Can someone please help?
I have news.

I have solved the problem number 2 by running this query:

Code: Select all

UPDATE phpbb_modules SET module_auth = '' WHERE module_langname = 'ACP_GALLERY_OVERVIEW';
UPDATE phpbb_modules SET module_auth = '' WHERE module_langname = 'ACP_GALLERY_MANAGE_ALBUMS';
UPDATE phpbb_modules SET module_auth = '' WHERE module_langname = 'ACP_GALLERY_CONFIGURE_GALLERY';
UPDATE phpbb_modules SET module_auth = '' WHERE module_langname = 'ACP_GALLERY_ALBUM_PERMISSIONS';
UPDATE phpbb_modules SET module_auth = '' WHERE module_langname = 'ACP_IMPORT_ALBUMS';
UPDATE phpbb_modules SET module_auth = '' WHERE module_langname = 'ACP_GALLERY_CLEANUP';
Now, the module(s) appear correctly.
But, when I click on them, I get the blank screen. And i get this blanck screen when going to the Gallery part in UCP, also.

Anibody can help?
sTimulated
Registered User
Posts: 91
Joined: Fri Mar 27, 2009 4:16 pm
Contact:

Re: Possible to rename .mod tab in acp?

Post by sTimulated »

wreilly wrote:
It's in the info_acp_gallery.php under language/en/mods
Many thanks but I just found another way...

Goto the system tab in the acp and then goto administration control panel in module management.
I just renamed it to Gallery and it worked :)

Is this an exceptable way or will it feck things up?
Everything seems to be ok though so far and Gallery is working perfectly :)
Lord Phobos
Registered User
Posts: 616
Joined: Tue May 18, 2004 11:41 pm

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by Lord Phobos »

My posts are invisible?
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by nickvergessen »

Lord Phobos wrote:My posts are invisible?
No, but some people have jobs in their real-life :P (/me is currently busy with studying)
Lord Phobos wrote:1) I can't see the recent pics in the index. Red crosses. I see them in the Gallery, they are there. But are not showing in the recent pics block in the index. Yes, I have correctly moved the files. I think I can solve this, but...
Please show a Link to your board, if needed a test-account
Lord Phobos wrote:3) The "Gallery" tab in the UCP goes to a blank screen.
please try to re upload the language files (if you edited tehm look to save them with the right collation (UTF8 without BOM)
No Support via PM
Lord Phobos
Registered User
Posts: 616
Joined: Tue May 18, 2004 11:41 pm

Re: [Beta] phpBB Gallery 0.4.1 (including TS Gallery converter)

Post by Lord Phobos »

I took your lang files, opened them with winmerge, compared them to my old (and working) translated by me italian files, and uploaded...

How can I change the collation?
Locked

Return to “[3.0.x] MODs in Development”