[RC] phpBB Gallery 1.0.4 (including TS Gallery converter)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Suggested Hosts
soundshaper
Registered User
Posts: 2
Joined: Tue Feb 17, 2009 8:44 am

Re: [Beta] phpBB Gallery 0.4.1

Post by soundshaper »

New to php, but not to html and css. Can someone tell me what I need to modify in order to allow any file type, any size? I want the gallery to be more of a private file-sharing portal within my small community.
shahinavthal
Registered User
Posts: 277
Joined: Fri Sep 19, 2008 6:53 am

Re: [Beta] phpBB Gallery 0.4.1

Post by shahinavthal »

kateland wrote:http://www.ne-core.com/phpBB3/viewonline.txt

And thanks on the hotlink advice. :)
Please check the edits once again as there are repititions of the same line in the viewonline..For example Lines from 94 & Line 114 are repeitions..i think they got added maybe while pasting the edits...So please make sure there are no mistakes in the edits...

soundshaper wrote:New to php, but not to html and css. Can someone tell me what I need to modify in order to allow any file type, any size? I want the gallery to be more of a private file-sharing portal within my small community.
As the name suggests...it is only for images...as for file size, you could check with your host as to how big the files can be uploaded through your php forum
User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by zake black »

Ok I was thinking the other night. I guess as an idea for an update?? thought id mention it.

The option to tag an image in the gallery against a forum memember? in the same way as you tag a photo on face book.

Thats it.. said id share!
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by nickvergessen »

Seems like your file is out of date.
find:

Code: Select all

// Album info
$sql = 'SELECT *
	FROM ' . GALLERY_ALBUMS_TABLE . '
	ORDER BY left_id ASC';
$result = $db->sql_query($sql, 600);

$album_data = array();
while ($row = $db->sql_fetchrow($result))
{
	$album_data[$row['album_id']] = $row;
}
$db->sql_freeresult($result);

// Nick's Gallery Mod
$recent_image_addon = false;
include("$phpbb_root_path" . GALLERY_ROOT_PATH . "includes/common.$phpEx");
$user->add_lang('mods/gallery');

$db->sql_freeresult($result);

// Album info
$sql = 'SELECT *
	FROM ' . GALLERY_ALBUMS_TABLE . '
	ORDER BY left_id ASC';
$result = $db->sql_query($sql, 600);

$album_data = array();
while ($row = $db->sql_fetchrow($result))
{
	$album_data[$row['album_id']] = $row;
}


$db->sql_freeresult($result);
$recent_image_addon = false;
include("$phpbb_root_path" . GALLERY_ROOT_PATH . "includes/common.$phpEx");
$user->add_lang('mods/gallery');
and replace with

Code: Select all

// Album info
$gallery_root_path = GALLERY_ROOT_PATH;
$recent_image_addon = false;
include_once("{$phpbb_root_path}{$gallery_root_path}includes/common.$phpEx");
include_once("{$phpbb_root_path}{$gallery_root_path}includes/permissions.$phpEx");
$album_access_array = get_album_access_array();
$album_data = $cache->obtain_album_list();
$user->add_lang('mods/gallery');
when you are running 0.4.1

if not, just search and delete:

Code: Select all

// Album info
$sql = 'SELECT *
	FROM ' . GALLERY_ALBUMS_TABLE . '
	ORDER BY left_id ASC';
$result = $db->sql_query($sql, 600);

$album_data = array();
while ($row = $db->sql_fetchrow($result))
{
	$album_data[$row['album_id']] = $row;
}


$db->sql_freeresult($result);
$recent_image_addon = false;
include("$phpbb_root_path" . GALLERY_ROOT_PATH . "includes/common.$phpEx");
$user->add_lang('mods/gallery');
// fin
No Support via PM
User avatar
kateland
Registered User
Posts: 198
Joined: Wed Nov 22, 2006 7:08 pm
Location: Philadelphia, PA
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by kateland »

Shew! Wow, did I goof up those edits. I couldn't see the duplicates - thanks for pointing them out. All is working now. :D
here's your love letter
you bloodletter
you disappointed every time
User avatar
kateland
Registered User
Posts: 198
Joined: Wed Nov 22, 2006 7:08 pm
Location: Philadelphia, PA
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by kateland »

And I spoke too soon.

I just updated to 0.4.1 and now no images and no random pics show. No thumbnails showing either. I could *swear* I read an FAQ or Known issue or post about this but I can't find it again! I've read all posts since page 125 on this board and the english ones on flying bits. I will go over one more time to flying bits, I know I missed it...but in the meantime here is my gallery. I'm sure it's a setting or something. Refreshed everything.

http://www.ne-core.com/phpBB3/gallery

Edit: OK. I wonder if part of my issue is that I went from 0.3.1 -> 0.4.0 -> 0.4.1. I didn't do any of the RCs.

Still researching issues. moved my images from gallery/upload to gallery/images/upload etc. Any suggestions would be great.
here's your love letter
you bloodletter
you disappointed every time
User avatar
novanilla
Registered User
Posts: 332
Joined: Wed Jul 02, 2008 1:08 pm
Location: Colorado
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by novanilla »

kateland wrote:And I spoke too soon.

I just updated to 0.4.1 and now no images and no random pics show. No thumbnails showing either. I could *swear* I read an FAQ or Known issue or post about this but I can't find it again! I've read all posts since page 125 on this board and the english ones on flying bits. I will go over one more time to flying bits, I know I missed it...but in the meantime here is my gallery. I'm sure it's a setting or something. Refreshed everything.

http://www.ne-core.com/phpBB3/gallery
Hi Kateland,

In the update instructions (somewhere, I can't remember where), there is a change to your image and thumbnail paths. You have to move all of the existing images from one place to the other, and they'll all show up again. Right click on the thumbnail spaces (and then the image spaces when you open the albums) to find out where they should be moved.

(oops, sorry I didn't see your edit - if that's not the problem I have no idea what is)
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by nickvergessen »

Yes, they needed to be moved.
But another question, when you didn't do the RCs, did you do the edits (which are needed)
No Support via PM
User avatar
kateland
Registered User
Posts: 198
Joined: Wed Nov 22, 2006 7:08 pm
Location: Philadelphia, PA
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by kateland »

No I didn't, I don't know why I didn't think I needed them.

So your recommendation is to go through RC 1 2 3 and check file edits? Make sure everything matches?

I gotta stop hitting post. Edit: I checked my database tables and the rows are intact; the file structure thinks nothing is there.
here's your love letter
you bloodletter
you disappointed every time
User avatar
kateland
Registered User
Posts: 198
Joined: Wed Nov 22, 2006 7:08 pm
Location: Philadelphia, PA
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by kateland »

Oh my god it finally works.

I'm embarrassed to even tell you what I did - in this case didn't do...but I didn't upload the /prosilver templates to my /prosilver_se main theme. :oops:

yeeep I'm a noob :)

Ha.
here's your love letter
you bloodletter
you disappointed every time
Fridge
Registered User
Posts: 307
Joined: Sat Nov 11, 2006 1:41 am
Location: Rotterdam, The Netherlands
Name: Martin
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by Fridge »

At the moment i'm using phpBB 3.0.2 and not willing to update right now, so my question is....will version 0.41 of this mod run on my outdated phpBB install ?
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by nickvergessen »

I'm not sure, but I think you can not do the edits on the includes/sessions.php but that won't hurt much! Just the viewonline thing won't work.
No Support via PM
Fridge
Registered User
Posts: 307
Joined: Sat Nov 11, 2006 1:41 am
Location: Rotterdam, The Netherlands
Name: Martin
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by Fridge »

I will give it a try, thxn for your answer ;)
MzVette
Registered User
Posts: 390
Joined: Wed Feb 11, 2004 3:54 am
Location: California Dreaming!
Contact:

Re: [Beta] phpBB Gallery 0.4.1

Post by MzVette »

Here's the error message I get after running the install:

Code: Select all

Fatal error: Language file ./language/en_us/mods/info_acp_gallery.php couldn't be opened. in /home/ourfamil/public_html/forums/includes/session.php on line 2019
Should I try reinstalling the session.php file and and making the required code changes?

Thanks in advance for your help.
wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: [Beta] phpBB Gallery 0.4.1

Post by wolfman24 »

No, you should copy info_acp_gallery.php into /language/en_us/mods/ because it couldn't be opened. At least that is what the message says. I assume you copied the file to /language/en/mods/ instead of /language/en_us/mods/
Locked

Return to “[3.0.x] MODs in Development”