[RC] phpBB Gallery 1.0.4 (including TS Gallery converter)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
Locked
User avatar
Kamahl19
Registered User
Posts: 1598
Joined: Tue Nov 06, 2007 3:33 pm
Location: Slovakia
Name: Martin
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by Kamahl19 »

this only select random image from your gallery. I can add it whereever you want. :)
ryudr
Registered User
Posts: 17
Joined: Wed Apr 30, 2008 9:54 pm

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by ryudr »

Uhh ok! This is not for me you talk to all people..i'm thinking you help me to resolve my problem.. :(
ryudr
Registered User
Posts: 17
Joined: Wed Apr 30, 2008 9:54 pm

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by ryudr »

** IF YOU HAVE THE SAME PROBLEM - NO IMAGE DISPLAYED - THERE IS NO ISSUE NOBODY CAN HELP YOU **
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by nickvergessen »

No Support via PM
aidesign
Registered User
Posts: 110
Joined: Fri Oct 22, 2004 6:25 pm
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by aidesign »

I just converted my board to phpBB3 and am attempting to convert my Smartor Photo Album 2.0.56 MOD to use this one. I uploaded all the files for this MOD, then I went through all the manual file edits. Then I ran the /install/gallery/install.php file. I choose the 'Install MOD' first. Worked just fine. Then I went back and choose the 'Convert MOD to v0.3.1' and pointed to my old phpBB2 path and went I hit submit I get an error.

Code: Select all

General Error
SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/forums/album_cat ORDER BY cat_order' at line 2 [1064]

SQL

SELECT * FROM /forums/album_cat ORDER BY cat_order

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal_mysql->sql_error()

FILE: install_gallery/install.php
LINE: 586
CALL: dbal_mysql->sql_query()
I had my Smartor Album pretty heavily modded and have over 7,000 photos.

Can anyone help me? Thanks in advance!!
Toy Maker
Registered User
Posts: 87
Joined: Tue Jun 10, 2003 9:33 pm

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by Toy Maker »

Gallery pic/link isn't showing up on the header

that little eyeball pic, (Gallery) next to "FAQ" and "MEMBERS" isn't showing up. you can see at http://www.CarverAudio.com/phpBB3/gallery
i've followed the instructions like 5 times so far (perfectly) and it's just not showing up. i dunno what's wrong.
The /gallery works perfect, but the gallery link does not show up in subsilver2, and the link in Prosilver is there, but is wrong, and sends you back to the main index.php... I edited the files twice, and could not get the buttons to show up, or work correctly. some help please !!
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by nickvergessen »

aidesign wrote:Then I went back and choose the 'Convert MOD to v0.3.1' and pointed to my old phpBB2 path and went I hit submit I get an error.
its not the Path you need to enter, but the Prefix of your installation
Toy Maker wrote:Gallery pic/link isn't showing up on the header
You cleared your Cache?
No Support via PM
User avatar
Bob in Iowa
Registered User
Posts: 70
Joined: Tue Jan 17, 2006 6:40 pm
Location: Iowa
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by Bob in Iowa »

Nick -- great mod!! I haven't checked it out in a while, so I just installed v0.3.1 on a test board and converted the Smartor albums that I have on a phpBB2 board.

Everything worked flawlessly in the conversion, but later on, I did see a problem that might be caused by an ommission in the install script.

Apparently, the conversion mode of the install script does not add a session_album_id column to the sessions table. I noticed this when I got an sql error, pointing to viewonline.php and saying that s.session_album_id was an unknown column, when I clicked on the "Who is online" link on the index page. I checked the database, and sure enough -- the column wasn't there. I added it manually with phpMyAdmin, so everything works ok now.
Toy Maker
Registered User
Posts: 87
Joined: Tue Jun 10, 2003 9:33 pm

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by Toy Maker »

nickvergessen wrote:
aidesign wrote:Then I went back and choose the 'Convert MOD to v0.3.1' and pointed to my old phpBB2 path and went I hit submit I get an error.
its not the Path you need to enter, but the Prefix of your installation
Toy Maker wrote:Gallery pic/link isn't showing up on the header
You cleared your Cache?

DUUUUUUUUUUU....... no :? (that needs to be added to the bottom of the instructions, how would I know that) totall newbie !!

Just did it !! It shows up now, but the text for the link says, {GALLERY} and when you hover the mouse over it, the help text reads, { GALLERY_EXPLAIN } when you click the link, it takes you to phpBB3/index.php
Now I get the same exact wrong text/link in both themes.

I'm almost there!!!! Must be something wrong in one of the files I edited... any idea which one it would be ??

THANKS !!! so far !!!
aidesign
Registered User
Posts: 110
Joined: Fri Oct 22, 2004 6:25 pm
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by aidesign »

nickvergessen wrote:
aidesign wrote:Then I went back and choose the 'Convert MOD to v0.3.1' and pointed to my old phpBB2 path and went I hit submit I get an error.
its not the Path you need to enter, but the Prefix of your installation

Opps, I meant prefix. Well actually to generate that error I put /forums/ but I put in just forums in and now it's generating the following error.

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Table 'emoboy_phpbb3.forumsalbum_cat' doesn't exist [1146]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.
Maybe I'm getting confused as to what the 'prefix' means. I put in the root folder name of my phpBB2 install (which is 'forums'), I put in the MySQL database name, I even tried putting in the value of $table_prefix = from the config.php file.

Thanks in advance.
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by nickvergessen »

aidesign wrote:Maybe I'm getting confused as to what the 'prefix' means. I put in the root folder name of my phpBB2 install (which is 'forums'), I put in the MySQL database name, I even tried putting in the value of $table_prefix = from the config.php file.
Thats the right value.
Please note that the tables of teh old phpbb2 need to be in the same ddatabase as the phpbb3 installation is.
Toy Maker wrote:Just did it !! It shows up now, but the text for the link says, {GALLERY} and when you hover the mouse over it, the help text reads, { GALLERY_EXPLAIN } when you click the link, it takes you to phpBB3/index.php
you have a link?
Bob in Iowa wrote:Apparently, the conversion mode of the install script does not add a session_album_id column to the sessions table. I noticed this when I got an sql error, pointing to viewonline.php and saying that s.session_album_id was an unknown column, when I clicked on the "Who is online" link on the index page. I checked the database, and sure enough -- the column wasn't there. I added it manually with phpMyAdmin, so everything works ok now.
Yes, its a known issue: http://www.flying-bits.org/bugtracker/viewbug.php?b=254
No Support via PM
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by nickvergessen »

Seems like the first part of the includes/functions.php got lost.
No Support via PM
aidesign
Registered User
Posts: 110
Joined: Fri Oct 22, 2004 6:25 pm
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by aidesign »

nickvergessen wrote:
aidesign wrote:Maybe I'm getting confused as to what the 'prefix' means. I put in the root folder name of my phpBB2 install (which is 'forums'), I put in the MySQL database name, I even tried putting in the value of $table_prefix = from the config.php file.
Thats the right value.
Please note that the tables of teh old phpbb2 need to be in the same ddatabase as the phpbb3 installation is.
Sorry, I'm kind of a database n00b. I converted my old phpBB2 board to phpBB3. The updater probably only copied over forum related tables to this new phpBB3 database? So do you mean I have to copy over the tables relating to the Album from the old database to the new database? Sorry I just need some clarification here.
User avatar
Sunka
Registered User
Posts: 566
Joined: Wed Mar 26, 2008 2:48 pm
Location: Croatia, Zvoneca

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by Sunka »

When I try to upload more then 1 image at once to my album...this errors shows

Code: Select all

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 9152 bytes) in /home/pijanitv/public_html/forum/gallery/posting.php on line 450
Is this happening maybe because my images is big...
Can this error be fixed?
Locked

Return to “[3.0.x] MODs in Development”