[RC] phpBB Gallery 1.0.4 (including TS Gallery converter)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Anti-Spam Guide
Locked
Sablehawk
Registered User
Posts: 21
Joined: Mon Jun 02, 2003 10:45 pm

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by Sablehawk » Thu Jul 31, 2008 9:44 am

I used the subsilver 2 like you suggested and it worked excellently. Thanks for the suggestion.

SharpShot.gif
Registered User
Posts: 18
Joined: Tue Jul 10, 2007 5:56 pm

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by SharpShot.gif » Thu Jul 31, 2008 11:45 am

I did and the same result

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by muggins » Fri Aug 01, 2008 2:29 am

nickvergessen wrote:you need to run:
ACP > MODs > phpbb gallery > Manage Cache
I have the option in ACP, but nothing is on the right side of the ACP page. I have 'managed' my cache manually, thinking that the option was a stub for your next version. :oops:

Any tips? I can PM you a test account for my board, if needed. I have quite a few mods, some of them slightly customized by me, but nothing I can find that is obviously wrong...

My other question concerns the links within your mod. Some of the links to galleries open in the same tab (or window), some open a new tab and confuse my members terribly. They can't get back to the index without finding the window they started from, out of {COUNT_MANY} :lol: Sorry...
Muggins

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by nickvergessen » Fri Aug 01, 2008 6:13 am

muggins wrote:Some of the links to galleries open in the same tab (or window), some open a new tab and confuse my members terribly. They can't get back to the index without finding the window they started from, out of {COUNT_MANY} :lol: Sorry...
hm? all should open in the same tab. which aren't?
No Support via PM

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by muggins » Fri Aug 01, 2008 2:24 pm

I will check today and post my findings. I have added target="_blank" to links, as described in the knowledge base article for phpBB3, and that may have something to do with it.

Thanks for the quick response on the links, but what about the 'manage cache' option that I can't use? Shall I create a user for you?
Muggins

bigwest
Registered User
Posts: 3
Joined: Fri Aug 01, 2008 3:11 pm

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by bigwest » Fri Aug 01, 2008 3:16 pm

I installed this mod and it seemed to be working fine to begin with. Now the "Upload Image" button stretches right across the screen!!

Image

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by nickvergessen » Fri Aug 01, 2008 3:23 pm

muggins wrote:Thanks for the quick response on the links, but what about the 'manage cache' option that I can't use? Shall I create a user for you?
I don't know any other way ;)

@bigwest: reload your imageset in the acp > styles >
No Support via PM

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by muggins » Fri Aug 01, 2008 3:26 pm

Give me a little while and I'll PM your details...

Done.

Edit: My bad! Not your mod... :oops:
Last edited by muggins on Fri Aug 01, 2008 7:14 pm, edited 2 times in total.
Muggins

bigwest
Registered User
Posts: 3
Joined: Fri Aug 01, 2008 3:11 pm

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by bigwest » Fri Aug 01, 2008 3:30 pm

nickvergessen wrote:@bigwest: reload your imageset in the acp > styles >
Thanks that did the trick

2klix
Registered User
Posts: 5
Joined: Sun Aug 10, 2008 11:55 am

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by 2klix » Sun Aug 10, 2008 12:25 pm

I am getting an error on my ACP .MODS personal album permissions page as follows:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Unknown column 'allow_personal_albums' in 'field list' [1054]

SQL

SELECT group_id, group_name, group_type, allow_personal_albums, view_personal_albums, personal_subalbums FROM phpbb_groups ORDER BY group_name ASC

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/acp/acp_gallery.php
LINE: 633
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_gallery.php
LINE: 95
CALL: acp_gallery->album_personal_permissions()

FILE: includes/functions_module.php
LINE: 471
CALL: acp_gallery->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
I know this problem has been addressed before in the forum but I am not really sure how to fix this, can anyone give me some clearer instructions please.
Thanks
Matt

2klix
Registered User
Posts: 5
Joined: Sun Aug 10, 2008 11:55 am

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by 2klix » Sun Aug 10, 2008 12:29 pm

Nice MOD, I nearly have things working but have a small menu problem. On the .MODS page I have the menu on the left but it is repeated, has anyone else had this problem and if so how do I fix it?
Thanks
Matt

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.3.1 - keep it up tsr

Post by nickvergessen » Sun Aug 10, 2008 1:06 pm

just wait some minutes and take the next version.
No Support via PM

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.0-RC1

Post by nickvergessen » Sun Aug 10, 2008 2:00 pm

Modification Name: phpbb gallery
Author: nickvergessen

Modification Version: 0.4.0-RC1
Modification Description: Features: feature list is not available yet

Demo URL: http://www.flying-bits.org/gallery/index.php
Supported Language-Packages: de, en
Supported Styles: prosilver, subsilver2

MOD Repository: http://code.bantux.de/svn/phpbb-gallery (SVN/Subversion)
Browse Repository: http://code.bantux.de/repositories/show/phpbb-gallery
Bug-Tracker: http://www.flying-bits.org/bugtracker/viewcat.php?c=6
(Before reporting a bug see the FAQ, whether there is something you should know about that bug)


FAQ: http://www.flying-bits.org/viewforum.php?f=67

Modification Download: Download v0.4.0-RC1
Note: Because of a complete change in the permissions-system you need to set all permissions new, when you update from previous versions (than 0.4.x), or convert from Smartor's Album MOD.
No Support via PM

Kharon
Registered User
Posts: 235
Joined: Thu Oct 26, 2006 5:27 pm

Re: [Beta] phpBB Gallery 0.4.0-RC1

Post by Kharon » Sun Aug 10, 2008 6:52 pm

server:localhost
phpbb version:3.0.2

I updated 0.3.1 to 0.4.0RC1 five minutes ago..

I am sending image to gallery ..

Code: Select all

[phpBB Debug] PHP Notice: in file /gallery/posting.php on line 421: Undefined index: album_approval
thanks..
sorry my english..

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: [Beta] phpBB Gallery 0.4.0-RC1

Post by nickvergessen » Sun Aug 10, 2008 7:03 pm

Kharon wrote:server:localhost
phpbb version:3.0.2

I updated 0.3.1 to 0.4.0RC1 five minutes ago..

I am sending image to gallery ..

Code: Select all

[phpBB Debug] PHP Notice: in file /gallery/posting.php on line 421: Undefined index: album_approval
thanks..
sorry my english..
thanks, i put it into my bugtracker:
http://www.flying-bits.org/bugtracker/viewbug.php?b=282
No Support via PM

Locked

Return to “[3.0.x] MODs in Development”