Page 52 of 212

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Thu Aug 14, 2008 7:52 am
by nickvergessen
ChriZathens wrote:This message is in language/en/mods/info_ucp_gallery.php
no, its language/en/mods/gallery_ucp.php

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Thu Aug 14, 2008 10:41 pm
by lazlo
Not sure if this is the right place to post, but please help me or at least point me to the right direction:
I have had a clean install of phpBB3 and try to add the Gallery.

when I try to install Gallery I am getting the following message:
Fatal error: Call to a member function on a non-object in /homepages/46/d115527691/htdocs/phpbb3/phpBB3/phpbb_root/install/gallery_install.php on line 18

I think I have followed the instructions to the letter for the changes before the installation, but obviously missed something.
The link is here:

http://lazlo.us/phpbb3/phpBB3/phpbb_roo ... nstall.php

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Thu Aug 14, 2008 10:53 pm
by nickvergessen
you made a little mistake.
you need to upload the install_gallery, so you can visit it with:
http://lazlo.us/phpbb3/phpBB3/install/g ... nstall.php

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Thu Aug 14, 2008 11:58 pm
by lazlo
Thanks

It is an easy mistake, I have no knowledge about using PHP.
I thought this would have been the path:

phpBB3/phpbb_root/install/gallery_install.php

I will try it

thanks again

Lazlo

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Fri Aug 15, 2008 1:36 pm
by Kharon
comments and rate problem..

Album Permissions > Personal albums & Own personal albums > Administrator and other groups (example)

Permission:
Can rate images - yes
Can comment on image - yes

/phpBB3/gallery/image_page.php?album_id=4&image_id=7#comments - not working .. blank page

/phpBB3/gallery/image_page.php?album_id=4&image_id=7#rating - not working .. blank page

thanks
sorry,my english

MSSQL ERROR

Posted: Fri Aug 15, 2008 2:53 pm
by rsl22
Your help to resolve this error will be highly appreciated.

General Error
SQL ERROR [ mssql ]

Column 'a.album_approval' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause.
Column '%.*ls.%.*ls' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause. [8120]

SQL

SELECT a.*, COUNT(pc.image_id) AS count, MAX(pc.image_id) as last_image FROM phpbb31_gallery_albums AS a LEFT JOIN phpbb31_gallery_albums AS sa ON ( sa.left_id < a.right_id AND sa.left_id > a.left_id ) LEFT JOIN phpbb31_gallery_images AS pc ON ( pc.image_album_id = sa.album_id OR pc.image_album_id = a.album_id ) WHERE a.album_id <> 0 AND a.parent_id = 0 GROUP BY a.album_id ORDER BY a.left_id ASC

BACKTRACE


FILE: includes/db/mssql.php
LINE: 137
CALL: dbal->sql_error()

FILE: gallery/includes/functions_display.php
LINE: 29
CALL: dbal_mssql->sql_query()

FILE: gallery/index.php
LINE: 35
CALL: include('gallery/includes/functions_display.php')

Thanks,
RSL22

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Fri Aug 15, 2008 3:25 pm
by nickvergessen
Kharon wrote:comments and rate problem..

Album Permissions > Personal albums & Own personal albums > Administrator and other groups (example)

Permission:
Can rate images - yes
Can comment on image - yes

/phpBB3/gallery/image_page.php?album_id=4&image_id=7#comments - not working .. blank page

/phpBB3/gallery/image_page.php?album_id=4&image_id=7#rating - not working .. blank page

thanks
sorry,my english
For the blankpage problem see:
http://www.flying-bits.org/viewtopic.php?f=67&t=607
rsl22 wrote:General Error
SQL ERROR [ mssql ]

Column 'a.album_approval' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause.
which version of the MOD are you using?

line 29 of the current gallery/includes/functions_display.php
is

Code: Select all

$sql_where = 'album_user_id = 0';
so i may see your gallery/includes/functions_display.php?

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Fri Aug 15, 2008 4:07 pm
by Kharon
nickvergessen wrote:
Kharon wrote:comments and rate problem..
/phpBB3/gallery/image_page.php?album_id=4&image_id=7#comments - not working .. blank page

/phpBB3/gallery/image_page.php?album_id=4&image_id=7#rating - not working .. blank page

thanks
sorry,my english
For the blankpage problem see:
http://www.flying-bits.org/viewtopic.php?f=67&t=607
thanks , rate and comment is working,now :)

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Fri Aug 15, 2008 6:00 pm
by Trinity
Hey Nick. Is there any way we can see what version we are running? I really can't remember what I have installed, and I would like to upgrade to your newest version.

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Fri Aug 15, 2008 9:06 pm
by lazlo
nickvergessen wrote:you made a little mistake.
you need to upload the install_gallery, so you can visit it with:
http://lazlo.us/phpbb3/phpBB3/install/g ... nstall.php
Thanks Nick for your very valuable help, I have made a giant step forward
The Gallery is installed :
http://lazlo.us/davro/phpBB3/gallery/

But I still cannot figure out how to post pictures.
Cannot find a button to click on

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Sat Aug 16, 2008 4:09 am
by darkone_d1_2000
Hey Nick

Upgrade from 3.1 - 4.0 went flawlessly

I have just some questions on the security because I think I'm setting it up wrong.

1. What does 'Number of uploaded images' or the subalbum fields mean? Is this where we designate how many pics and subalbums people are allowed?

2. What would I need to setup to have personal galleries viewable only by registered users/mods/admins. And does the default security for personal galleries setup so that the owner can edit everything in their own gallery but registered users can only view/rate/comment.

3. What is the 'Own Personal Gallery' security for. Doesn't make sense that you cannot use your own gallery.

4. This is probably because of my security setup but where is the personal galleries link?

5. Is there a permissions guide for the gallery to help with setup?


Think that it is for now... thx for the hard work Nick


-D1-

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Sat Aug 16, 2008 4:41 am
by Sunka
Hi Nick...
I have 3 questions
  • When I update to v0.4.0 and install add on to view recent and last images on index page, every time I refresh page, the counter for How many times picture view is inceasing (before in v0.3.1 there is not that error)
  • Also, now pictures (from index page) when I click on them, they open (like other pictures in posts), and before in v0.3.1 when click on picture it is leads to album where picure is (now it is only when you click on image title)
  • I get this error:

    Code: Select all

    [phpBB Debug] PHP Notice: in file /memberlist.php on line 570: array_merge() [function.array-merge]: Argument #2 is not an array
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3917: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3021)
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3919: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3021)
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3920: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3021)
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3921: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3021)
    only, when look profile of users with have not albums
EDIT: Problem #3 solved few posts above

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Sat Aug 16, 2008 9:19 am
by FreakyBlue
Hi Nick,
I've installed the mod at my testforum (upgrade from 3.0.1.). Great mod! I didn't lose any pics :D

Couple of things for your interest:
1. this mod isn't working well if you have installed the admanagament mod from tas2580: http://www.phpbb.com/community/viewtopi ... t#p3015663
The problem is that the acp isn't working well. It's totally screwed up. I've deleted the admanagement mod and the gallery works fine, everything is accessable in the acp :D
2. I couln't see the upload image button in my subsilver based style (so i couldn't upload). Looked at the gallery_album_body.html and noticed that you've forgot to link the image. This will solve it:

Find

Code: Select all

<td align="{S_CONTENT_FLOW_BEGIN}" valign="middle"><a href="{U_UPLOAD_IMAGE}">{UPLOAD_IMG}</a></td>
Replace with

Code: Select all

<td align="{S_CONTENT_FLOW_BEGIN}" valign="middle"><a href="{U_UPLOAD_IMAGE}"><img src="{T_IMAGESET_LANG_PATH}/button_upload_image.gif" alt="{L_UPLOAD_IMAGE}" />{UPLOAD_IMG}</a></td>
Futhermore, i kept getting this when i tried to upload an image:
You have reached your quota of imagess. You cannot upload any more. Please contact the administrator for more information.
Solved it by editing the permissions upload (default is 0) to 1000. Maybe you could explain this step in the ACP for the users of this mod.

Last, this week i will make a dutch translation. When it's done i'll give it to you.

thnx!
Greetz,
FreakyBlue (alias David Jansen)

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Sat Aug 16, 2008 10:57 am
by nickvergessen
Trinity wrote:Hey Nick. Is there any way we can see what version we are running? I really can't remember what I have installed, and I would like to upgrade to your newest version.
as on some versions i forgot to update the gallery_config value, i'll need to set up a check list, to tell you that.
that may take some time ;)
lazlo wrote:But I still cannot figure out how to post pictures.
Cannot find a button to click on
do the points mentioned in the DIY-Instructions you didn't clear theme/template/imageset and cache yet
darkone_d1_2000 wrote:1. What does 'Number of uploaded images' or the subalbum fields mean? Is this where we designate how many pics and subalbums people are allowed?
Exactly
darkone_d1_2000 wrote:2. What would I need to setup to have personal galleries viewable only by registered users/mods/admins. And does the default security for personal galleries setup so that the owner can edit everything in their own gallery but registered users can only view/rate/comment.
there are no default permissions on personal-albums
you may add/edit the permissions in the point album permissions in the ACP
darkone_d1_2000 wrote:3. What is the 'Own Personal Gallery' security for. Doesn't make sense that you cannot use your own gallery.
it's to give users other permissions in their own personal-albums, like moderating the comments, or even allow comments, and don't allow comments on the personal albums of others.
darkone_d1_2000 wrote:4.
the link can be found under the albums list.
See my Demo-board for example: http://www.flying-bits.org/gallery/index.php
darkone_d1_2000 wrote:5. Is there a permissions guide for the gallery to help with setup?
no, but the system management will change anyway with future version
Sunka wrote:When I update to v0.4.0 and install add on to view recent and last images on index page, every time I refresh page, the counter for How many times picture view is inceasing (before in v0.3.1 there is not that error)
i can't reproduce!
Sunka wrote:Also, now pictures (from index page) when I click on them, they open (like other pictures in posts), and before in v0.3.1 when click on picture it is leads to album where picure is (now it is only when you click on image title)
this is, just like i wanted it ;)
FreakyBlue wrote:2. I couln't see the upload image button in my subsilver based style (so i couldn't upload). Looked at the gallery_album_body.html and noticed that you've forgot to link the image. This will solve it:

Find

Code: Select all

<td align="{S_CONTENT_FLOW_BEGIN}" valign="middle"><a href="{U_UPLOAD_IMAGE}">{UPLOAD_IMG}</a></td>
Replace with

Code: Select all

<td align="{S_CONTENT_FLOW_BEGIN}" valign="middle"><a href="{U_UPLOAD_IMAGE}"><img src="{T_IMAGESET_LANG_PATH}/button_upload_image.gif" alt="{L_UPLOAD_IMAGE}" />{UPLOAD_IMG}</a></td>
should have worked, if you refreshed your imageset ;)

Re: [Beta] phpBB Gallery 0.4.0-RC1

Posted: Sat Aug 16, 2008 2:13 pm
by mapb_1990
after update of version 3.0.1, appears to me this error to open the topics.

Code: Select all

Erro Geral
SQL ERROR [ mysql4 ]

Not unique table/alias: 'ca' [1066]

SQL

SELECT u.*, z.friend, z.foe, p.*, ca.cash_amt, gu.personal_album_id FROM (phpbb_users u, phpbb_posts p) LEFT JOIN phpbb_cash_amt ca ON (ca.cash_id = 1 AND ca.user_id = p.poster_id) LEFT JOIN phpbb_zebra z ON (z.user_id = 4 AND z.zebra_id = p.poster_id) LEFT JOIN phpbb_cash_amt ca ON (ca.cash_id = 1 AND ca.user_id = p.poster_id) LEFT JOIN phpbb_gallery_users gu ON (gu.user_id = p.poster_id) WHERE p.post_id IN ('10000', '10002', '10003', '10004', '10008', '10018', '10019', '10029', '10032', '10044', '10046', '10067', '10069') AND u.user_id = p.poster_id

BACKTRACE


FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: viewtopic.php
LINE: 953
CALL: dbal_mysql->sql_query()