[RC] Prime Quick Reply

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Ideas Centre
Locked
btracy
Registered User
Posts: 13
Joined: Thu Apr 03, 2008 1:21 am

Re: [BETA] Prime Quick Reply

Post by btracy »

Has anyone created an Italian and a Spanish version?

Thanks,

Bill
User avatar
primehalo
Former Team Member
Posts: 2898
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [BETA] Prime Quick Reply

Post by primehalo »

btracy wrote:Has anyone created an Italian and a Spanish version?

Thanks,

Bill
Not that I'm aware of.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
btracy
Registered User
Posts: 13
Joined: Thu Apr 03, 2008 1:21 am

Re: [BETA] Prime Quick Reply

Post by btracy »

A friend of mine translated into Italian for me, so I thought I would post it here:

Code: Select all

$lang = array_merge($lang, array(
	// Originally from posting.php, edited to fit
	'QUICK_REPLY_ATTACH_SIG'			=> 'Aggiungi una firma',
	'QUICK_REPLY_DISABLE_BBCODE'		=> 'Disattiva BBCode',
	'QUICK_REPLY_DISABLE_SMILIES'		=> 'Disattiva le faccine',
	'QUICK_REPLY_DISABLE_MAGIC_URL'		=> 'Non fare cliccabili i collegamenti',
	'QUICK_REPLY_MORE_SMILIES'			=> 'Visualizza più faccine',
	'QUICK_REPLY_NOTIFY_REPLY'			=> 'Avvisami di nuove risposte',
	'QUICK_REPLY_TOO_FEW_CHARS'			=> 'Il tuo messaggio contiene troppi pochi caratteri',

	// Custom
	'QUICK_REPLY_POST_REPLY'			=> 'Dai una risposta',
	'QUICK_REPLY_SHOW_OPTIONS'			=> 'Mostra opzioni di risposta',
	'QUICK_REPLY_HIDE_OPTIONS'			=> 'Nascondi opzioni di risposta',
	'QUICK_REPLY_SHOW'					=> '[Mostra]',
	'QUICK_REPLY_HIDE'					=> '[Nascondi]',
	'QUICK_REPLY_QUOTE_LAST_POST'		=> 'Cita l ultimo messaggio',
	'QUICK_REPLY_DISPLAY_SUBJECT'		=> 'Mostra il titolo',
	'QUICK_REPLY_DISPLAY_BBOCDES'		=> 'Mostra BBCodes',
	'QUICK_REPLY_DISPLAY_SMILIES'		=> 'Mostra le faccine',

	// Admin
	'QUICK_REPLY_ADMIN_CATEGORY'		=> 'Risposta veloce',
	'QUICK_REPLY_ADMIN_ENABLED'			=> 'Attiva la risposta veloce',
	'QUICK_REPLY_ADMIN_ENABLED_EXPLAIN'	=> 'Inserisci un modulo per la risposta veloce sotto la discussione.',
	'QUICK_REPLY_ADMIN_GUESTS'			=> 'Attiva per gli ospiti',
	'QUICK_REPLY_ADMIN_GUESTS_EXPLAIN'	=> 'Permette agli ospiti di usare la risposta veloce.',
	'QUICK_REPLY_ADMIN_MEMORY'			=> 'Ricorda la sistemazione dell’area di testo',
	'QUICK_REPLY_ADMIN_MEMORY_EXPLAIN'	=> 'Ricorda se un utente ha reso l area di testo visibile o nascosto.',
	'QUICK_REPLY_ADMIN_LAST_PAGE_ONLY'	=> 'Solo l ultima pagina',
	'QUICK_REPLY_ADMIN_FORM'			=> 'Mostra l area di testo',
	'QUICK_REPLY_ADMIN_FORM_EXPLAIN'	=> 'S è invisibile, gli utenti dovranno cliccare per vederla.',
	'QUICK_REPLY_ADMIN_OPTIONS'			=> 'Mostra le opzioni',
	'QUICK_REPLY_ADMIN_OPTIONS_EXPLAIN'	=> 'S’è invisibile, gli utenti dovranno cliccare per vederla.',
	'QUICK_REPLY_ADMIN_SUBJECT'			=> 'Mostra il titolo',
	'QUICK_REPLY_ADMIN_SUBJECT_EXPLAIN'	=> 'S’è invisibile, gli utenti dovranno cliccare per vederla.',
	'QUICK_REPLY_ADMIN_BBCODES'			=> 'Mostra BBCodes',
	'QUICK_REPLY_ADMIN_BBCODES_EXPLAIN'	=> 'S’è invisibile, gli utenti dovranno cliccare per vederla.',
	'QUICK_REPLY_ADMIN_SMILIES'			=> 'Mostra le faccine',
	'QUICK_REPLY_ADMIN_SMILIES_EXPLAIN'	=> 'S’è invisibile, gli utenti dovranno cliccare per vederla.',

	// Used if Prime Multi-Quote is installed
	'QUICK_REPLY_QUOTE_SELECTED'		=> 'Citazione selezionata',
	'QUICK_REPLY_NO_QUOTES_SELECTED'	=> 'Nessun messaggio selezionato!',
));

?>
Thanks for this great MOD!

Bill from NJ
User avatar
primehalo
Former Team Member
Posts: 2898
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [BETA] Prime Quick Reply

Post by primehalo »

Thanks!
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
lfaragon
Registered User
Posts: 7
Joined: Sun Mar 30, 2008 9:08 pm

Re: [BETA] Prime Quick Reply

Post by lfaragon »

Is there a solution to the following problem:

Everything works great, however when posting there is an error on IE, as I said it does post and seems that everything is fine, it is just annoying to see the error.

I researched the error in Firefox and this is what I get:

Code: Select all

"prime_posts_id not defined"

The error is in line 170 of prosilver/template/prime_quick_reply.js
Any help on how to fix this error would be much appreciated.

Thanks for a great mod, keep up the good work.
User avatar
fiorefrank
Registered User
Posts: 226
Joined: Fri Jun 08, 2007 10:43 am
Location: Italy
Contact:

Re: [BETA] Prime Quick Reply

Post by fiorefrank »

just great!
i have tested it on local server and works fine
frank
User avatar
primehalo
Former Team Member
Posts: 2898
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [BETA] Prime Quick Reply

Post by primehalo »

lfaragon wrote:Is there a solution to the following problem:

Everything works great, however when posting there is an error on IE, as I said it does post and seems that everything is fine, it is just annoying to see the error.

I researched the error in Firefox and this is what I get:

Code: Select all

"prime_posts_id not defined"

The error is in line 170 of prosilver/template/prime_quick_reply.js
Any help on how to fix this error would be much appreciated.

Thanks for a great mod, keep up the good work.
Yes, that would be an error, because "prime_posts_id" does not exist. I'm not sure how that got in your file.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
User avatar
Kojek
Registered User
Posts: 36
Joined: Sat Apr 26, 2008 11:38 am

Re: [BETA] Prime Quick Reply

Post by Kojek »

do i need to remove the //-- mod: Prime Quick Reply -------------------------------------------------// ???
cause there isn't any quick reply is showing..
User avatar
primehalo
Former Team Member
Posts: 2898
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [BETA] Prime Quick Reply

Post by primehalo »

No... you shouldn't need to remove anything to make it work.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
lfaragon
Registered User
Posts: 7
Joined: Sun Mar 30, 2008 9:08 pm

Re: [BETA] Prime Quick Reply

Post by lfaragon »

In terms of the error that I receive is from this part of the quick_reply.js:

Code: Select all

// Disable the hidden quoted posts, as no need to submit all that data.
	if (quick_reply_form.quoted_post)
	{
		quick_reply_form.quoted_post.disabled = true;
	}
	if (prime_post_ids && typeof(prime_post_ids) == 'object')
	{
		for (var i=0; i<prime_post_ids.length; i++)
		{
			var quoted_post_id = 'quoted_post' + prime_post_ids[i];
			if (quick_reply_form[quoted_post_id])
			{
				quick_reply_form[quoted_post_id].disabled = true;
			}
		}
	}
	return true;
}
The error comes from this line:

Code: Select all

if (prime_post_ids && typeof(prime_post_ids) == 'object')
So prime_post_ids do exist on the file, what I can't figure out is why is it causing an error, would deleting this last portion cause a major problem with the script in general?

Thanks for the quick response.
User avatar
primehalo
Former Team Member
Posts: 2898
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [BETA] Prime Quick Reply

Post by primehalo »

Yes, "prime_post_ids" does exist, but "prime_posts_id" does not exist, and you said your error was:
lfaragon wrote:

Code: Select all

"prime_posts_id not defined"

The error is in line 170 of prosilver/template/prime_quick_reply.js
If you're saying that this was just a typo, then I'm also not sure why you would be getting an error. I will try to look into it, but deleting that portion shouldn't cause any problems.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
qtranvu
Registered User
Posts: 9
Joined: Sun Apr 27, 2008 8:52 am

Re: [BETA] Prime Quick Reply

Post by qtranvu »

I have a question.

I added both mod, Prime Quick Reply and Hoteditor mod. Apparently, the Hoteditor mod has an instruction:

Code: Select all

styles/prosilver/template/posting_buttons.html

#
#-----[ FIND ]------------------------------------------
# ~ line number 72

<div id="format-buttons">
	<input type="button" class="button2" accesskey="b" name="addbbcode0" value=" B " style="font-weight:bold; width: 30px" onclick="bbstyle(0)" title="{L_BBCODE_B_HELP}" />
	<input type="button" class="button2" accesskey="i" name="addbbcode2" value=" i " style="font-style:italic; width: 30px" onclick="bbstyle(2)" title="{L_BBCODE_I_HELP}" />
	<input type="button" class="button2" accesskey="u" name="addbbcode4" value=" u " style="text-decoration: underline; width: 30px" onclick="bbstyle(4)" title="{L_BBCODE_U_HELP}" />
	<!-- IF S_BBCODE_QUOTE -->
		<input type="button" class="button2" accesskey="q" name="addbbcode6" value="Quote" style="width: 50px" onclick="bbstyle(6)" title="{L_BBCODE_Q_HELP}" />
	<!-- ENDIF -->
	<input type="button" class="button2" accesskey="c" name="addbbcode8" value="Code" style="width: 40px" onclick="bbstyle(8)" title="{L_BBCODE_C_HELP}" />
	<input type="button" class="button2" accesskey="l" name="addbbcode10" value="List" style="width: 40px" onclick="bbstyle(10)" title="{L_BBCODE_L_HELP}" />
	<input type="button" class="button2" accesskey="o" name="addbbcode12" value="List=" style="width: 40px" onclick="bbstyle(12)" title="{L_BBCODE_O_HELP}" />
	<input type="button" class="button2" accesskey="t" name="addlitsitem" value="[*]" style="width: 40px" onclick="bbstyle(-1)" title="{L_BBCODE_LISTITEM_HELP}" />
	<!-- IF S_BBCODE_IMG -->
		<input type="button" class="button2" accesskey="p" name="addbbcode14" value="Img" style="width: 40px" onclick="bbstyle(14)" title="{L_BBCODE_P_HELP}" />
	<!-- ENDIF -->
	<!-- IF S_LINKS_ALLOWED -->
		<input type="button" class="button2" accesskey="w" name="addbbcode16" value="URL" style="text-decoration: underline; width: 40px" onclick="bbstyle(16)" title="{L_BBCODE_W_HELP}" />
	<!-- ENDIF -->
	<!-- IF S_BBCODE_FLASH -->
		<input type="button" class="button2" accesskey="d" name="addbbcode18" value="Flash" onclick="bbstyle(18)" title="{L_BBCODE_D_HELP}" />
	<!-- ENDIF -->
	<select name="addbbcode20" onchange="bbfontstyle('[size=' + this.form.addbbcode20.options[this.form.addbbcode20.selectedIndex].value + ']', '[/size]');this.form.addbbcode20.selectedIndex = 2;" title="{L_BBCODE_F_HELP}">
		<option value="50">{L_FONT_TINY}</option>
		<option value="85">{L_FONT_SMALL}</option>
		<option value="100" selected="selected">{L_FONT_NORMAL}</option>
		<option value="150">{L_FONT_LARGE}</option>
		<option value="200">{L_FONT_HUGE}</option>
	</select>
	<input type="button" class="button2" name="bbpalette" id="bbpalette" value="{L_FONT_COLOR}" onclick="change_palette();" title="{L_BBCODE_S_HELP}" />
	<!-- BEGIN custom_tags -->
		<input type="button" class="button2" name="addbbcode{custom_tags.BBCODE_ID}" value="{custom_tags.BBCODE_TAG}" onclick="bbstyle({custom_tags.BBCODE_ID})" title="{custom_tags.BBCODE_HELPLINE}" />
	<!-- END custom_tags -->
</div>
#
#-----[ REPLACE WITH ]------------------------------------------
#

<!--//HotEditor MOD Remove Original BBCode Buttons -->

For now, the Prime Quick reply does not show bb code, and when I click on the smilies, they are not inserted into the quick reply and the screen is moved to the top of the page.

How would I make the Prime Quick Reply Mod compatible with the Hoteditor mod ? Has anyone successfully integrated both mods ? Any suggestion or advice ?

The Hoteditor Mod is here: http://www.phpbb.com/community/viewtopi ... 0&t=546265
Thank you very much.
User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: [BETA] Prime Quick Reply

Post by leviatan21 »

qtranvu wrote:I have a question.

I added both mod, Prime Quick Reply and Hoteditor mod. Apparently, the Hoteditor mod has an instruction:

For now, the Prime Quick reply does not show bb code, and when I click on the smilies, they are not inserted into the quick reply and the screen is moved to the top of the page.

How would I make the Prime Quick Reply Mod compatible with the Hoteditor mod ? Has anyone successfully integrated both mods ? Any suggestion or advice ?

The Hoteditor Mod is here: http://www.phpbb.com/community/viewtopi ... 0&t=546265
Thank you very much.
Hi qtranvu :
Let me comment something about Hoteditor : the topic for that mod is locked because the author don't care about users, I don't recommend you to use it, is not safe, and make your forum get slower, it force the phpbb3 code to do a lot of unnecessary process.
I know it very well, because I was an user for that mod, and I realize this issues a long time ago. For this is the reason because I wrote the ABBC3 mod, please take your time to visit it.

P.S. : Sorry primehalo if I you think that I use your topic for promote my mod :oops: , but sincerely I do not recommend the use of Hoteditor, and I bet that you think like me ( I can see inside your codes, you're great developer ).
If you think this post is out of place, I will delete it. Thanks
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español
drankur
Registered User
Posts: 271
Joined: Sat Dec 22, 2007 4:16 am

Re: [BETA] Prime Quick Reply

Post by drankur »

i am getting this error , what to do
Fatal error: Cannot redeclare generate_smilies() (previously declared in /home/prepgmed/public_html/forum/includes/functions_posting.php:22) in /home/prepgmed/public_html/forum/includes/functions_posting.php on line 112
User avatar
primehalo
Former Team Member
Posts: 2898
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [BETA] Prime Quick Reply

Post by primehalo »

drankur wrote:i am getting this error , what to do
Fatal error: Cannot redeclare generate_smilies() (previously declared in /home/prepgmed/public_html/forum/includes/functions_posting.php:22) in /home/prepgmed/public_html/forum/includes/functions_posting.php on line 112
This MOD does not modify the functions_posting.php file, therefore I surmise that something went terribly wrong during your installation. I'd recommend undoing the installation, and then try it again.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
Locked

Return to “[3.0.x] MODs in Development”