[ABD] lastRSS autoposting bot MOD (0.1.4)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

[ABD] lastRSS autoposting bot MOD (0.1.4)

Post by Smix » Fri Mar 14, 2008 3:38 pm

MOD Title: lastRSS autoposting bot
MOD Description: RSS content autoposting bot for phpBB3
MOD Version: 0.1.4
Last Stable version: 0.1.4

This mod is currently abandoned, because I´ve reworked it´s functionality into new mod :arrow: "Smixmods Feed News Center"


If you like my mods, please reconsider a small donation
:arrow: Image
Last edited by Smix on Sun Jan 31, 2010 4:32 pm, edited 28 times in total.

Nick-Harper
Registered User
Posts: 56
Joined: Mon Feb 25, 2008 1:39 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by Nick-Harper » Fri Mar 14, 2008 6:43 pm

I have installed this :)

Is there a way to manually make them check the feed and update?

I want to see this in action :mrgreen:
Image

darkwinglh
Registered User
Posts: 14
Joined: Thu Dec 27, 2007 6:37 pm
Location: Oklahoma
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by darkwinglh » Fri Mar 14, 2008 8:57 pm

Works great, tried it on the test system and can't wait until you get an acp module for it. One question, how do you change the poster? I have an account that does all autoposting, and would like to use it instead of my account.

Thanks in advance.
DW

Nick-Harper
Registered User
Posts: 56
Joined: Mon Feb 25, 2008 1:39 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by Nick-Harper » Fri Mar 14, 2008 9:44 pm

I think I have fixed this.

The only thing is that it is a bit messed up

Take a look here

As you can see it looks a bit dodgy, is there a way to edit this?

It also seems to give an error to do with the cash mod every time it posts, I will post it up next time it happens :)
Image

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by Smix » Fri Mar 14, 2008 10:04 pm

Final way of view is not finished of course.

Poster id is in config table - check the first post or the attached txt file for more info ...

Sorry for short replies, but I already don't remember questions :D (I'm typing this on my mobile phone) ...

Nick-Harper
Registered User
Posts: 56
Joined: Mon Feb 25, 2008 1:39 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by Nick-Harper » Sat Mar 15, 2008 12:00 am

I get the error below every time the RSS posts, this is because of the cash mod:

Code: Select all

Fatal error: Cannot redeclare cash_post() (previously declared in /usr/local/psa/home/vhosts/skybluestalk.co.uk/httpdocs/includes/mods/functions_cash.php:17) in /usr/local/psa/home/vhosts/skybluestalk.co.uk/httpdocs/includes/mods/functions_cash.php on line 68
Image

KidneyBoy
Registered User
Posts: 81
Joined: Thu Jan 22, 2004 1:04 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by KidneyBoy » Sat Mar 15, 2008 4:55 am

Oh man this is great! I am SO HAPPY to see somebody come out with some sort of stubstance here! THANK YOU for this MOD! I'm so anxious to have this mod installed! I will hold off until the ACP comes around, but I'm anxious to watch this develop! Thanks so much!!

KidneyBoy

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by Smix » Sat Mar 15, 2008 6:51 am

4 Nick: thank you for report, I'll try to measure where is the problem (because I cant check the cash mod now, but I'm sure it's in including "some" file twice ...)

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by Smix » Sat Mar 15, 2008 10:34 am

Trying to fix ... Dont know where the problem with cash mod is, but try to cheat it with this ...

Open functions_cash.Php
Find

Code: Select all

<?php
on next row add

Code: Select all

if(!function_exists('cash_post')){ 
find

Code: Select all

?>

add to previous row

Code: Select all

}
Last edited by Smix on Mon Mar 17, 2008 12:01 pm, edited 1 time in total.

borninblood
Registered User
Posts: 123
Joined: Wed May 18, 2005 11:10 am
Location: Belfast

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by borninblood » Sat Mar 15, 2008 11:00 am

Great mod!

Can I just confirm should next_check always be set to zero in the beginning?

saaiberke
Registered User
Posts: 1126
Joined: Wed Jul 20, 2005 8:13 am
Location: Gent/Belgium
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by saaiberke » Sat Mar 15, 2008 11:54 am

I am getting this error:

Code: Select all

SQL ERROR [ mysql4 ]

Column 'topic_first_poster_name' cannot be null [1048]

SQL

INSERT INTO phpbb3_topics (topic_poster, topic_time, forum_id, icon_id, topic_approved, topic_title, topic_first_poster_name, topic_first_poster_colour, topic_type, topic_time_limit, topic_attachment) VALUES (0, 1205581913, '50', 0, 1, 'BF2 pbbans | dziobak87 (f3fdd137)', NULL, NULL, 0, 0, 0)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions_posting.php
LINE: 1827
CALL: dbal_mysql->sql_query()

FILE: includes/functions_lastrss_autopost.php
LINE: 202
CALL: submit_post()

FILE: includes/functions_lastrss_autopost.php
LINE: 96
CALL: autopost()

FILE: includes/functions_lastrss_autopost.php
LINE: 244
CALL: autopost_init()

FILE: index.php
LINE: 28
CALL: include('includes/functions_lastrss_autopost.php')
Any idea how to fix this?

Thx,

Nic

Nick-Harper
Registered User
Posts: 56
Joined: Mon Feb 25, 2008 1:39 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by Nick-Harper » Sat Mar 15, 2008 12:03 pm

I now have this working pretty well as you can see here

The only thing is that it is going backwards through the RSS, it started from newest post and is now going back through time so I have the new news at the bottom and the old news at the top!

How can I make it so that it only takes new news rather than going back in time?

Thanks
Image

borninblood
Registered User
Posts: 123
Joined: Wed May 18, 2005 11:10 am
Location: Belfast

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by borninblood » Sat Mar 15, 2008 1:31 pm

I can't get this mod to work.

No errors, just no output.

I have two RSS feeds added into the database, with everything enabled, and the whole thing is enabled in the config table, but the two feeds aren't showing. I gave it an hour just to make sure it didn't have to automatically update anything but there is still nothing.

My hosts allow both curl and fopen.

Any help would be great appreciated.

User avatar
Hippie459MN
Registered User
Posts: 918
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by Hippie459MN » Sat Mar 15, 2008 2:16 pm

I cant wait for this with ACP controls! Might go ahead and try it now though. I am using the lastRSS agregator mod and love it and been looking for something like this for a while.

Ghost Rider
Registered User
Posts: 8
Joined: Sun Aug 05, 2007 2:47 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.0)

Post by Ghost Rider » Sat Mar 15, 2008 3:15 pm

Nice! I can't wait for the ACP-version of this. And the okay from the author to use it on a live forum!

Thanks for your hard work!

Locked

Return to “[3.0.x] Abandoned MODs”