Page 1 of 55

[MODDB] HighSlide Attachment MOD

Posted: Sat Mar 15, 2008 8:54 am
by Stoker 4.0
Modification Name: Highslide Attachment Mod
Author: Stoker and Peter

Modification Description: The Highslide Attachment Mod for phpBB3 makes attached images open in a nice popup layer. Large images fits screen (resized) with option to view fullsize. Images is with Gallery and slideshow.
There is only 2 file edits per style and one folder to upload - very easy to install.
Modification Version: 4.1.12
phpBB Version: 3.0.8
AutoMOD: Yes

Support: hhttp://www.phpbb3bbcodes.com/viewforum.php?f=32

Demo URL: http://www.phpbb3bbcodes.com/viewtopic.php?f=32&t=1176

Modification Download:
>>>Download here<<<

Credits:
Thanks to Torstein Hønsi for providing us with the Highslide script
(Have in mind that License for the script is needed for commercial websites!)
Thanks to Michaelo who provide the IE fix

Re: [RC] HighSlide Attachment & IMG MOD 1.0.1

Posted: Sat Mar 15, 2008 9:26 am
by moustafamin
is it compatitble with hoteditor?

Re: [RC] HighSlide Attachment & IMG MOD 1.0.1

Posted: Sat Mar 15, 2008 9:47 am
by stokerpiller
moustafamin wrote:is it compatitble with hoteditor?
I see no problems with compability, but it isn't testet with hoteditor.

Re: [RC] HighSlide Attachment & IMG MOD 1.0.1

Posted: Sat Mar 15, 2008 7:20 pm
by lefty74
very, very cool, had the link already from a mate but its much easier to follow instructions then trying to figure it out myself.

thanks very much

p.s. the install instructions seem a bit muddled up at places

Re: [RC] HighSlide Attachment & IMG MOD 1.0.1

Posted: Sat Mar 15, 2008 7:44 pm
by stokerpiller
lefty74 wrote:very, very cool, had the link already from a mate but its much easier to follow instructions then trying to figure it out myself.

thanks very much

p.s. the install instructions seem a bit muddled up at places
Thanks Lefty74

We will have a look at the modx instructions. It is our first modx file.
I think we will use Geoff's automatic modx creator on next update :)

Re: [RC] HighSlide Attachment & IMG MOD 1.0.1

Posted: Sat Mar 15, 2008 7:57 pm
by lefty74
have a look at evil's mod to modx converter, works a treat from what i can tell. only the installation time needs amending.

Re: [RC] HighSlide Attachment & IMG MOD 1.0.2

Posted: Sat Mar 15, 2008 9:29 pm
by joebart72
One word : GREAT !!!! :D

Re: [RC] HighSlide Attachment & IMG MOD 1.0.2

Posted: Sat Mar 15, 2008 9:56 pm
by stokerpiller
joebart72 wrote:One word : GREAT !!!! :D
Thanks joebart
I am glad You liked it.

However I have visited Your forum. Looks great by the way :)
But i noticed that Your forum images on the index also is affected by the Highslide Mod.
I mean all the small images.
To prevent this, You have to create a new custom img bbcode in ACP and use that when You want images in Your forum description.

Re: [RC] HighSlide Attachment & IMG MOD 1.0.2

Posted: Sat Mar 15, 2008 10:15 pm
by saaiberke
I am having problems with this mod.

In Prosilver I see the cursor changing when I hover over the image, when I click it the image is loaded in a new browsertab and doesn't use the highslide functions.

On Subsilver2 and BF_VISTA style, it doesn't work at all. :(

The iùages in my signature are affected, when I click them, they get a border around them, and that is all :)

Any ideas what might be wrong?

Grtz,

Nic

EDIT: I found what was wrong, the mod is not compatible with the prime links mod.

Re: [RC] HighSlide Attachment & IMG MOD 1.0.2

Posted: Sat Mar 15, 2008 10:31 pm
by stokerpiller
saaiberke wrote:I am having problems with this mod.

In Prosilver I see the cursor changing when I hover over the image, when I click it the image is loaded in a new browsertab and doesn't use the highslide functions.

On Subsilver2 and BF_VISTA style, it doesn't work at all. :(

The iùages in my signature are affected, when I click them, they get a border around them, and that is all :)

Any ideas what might be wrong?

Grtz,

Nic

EDIT: I found what was wrong, the mod is not compatible with the prime links mod.
Hello saaiberke

Is it images inserted with the Img BBCode that doesn't work or attached images?
Do You have the Prime Links installed?
If so make sure to update it to the latest version.

Purge cache, refresh styles and templates in ACP?

Re: [RC] HighSlide Attachment & IMG MOD 1.0.2

Posted: Sat Mar 15, 2008 10:35 pm
by stokerpiller
Okay, You found out the compatibility probs with prime links.
Just update to the newest version of prime links and it will be fine.
So actually this mod is compatible with Prime Links, just only the newest version :)

The edit of the bbcode.php is the one that affects the img BBCode.
You can undo this edit or create a new image BBCode in ACP. Then You will have an image BBCode that doesn't get affected by this mod.
That should be the solution to small images in sig and forum descriptions.

Re: [RC] HighSlide Attachment & IMG MOD 1.0.2

Posted: Sat Mar 15, 2008 10:52 pm
by saaiberke
Thank you very much, it works now. The only problem I have left is that I don't see zoomin.cur in Subsilver2 and themes based on subsilver2, but once the picture opens up I can see zoomout.cur. I also don't see fullexpand.gif on the picture as I do in Prosilver.

I refreshed cache and styles several times :)

But I'm glad it is already working now :)

Thank you!

Nic

Re: [RC] HighSlide Attachment & IMG MOD 1.0.2

Posted: Sat Mar 15, 2008 11:05 pm
by stokerpiller
saaiberke wrote:Thank you very much, it works now. The only problem I have left is that I don't see zoomin.cur in Subsilver2 and themes based on subsilver2, but once the picture opens up I can see zoomout.cur. I also don't see fullexpand.gif on the picture as I do in Prosilver.

I refreshed cache and styles several times :)

But I'm glad it is already working now :)

Thank you!

Nic
Well, an hour ago or so I updated the mod instructions and there where an error in the subsilver2 instructions :oops:
Use the the same css for subsilver2 as You did for Prosilver.

Anyway, the mod instructions is updated now.

Re: [RC] HighSlide Attachment & IMG MOD 1.0.2

Posted: Sat Mar 15, 2008 11:38 pm
by joebart72
I've got a little problem with my signature( in flash). Look at this :

Image

It works with gif, jpg or png... but not with flash 8-)

Re: [RC] HighSlide Attachment & IMG MOD 1.0.2

Posted: Sat Mar 15, 2008 11:59 pm
by MrC
Nice, this is what i was waiting for.

I made an addition for the NV gallery

First i changed the location of the highslide folder, i moved it to the template folder.
Then the highslide folder path in overall_header.html must be changed

open overall_header.html

Find:

Code: Select all

<script type="text/javascript" src="highslide/highslide-full.js"></script>
Replace with:

Code: Select all

<script type="text/javascript" src="{T_TEMPLATE_PATH}/highslide/highslide-full.js"></script>
Find:

Code: Select all

hs.graphicsDir = 'highslide/graphics/';
Replace with:

Code: Select all

hs.graphicsDir = '{T_TEMPLATE_PATH}/highslide/graphics/';
Now open gallery_page_body.html

Find and remove:

Code: Select all

<script type="text/javascript" src="{T_TEMPLATE_PATH}/gallery_lytebox.js"></script>
<script type="text/javascript" >
	if (window.addEventListener) {
		window.addEventListener("load",initLytebox,false);
	} else if (window.attachEvent) {
		window.attachEvent("onload",initLytebox);
	} else {
		window.onload = function() {initLytebox();}
	}
	function initLytebox() {
		var imgMaxWidth = {IMAGE_RSZ_WIDTH};
		var imgWarning = '';
		myLytebox = new LyteBox(imgMaxWidth, imgWarning);
	}
</script>
Find:

Code: Select all

<a href="{U_IMAGE}" rel="lytebox" title="{IMAGE_NAME}" class="image-resize"><img src="{U_IMAGE}" alt="{IMAGE_NAME}" title="{IMAGE_NAME}" style="max-height: {IMAGE_RSZ_HEIGHT}px; max-width: {IMAGE_RSZ_WIDTH}px;" /></a></div>
Replace with:

Code: Select all

<a href="{U_IMAGE}" rel="highslide" onclick="return hs.expand(this)" title="{IMAGE_NAME}" class="highslide"><img src="{U_IMAGE}" alt="{IMAGE_NAME}" title="{IMAGE_NAME}" style="max-height: {IMAGE_RSZ_HEIGHT}px; max-width: {IMAGE_RSZ_WIDTH}px;" /></a></div>
CSS part

Find:

Code: Select all

cursor: url(highslide/graphics/zoomin.cur), pointer;
Replace with:

Code: Select all

cursor: url({T_TEMPLATE_PATH}/highslide/graphics/zoomin.cur), pointer;
Find:

Code: Select all

background-image: url(highslide/graphics/loader.white.gif);
Replace with:

Code: Select all

background-image: url({T_TEMPLATE_PATH}/highslide/graphics/loader.white.gif);
Find:

Code: Select all

background: url(highslide/graphics/fullexpand.gif) no-repeat;
Replace with:

Code: Select all

background: url({T_TEMPLATE_PATH}/highslide/graphics/fullexpand.gif) no-repeat;

Find:

Code: Select all

background: url(highslide/graphics/controlbar4.gif);
Replace with:

Code: Select all

background: url({T_TEMPLATE_PATH}/highslide/graphics/controlbar4.gif);
Find:

Code: Select all

background-image: url(highslide/graphics/controlbar4-hover.gif);
Replace with:

Code: Select all

background-image: url({T_TEMPLATE_PATH}/highslide/graphics/controlbar4-hover.gif);
You can also remove the gallery_lytebox.css file from the theme folder.