Images Outside phpBB

Discussion forum for MOD Writers regarding MOD Development.
Locked
User avatar
EsrarliKapi
Registered User
Posts: 29
Joined: Thu Jul 03, 2008 12:16 pm
Location: Ankara
Contact:

Images Outside phpBB

Post by EsrarliKapi » Tue Mar 17, 2009 12:31 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.4
What is your board's URL?
How did you install your board? I installed my board myself
Is your board a fresh install or a conversion? Conversion from phpBB2
Do you have any MODs installed? No
Please describe your problem. My forum is in the "forum" directory. (mysite.com/forum) I created a page in the site root (mysite.com/) and I fetch information from my forum. But the icons does not appear, like topic icon, last post icon, avatar. I use the method phpBB uses like:

Code: Select all

$user->img($folder_img, $folder_alt, false, '', 'src')
Also, when I view the image url and try to reach that url, I can see the image there.
What styles do you currently have installed? Prosilver Special Edition
What language(s) is your board currently using? Turkish
Which database type/version are you using? MySQL 5
What is your level of experience? Intermediate
Generated by SRT Generator ($Rev: 2853 $)
[Ultimate Simplicity]

User avatar
EsrarliKapi
Registered User
Posts: 29
Joined: Thu Jul 03, 2008 12:16 pm
Location: Ankara
Contact:

Re: Images Outside phpBB

Post by EsrarliKapi » Wed Mar 18, 2009 7:24 am

Although I hate bumping my topics, I hope this helps...
[Ultimate Simplicity]

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Images Outside phpBB

Post by karlsemple » Wed Mar 18, 2009 7:28 am

This is not really a phpBB support issue, you may find you have more success asking in the mod writers discussion as what you are doing is custom coding using the phpBB code base :)

Although the page in your root directory...I am assuming it uses the phpBB session? If not you may find that you need to specify the phpbb_root_path in your external page.
Image

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Images Outside phpBB

Post by ric323 » Wed Mar 18, 2009 7:59 am

-- moved to "MOD Writers Discussion"
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

User avatar
EsrarliKapi
Registered User
Posts: 29
Joined: Thu Jul 03, 2008 12:16 pm
Location: Ankara
Contact:

Re: Images Outside phpBB

Post by EsrarliKapi » Wed Mar 18, 2009 8:06 am

Thanks.

I do define $phpbb_root_path correctly. My page wouldn't be working otherwise. The output is like this:

Code: Select all

<img src="./forum/styles/prosilver_se/imageset/topic_read.gif" width="27" height="27" alt="Yeni mesaj yok" title="Yeni mesaj yok" />
When I right click and select "View Image" it gives me a 404 error. But when I paste the url to my browser address bar and try viewing the image, it shows. I'm guessing it could be a permission issue. But again, all images are shown correctly in my forum. Any ideas?

----

Edit:

Solved the issue. It was because of an .htaccess file I totally forgot about.
[Ultimate Simplicity]

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Images Outside phpBB

Post by ric323 » Wed Mar 18, 2009 8:30 am

Please supply your board's address so we can see this happening.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Locked

Return to “[3.0.x] MOD Writers Discussion”