+500 forums = overheated forums table?

Discussion forum for MOD Writers regarding MOD Development.
User avatar
Sierron
Registered User
Posts: 241
Joined: Fri Apr 30, 2010 10:22 am
Location: Germany
Name: Artur
Contact:

Re: +500 forums = overheated forums table?

Post by Sierron » Tue Aug 17, 2010 2:39 am

Wow, that's nice.

But if you want to use it like you said, you at least need an (own) server for that. 500+ forums give a big html file to lo...

Well... I looked at your site. You have over 500+ forums. That's true. The most are in subcategories. So phpBB3 can handle 500+ forums. Nice to know :o .


But that doesn't say anything about, if it can handle 500+ at once. As an example in the index or something.
Multilanguage TimeSplitters Site

If you need support, I suggest you to use the Support Request Template for your questions on this board. If you have some serious problems, the Support Toolkit can fix it (depends on the problem).

Thanks in advance
Registered User
Posts: 173
Joined: Mon Dec 28, 2009 8:17 am

Re: +500 forums = overheated forums table?

Post by Thanks in advance » Tue Oct 11, 2011 4:41 pm

D¡cky wrote:I maintain a board with approximately 500 forums and it is on a regular shared hosting account. There have not been any problems with the basic running of the board. The only problems there have been is when moving forums around. Sometimes when moving a forum, it can make a mess of the forum tree and you will need to rebuild it.
As I'm pretty much in the same situation (~500 forums, Shared Hosting), may I ask how you rebuild / repair the forum structure? I know the STK can solve Left/Right ID's, but AFAIK it does nothing with the forum_parents-column. There also exists a pretty old script (fix.php), but I don't know if it can still be used, it too has limitations pointed out here. Thanks!

manic2
Registered User
Posts: 435
Joined: Thu Jun 12, 2008 9:16 pm

Re: +500 forums = overheated forums table?

Post by manic2 » Wed Oct 12, 2011 8:57 am

Thanks in advance wrote: but AFAIK it does nothing with the forum_parents-column.
AFAIK that column rebuilds itself as & when you click on each forum using this code in \includes\functions_display.php:-

Code: Select all

		if ($forum_data['forum_parents'] == '')
		{
			$sql = 'SELECT forum_id, forum_name, forum_type
				FROM ' . FORUMS_TABLE . '
				WHERE left_id < ' . $forum_data['left_id'] . '
					AND right_id > ' . $forum_data['right_id'] . '
				ORDER BY left_id ASC';
			$result = $db->sql_query($sql);

			while ($row = $db->sql_fetchrow($result))
			{
				$forum_parents[$row['forum_id']] = array($row['forum_name'], (int) $row['forum_type']);
			}
			$db->sql_freeresult($result);

			$forum_data['forum_parents'] = serialize($forum_parents);

			$sql = 'UPDATE ' . FORUMS_TABLE . "
				SET forum_parents = '" . $db->sql_escape($forum_data['forum_parents']) . "'
				WHERE parent_id = " . $forum_data['parent_id'];
			$db->sql_query($sql);
manic

Locked

Return to “[3.0.x] MOD Writers Discussion”