[BUG] Apply utf-8 chars in urls

Discussion forum for MOD Writers regarding MOD Development.
User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

[BUG] Apply utf-8 chars in urls

Post by 1234homie »

Firstly, sorry that I write here but I do not know where he is now moved bugtracker so I write here xD

I found a bug, if we add the link points utf-8 if we get a link and the text that it should be a link.

btw. I used google translator to translate this so sorry for mistakes :)

BUG example:
http://pl.wikipedia.org/wiki/XMLHtótpRequest
User avatar
Erik Frèrejean
Former Team Member
Posts: 9899
Joined: Tue Oct 09, 2007 9:09 am
Location: The Netherlands, 3.0.x Support Forum
Name: Erik Frèrejean
Contact:

Re: [BUG] Apply utf-8 chars in urls

Post by Erik Frèrejean »

Bugs should go in the bug tracker, not in the MOD writers discussion.

With regards to this issue, there have been multiple topics about this. See also this response of a def
nickvergessen wrote:non-ascii are not supported because the rfc say so
Btw, the correct url of the wiki article is http://i18n.ro/Rom%5Eana_pe_dispozitive_mobile
you get that, when you press the Pagină-link (first tab) on that page.

There are several tickets about utf8 in domains/urls and I think current status was not in 3.0 but maybe in 3.1 or later.
Support Toolkit | Support Request Template | Knowledge Base | phpBB 3.0.x documentation
I don't give support via PM or IM! (all unsolicited pms will be trashed!)
Desdenova
Registered User
Posts: 646
Joined: Sat Feb 23, 2008 7:25 pm

Re: [BUG] Apply utf-8 chars in urls

Post by Desdenova »

That should definitely be reconsidered now that unicode is now accepted for use in domain names.
See: http://blog.icann.org/2010/05/idn-cctlds/
User avatar
Erik Frèrejean
Former Team Member
Posts: 9899
Joined: Tue Oct 09, 2007 9:09 am
Location: The Netherlands, 3.0.x Support Forum
Name: Erik Frèrejean
Contact:

Re: [BUG] Apply utf-8 chars in urls

Post by Erik Frèrejean »

This was a pretty recent statement ;). If there are tickets about this issue I'm sure that it will be reconsidered at some point.
Support Toolkit | Support Request Template | Knowledge Base | phpBB 3.0.x documentation
I don't give support via PM or IM! (all unsolicited pms will be trashed!)
Desdenova
Registered User
Posts: 646
Joined: Sat Feb 23, 2008 7:25 pm

Re: [BUG] Apply utf-8 chars in urls

Post by Desdenova »

Erik Frèrejean wrote:This was a pretty recent statement ;). If there are tickets about this issue I'm sure that it will be reconsidered at some point.
The changes were made official in October of 2009; it's the implementation that is recent.
User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

Re: [BUG] Apply utf-8 chars in urls

Post by 1234homie »

topic posted 1 year ago and nothing ;/
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 26937
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [BUG] Apply utf-8 chars in urls

Post by Paul »

There has been no major release in that year, so thats not really weird at all ;). And besides that, this forum is not ment for bugs, the bugtracker is there for a reason :).
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [BUG] Apply utf-8 chars in urls

Post by 4_seven »

Dr.Death wrote: http://www.phpbb.com/bugs/phpbb3/ticket ... t_id=12339

Code: Select all

 Posted by Acyd Burn (Development Team Leader) on Jun 11th 2007, 11:15
To be specific: Olympus supports punycode but not special chars within domains. 
Posted by Acyd Burn (Development Team Leader) on May 28th 2008, 09:58
3.0.x will never support it. ;) Not in the near future. We may of course think about backporting it from the 3.2.x line once it is done there.
-----------------------------------------------------------------------------

Only thing you can do is an alternative url-bbcode, which allows special-chars in urls

Demo: http://www.4seven.de/forum/1/viewtopic. ... p=482#p482
BBCode

Code: Select all

Removed insecure BBcode. The warning is there for a reason.
If you want this, ignore the {TEXT} Security Warning. At least it's your choice..
Source: removed
Last edited by Paul on Mon Jun 27, 2011 11:24 am, edited 2 times in total.
Reason: Removed.
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
AmigoJack
Registered User
Posts: 5795
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: [BUG] Apply utf-8 chars in urls

Post by AmigoJack »

For those who haven't found out yet: extending this RegEx also allows IDN URLs everywhere.
  • The worst thing about censorship is ███████████
  • "The problem is probably not my English but you do not want to understand correctly. ... We will not come anybody anyway, nevertheless, it's best to shit this." Affin, 2018-11-20
  • "But this shit is not here for you. You can follow with your. Maybe the question, instead, was for you, who know, so you shoved us how you are." axe70, 2020-10-10
User avatar
Erik Frèrejean
Former Team Member
Posts: 9899
Joined: Tue Oct 09, 2007 9:09 am
Location: The Netherlands, 3.0.x Support Forum
Name: Erik Frèrejean
Contact:

Re: [BUG] Apply utf-8 chars in urls

Post by Erik Frèrejean »

4_seven wrote:Only thing you can do is an alternative url-bbcode, which allows special-chars in urls

Demo: http://www.4seven.de/forum/1/viewtopic. ... p=482#p482
NEVER use the {TEXT} token inside HTML tags!
Support Toolkit | Support Request Template | Knowledge Base | phpBB 3.0.x documentation
I don't give support via PM or IM! (all unsolicited pms will be trashed!)
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [BUG] Apply utf-8 chars in urls

Post by 4_seven »

Because of that i wrote: "It's your choice". As 'proof of concept' only, that it's possible.
Last edited by 4_seven on Mon Jun 27, 2011 10:52 pm, edited 1 time in total.
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
Erik Frèrejean
Former Team Member
Posts: 9899
Joined: Tue Oct 09, 2007 9:09 am
Location: The Netherlands, 3.0.x Support Forum
Name: Erik Frèrejean
Contact:

Re: [BUG] Apply utf-8 chars in urls

Post by Erik Frèrejean »

We (for obvious reasons) do not allow the postal of snippets/MODs/BBCodes/etc that potentially compromise the phpBB security model. Using a {TEXT} token in a HTML tag is exactly that and therefore can't be posted on this board.
Support Toolkit | Support Request Template | Knowledge Base | phpBB 3.0.x documentation
I don't give support via PM or IM! (all unsolicited pms will be trashed!)
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [BUG] Apply utf-8 chars in urls

Post by 4_seven »

i understand..
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

Re: [BUG] Apply utf-8 chars in urls

Post by 1234homie »

AmigoJack wrote:For those who haven't found out yet: extending this RegEx also allows IDN URLs everywhere.
What about security in this case?

edit://

http://area51.phpbb.com/phpBB/viewtopic ... 85#p217485 - 4.0 OMG! I will die by natural death before it will be released xD
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [BUG] Apply utf-8 chars in urls

Post by 4_seven »

EXreaction wrote:I've not extensively tested it however, but didn't notice any problems (can't think of any security issues either).
may another voice say something about this..
Current Mods | Mod Base | php(BB) programming | No help via PM
Locked

Return to “[3.0.x] MOD Writers Discussion”