Page 1 of 1

AutoMOD does not copy files to other Styles...

Posted: Tue Sep 04, 2012 1:59 pm
by MasterZ
I got my new MOD, Push Notifications, packaged up and out for people to download but I am still running into one installation issue.

It installs correctly but when you go to apply the prosilver style to my prosilver-based style it will not copy over the files.

I am guessing that means there is something wrong with my MODX file, but since I created that using the phpBB MODX creator I do not know what it could be.

Any ideas?

Re: AutoMOD does not copy files to other Styles...

Posted: Fri Sep 14, 2012 2:50 am
by Drakkim
AutoMOD works this way by design because not all templates are compatible. What I do with my mods is make a separate installer just for my other templates... If your template is prosilver-based, it should be as easy as editing your current install file and replacing "/prosilver/" with "/other_style_directory/".

Not, though, do not include those edits in the main installer... it will break the mod for everyone who doesn't have that style installed!

Now, I'm gonna go look at that mod because I've been wanting exactly that feature...

Re: AutoMOD does not copy files to other Styles...

Posted: Fri Sep 14, 2012 3:42 am
by MasterZ
Thanks for the tip, and I hope you enjoy the MOD.

With most MODs when I go to the mod info in AutoMOD I can select to apply the prosilver (or subsilver if the MOD includes instructions for it) to any theme I have installed. Why does this work for others but not for mine? I have looked through their install file and cannot find any significant differences.