version numbers in includes/ucp/info/ucp_foo.php

Discussion forum for MOD Writers regarding MOD Development.
Locked
asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

version numbers in includes/ucp/info/ucp_foo.php

Post by asinshesq »

When we add a ucp module we create a file in includes/ucp/info that looks something like this:

Code: Select all

<?php
/**
*
* @package ucp
* @version $Id: includes/ucp/info/ucp_foo
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
*
*/

/**
* @package module_install
*/
class ucp_foo_info
{
	function module()
	{
		return array(
			'filename'	=> 'ucp_foo',
			'title'		=> 'UCP_FOO',
			'version'	=> '1.0.4',
			'modes'		=> array(
				'foo'			=> array('title' => 'UCP_FOO', 'auth' => '', 'cat' => ''),
			),
		);
	}

	function install()
	{
	}

	function uninstall()
	{
	}
}

?>
How is the version number (1.0.4 in the above example) actually used? It doesn't seem to need to match the version number for the mod in question...any reason to update that number to match the version number for the mod in question?
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 26349
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: version numbers in includes/ucp/info/ucp_foo.php

Post by Paul »

I don't think it is used at all in 3.0.x.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
Locked

Return to “[3.0.x] MOD Writers Discussion”