Page 1 of 1

Can I use the mods that are here in development?

Posted: Sat Jul 28, 2007 5:34 pm
by Flahooper1
I was wondering if I am abl to use the mods that are in development or should I wait until they are considered complete. Any advice?

Thanks,

Wade

Re: Can I use the mods that are here in development?

Posted: Sat Jul 28, 2007 6:01 pm
by IPB_Refugee
Hi Wade,

you can use them but only at your own risk. As the phpBB team says: "No MODs within this forum [the development forum, IPB_Refugee] should be used within a live environment!"

So when you have not only a testboard it's better to wait till MODs are released by the phpBB team. (Or, when you know php, you can check the MOD's code by yourself.)

Regards
Wolfgang

Re: Can I use the mods that are here in development?

Posted: Sun Jul 29, 2007 1:26 am
by Flahooper1
When will some of these mods possibly be available for use?

Re: Can I use the mods that are here in development?

Posted: Sun Jul 29, 2007 1:46 am
by IPB_Refugee
Probably not before the gold release of phpBB3.

Regards
Wolfgang

Re: Can I use the mods that are here in development?

Posted: Wed Aug 01, 2007 5:21 am
by IPB_Refugee

Re: Can I use the mods that are here in development?

Posted: Wed Aug 01, 2007 7:44 am
by david63
One other point to bear in mind is that any mods that are here may not work with subsequent versions of phpbb3 due to code/database changes. This will be less of an issue once phpbb3 goes gold.

Re: Can I use the mods that are here in development?

Posted: Wed Aug 01, 2007 12:32 pm
by smithy_dll
Hello,

The MODs are personal projects of people unaffiliated with the phpBB Teams (phpBB Group). As such we cannot give you a time frame for their release as that is up to each individual developer.

You use MODs at your own risk as always, with the added risk of in development MODs as being marked by the creator as still being in development, and not having undergone inspection by the phpBB Modifications Team for compatibility, security, and other issues.

Still no guarantees are made.

If you are happy with the potential consequences and know what you are doing, there is nothing I can do to stop you using the MODs other than giving my advice which echos the messages splayed around the forums, documentation, and even this post.

smithy_dll

Re: Can I use the mods that are here in development?

Posted: Wed Aug 01, 2007 1:41 pm
by IPB_Refugee
Hi smithy_dll,

just a short question: The phpBB MOD Team doesn't release MODs that would not run with the gold version of Olympus, right? (That would definitely not be very funny in my opinion.)

Regards
Wolfgang

Re: Can I use the mods that are here in development?

Posted: Wed Aug 01, 2007 3:03 pm
by david63
IPB_Refugee wrote:Hi smithy_dll,

just a short question: The phpBB MOD Team doesn't release MODs that would not run with the gold version of Olympus, right? (That would definitely not be very funny in my opinion.)

Regards
Wolfgang
If you look at the mods that have been released it says which version that they are compatible with and at the moment the only version that they can be compatible with is RC4. That is not to say that they will not work with a future version but it is the mod author's responsibility to ensure that their mod(s) are compatible with the latest release.

Re: Can I use the mods that are here in development?

Posted: Wed Aug 01, 2007 3:55 pm
by IPB_Refugee
Thanks for the explanation, David!

(I think that there will not be many MODs released before the gold version will come over us and therefore I don't expect problems. But I'm not sure if it's very clever to release MODs that might not be compatible with Olympus. But I _am_ sure that the MOD team knows that and will make the right decisions.)

Regards
Wolfgang