Style problem

For support and discussion related to templates, themes, and imagesets in phpBB 3.0.
Scam Warning
Locked
Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Style problem

Post by Gunnar » Sun Jun 22, 2008 5:58 pm

I have a forum that i created a theme for from rhuk_milkyway (joomla)

here is what it should look like...

http://img524.imageshack.us/img524/796/1forumfh9.png

when i click to see the admin section where i need to relogin...

http://img357.imageshack.us/img357/8256/2forumhm3.png

when i try to relogin (to the admin section), i get no error, i just get redirected to the frontpage of the forum...

so, basically i cannot access the admin section ... :(

User avatar
TheIlluminative
Former Team Member
Posts: 2451
Joined: Thu Jun 26, 2003 11:34 pm
Location: Egypt
Name: Mahmoud
Contact:

Re: Style problem

Post by TheIlluminative » Sun Jun 22, 2008 6:00 pm

could u plz include overall_header.html ??

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style problem

Post by Gunnar » Sun Jun 22, 2008 6:06 pm


User avatar
TheIlluminative
Former Team Member
Posts: 2451
Joined: Thu Jun 26, 2003 11:34 pm
Location: Egypt
Name: Mahmoud
Contact:

Re: Style problem

Post by TheIlluminative » Sun Jun 22, 2008 6:12 pm

change this

Code: Select all

               <link rel="stylesheet" href="/v/s/styles/spjall/extra/kjarni/css/template.css" type="text/css" />
                <link rel="stylesheet" href="/v/s/styles/spjall/extra/kjarni/css/black.css" type="text/css" />
to

Code: Select all

               <link rel="stylesheet" href="{T_THEME_PATH}/template.css" type="text/css" />
                <link rel="stylesheet" href="{T_THEME_PATH}/black.css" type="text/css" />
and

Code: Select all

                <!--[if lte IE 6]>
                        <link href="/v/s/styles/spjall/extra/kjarni/css/ieonly.css" rel="stylesheet" type="text/css" />
                <![endif]-->
to

Code: Select all

                <!--[if lte IE 6]>
                        <link href="{T_THEME_PATH}/ieonly.css" rel="stylesheet" type="text/css" />
                <![endif]-->

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style problem

Post by Gunnar » Sun Jun 22, 2008 8:38 pm

is it not okay to use this ?


<link href="{T_THEME_PATH}/extra/kjarni/css/ieonly.css" rel="stylesheet" type="text/css" />

User avatar
TheIlluminative
Former Team Member
Posts: 2451
Joined: Thu Jun 26, 2003 11:34 pm
Location: Egypt
Name: Mahmoud
Contact:

Re: Style problem

Post by TheIlluminative » Sun Jun 22, 2008 8:42 pm

no, as {T_THEME_PATH} includes the path to the theme folder in your style, so you have to do the following:
use

Code: Select all

<link href="{T_THEME_PATH}/extra/kjarni/css/ieonly.css" rel="stylesheet" type="text/css" />
and put the "extra" folder with all it's content in the "theme" folder of your style..

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style problem

Post by Gunnar » Sun Jun 22, 2008 10:05 pm

ok i did what you said...

http://pastebin.com/m321b508e

now it is worse...

see here
this should be the admin relogin site thingy

http://img80.imageshack.us/img80/9537/3forumyl8.png

the forum itself works like it should...

User avatar
TheIlluminative
Former Team Member
Posts: 2451
Joined: Thu Jun 26, 2003 11:34 pm
Location: Egypt
Name: Mahmoud
Contact:

Re: Style problem

Post by TheIlluminative » Sun Jun 22, 2008 10:10 pm

are you sure u have the extra folder inside theme folder ??

plz provide a link to your live board ??

User avatar
TheIlluminative
Former Team Member
Posts: 2451
Joined: Thu Jun 26, 2003 11:34 pm
Location: Egypt
Name: Mahmoud
Contact:

Re: Style problem

Post by TheIlluminative » Sun Jun 22, 2008 10:11 pm

also try to make it

Code: Select all

<link rel="stylesheet" href="{T_THEME_PATH}/template.css" type="text/css" />
and put the CSS files inside the theme folder directly.. without subfolders..

Edit: for 1 last time, try this, on the first overall_header.html u gave me, http://pastebin.com/m5046cc93
try this, change

Code: Select all

{T_STYLESHEET_LINK}
into

Code: Select all

{T_THEME_PATH}/stylesheet.css
and leave the things as they are, sorry I didn't notice this at first, but I think this will make it..

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style problem

Post by Gunnar » Mon Jun 23, 2008 6:53 pm

okay now i have modified like you said

http://pastebin.com/m71be791b

if you want to see the live site you can see the url in the base tag in the code :P

<base href="http://kjarni.cc/v/s/" />

everything seems right and i used a debugger in firefox (firebug) to try to find out what is wrong with the admin relogin site thingy...

on the forum front page lets use template.css

http://img174.imageshack.us/img174/4862/4forumcd1.png

and the admin login site...

http://img372.imageshack.us/img372/2678/5forumoa2.png (a 404 error wtf :S)

the ./../ confuses me :S

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style problem

Post by Gunnar » Wed Jun 25, 2008 6:24 am

bumping
I really need help !

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style problem

Post by Gunnar » Wed Jun 25, 2008 9:07 pm

anyone pleease help me ....

User avatar
Raimon
Former Team Member
Posts: 12088
Joined: Tue May 30, 2006 5:31 pm
Location: Netherlands
Name: Raimon Meuldijk
Contact:

Re: Style problem

Post by Raimon » Wed Jun 25, 2008 10:05 pm

Whats the use of the

Code: Select all

<base href="http://kjarni.cc/v/s/" />
on that page ?
The

Code: Select all

{T_TEMPLATE_PATH}
defined all the location of your board , so have you add that with a reason?
Need phpBB installation, extenstions, Styles or integrate phpBB with you website?
Contact me for fair prices and good service!

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style problem

Post by Gunnar » Wed Jun 25, 2008 10:08 pm

Raimon wrote:Whats the use of the

Code: Select all

<base href="http://kjarni.cc/v/s/" />
on that page ?
The

Code: Select all

{T_TEMPLATE_PATH}
defined all the location of your board , so have you add that with a reason?
no idea, i think it was there to begin with....

... what :S

User avatar
Raimon
Former Team Member
Posts: 12088
Joined: Tue May 30, 2006 5:31 pm
Location: Netherlands
Name: Raimon Meuldijk
Contact:

Re: Style problem

Post by Raimon » Wed Jun 25, 2008 10:14 pm

Try to deleted the <base href="http://kjarni.cc/v/s/" /> from overall_header.html and see what then happens.
Need phpBB installation, extenstions, Styles or integrate phpBB with you website?
Contact me for fair prices and good service!

Locked

Return to “[3.0.x] Styles Support & Discussion”