New External Link on Main Menu

For support and discussion related to templates, themes, and imagesets in phpBB 3.0.
Anti-Spam Guide
terry54661
Registered User
Posts: 61
Joined: Fri Jun 19, 2009 10:42 pm
Name: Terry
Contact:

New External Link on Main Menu

Post by terry54661 »

I need to add a external link to my blog on the main menu next to Logout. I think I can do this by editing the overall_header file but cant seem to work out how to do it.


If anyone knows how this is done I would be very grateful for some help.

Thanks In Advance

Terry
Last edited by Pit$Bull on Tue Jun 29, 2010 11:51 am, edited 2 times in total.
Reason: Topic icon changed
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51456
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: New External Link on Main Menu

Post by stevemaury »

Find this:

Code: Select all

<a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="l">{L_LOGIN_LOGOUT}</a>
And replace with this:

Code: Select all

<a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="l">{L_LOGIN_LOGOUT}&nbsp<a href="Your link" title="Your title" </a>
The link placed here will only show to members who are logged in. If you want it to show to everyone, post back.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
chenpm
Registered User
Posts: 68
Joined: Sun Apr 11, 2010 9:40 am

Re: New External Link on Main Menu

Post by chenpm »

I would like to have the code to enable a reader (member or visitor) to link with an external page added to the header list of "FAQ", "Register", and "Login."

I presume that would be added to: http://mysite.com/styles/prosilver/temp ... eader.html

thank you very much

Phil
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51456
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: New External Link on Main Menu

Post by stevemaury »

That's the file.

FIND:

Code: Select all

<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
REPLACE WITH:

Code: Select all

<a href="Your link" title="Your title" </a>&nbsp;<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
Also, in the future, it is better to start your own topic rather than hijack an old topic.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
chenpm
Registered User
Posts: 68
Joined: Sun Apr 11, 2010 9:40 am

Re: New External Link on Main Menu

Post by chenpm »

Steve,

I did start my own topic on this, Terry54661 responded and suggested that I look at his thread. ;)

BTW, I really appreciate all the advice that you in particular have given me.

Thanks
Phil
chenpm
Registered User
Posts: 68
Joined: Sun Apr 11, 2010 9:40 am

Re: New External Link on Main Menu

Post by chenpm »

@SteveMauray,

I followed your instructions exactly. Refreshed my style's template and theme, Purged the cache and got the dreaded white screen. I restored my board to an earlier point, having learned my lesson.

My replacement text was:

<a href="http://pugetsoundspeaks.com" title="Home" </a>&nbsp;<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>

What did I do wrong?

Thanks,

Phil
User avatar
Rahber
Former Team Member
Posts: 2720
Joined: Tue Feb 12, 2008 3:39 pm
Location: Pakistan
Name: Rahber
Contact:

Re: New External Link on Main Menu

Post by Rahber »

chenpm wrote:
My replacement text was:

<a href="http://pugetsoundspeaks.com" title="Home" </a>&nbsp;<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>

What did I do wrong?
it should be like this

Code: Select all

<li class="icon-faq"><a href="http://pugetsoundspeaks.com" title="Home">Home</a></li><li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
chenpm
Registered User
Posts: 68
Joined: Sun Apr 11, 2010 9:40 am

Re: New External Link on Main Menu

Post by chenpm »

Thanks, tried that and it still doesn't work. On the other hand, I am getting pretty good at restoring my board from the dread "white screen" ;)
terry54661
Registered User
Posts: 61
Joined: Fri Jun 19, 2009 10:42 pm
Name: Terry
Contact:

Re: New External Link on Main Menu

Post by terry54661 »

lol try posting the code on here so people can see what your trying to do. Use
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51456
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: New External Link on Main Menu

Post by stevemaury »

THIS CODE:

Code: Select all

 <ul class="linklist rightside">

<li class="icon-home"><a href="http://pugetsoundspeaks.com">HOME</a></li><li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
Gives THIS RESULT:
home.png
home.png (5.31 KiB) Viewed 534 times
What are you using to edit the files?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
chenpm
Registered User
Posts: 68
Joined: Sun Apr 11, 2010 9:40 am

Re: New External Link on Main Menu

Post by chenpm »

Steve,

thanks, you're back. That is probably the code I need. I am using Ipage's FileManager.

Let me try the new code.

Thanks

Phil
chenpm
Registered User
Posts: 68
Joined: Sun Apr 11, 2010 9:40 am

Re: New External Link on Main Menu

Post by chenpm »

I pasted in your code, refreshed the template and the theme under prosilver and clear my cache and still get the white screen. IPage has some thing called File Manager and this allows you to edit files. I have used this successfully each time I have gotten code changes from you or others.

the full existing section is:

<ul class="linklist rightside">
<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
<!-- IF not S_IS_BOT -->
<!-- IF S_DISPLAY_MEMBERLIST --><li class="icon-members"><a href="{U_MEMBERLIST}" title="{L_MEMBERLIST_EXPLAIN}">{L_MEMBERLIST}</a></li><!-- ENDIF -->
<!-- IF not S_USER_LOGGED_IN and S_REGISTER_ENABLED and not (S_SHOW_COPPA or S_REGISTRATION) --><li class="icon-register"><a href="{U_REGISTER}">{L_REGISTER}</a></li><!-- ENDIF -->
<li class="icon-logout"><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="x">{L_LOGIN_LOGOUT}</a></li>
<!-- ENDIF -->
</ul>


I can't figure out why this is tanking each time. Your last code change should have done the trick.

The section looked like this after the change:

<ul class="linklist rightside">

<li class="icon-home"><a href="http://pugetsoundspeaks.com">HOME</a></li><li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
<!-- IF not S_IS_BOT -->
<!-- IF S_DISPLAY_MEMBERLIST --><li class="icon-members"><a href="{U_MEMBERLIST}" title="{L_MEMBERLIST_EXPLAIN}">{L_MEMBERLIST}</a></li><!-- ENDIF -->
<!-- IF not S_USER_LOGGED_IN and S_REGISTER_ENABLED and not (S_SHOW_COPPA or S_REGISTRATION) --><li class="icon-register"><a href="{U_REGISTER}">{L_REGISTER}</a></li><!-- ENDIF -->
<li class="icon-logout"><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="x">{L_LOGIN_LOGOUT}</a></li>
<!-- ENDIF -->
</ul>


I can't for the life of me figure out what I am doing wrong.

Thanks,

Phil
Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: New External Link on Main Menu

Post by Pit$Bull »

Use a simple text editor such as Notepad++ with an FTP client such as FileZilla for uploading
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51456
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: New External Link on Main Menu

Post by stevemaury »

Yes, that editor is hosing the files.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
chenpm
Registered User
Posts: 68
Joined: Sun Apr 11, 2010 9:40 am

Re: New External Link on Main Menu

Post by chenpm »

To Steve and Pit

There is only one thing I can say to you.

bow.gif
bow.gif (1.14 KiB) Viewed 493 times
bow.gif
bow.gif (1.14 KiB) Viewed 493 times
bow.gif
bow.gif (1.14 KiB) Viewed 493 times
Worked like a charm, just like you said.
Thanks,
Phil
Locked

Return to “[3.0.x] Styles Support & Discussion”