Unable to change style - code missing

For support and discussion related to templates, themes, and imagesets in phpBB 3.0.
Scam Warning
Locked
Crashtester
Registered User
Posts: 202
Joined: Sun Apr 18, 2010 11:57 pm

Unable to change style - code missing

Post by Crashtester »

Hi, I am using the Legacy style which inherits from Prosilver and I notice that I am missing the option to change styles from within the UCP. The option to change style is set in the ACP and other styles I have active still allow the function but for some reason it disappeared from Prosilver. See the image attached.

I cannot find the relevant file to repair this. Can anyone direct me to the file which I need to look at and if it is not too much trouble the code I need to add to restore this functionality.

I am running version 3.0.12. Many thanks.
Attachments
prosilver_missing_styles.png
prosilver_missing_styles.png (18.15 KiB) Viewed 284 times
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52001
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Unable to change style - code missing

Post by Brf »

Likely, you have overridden the style in the Board Settings.
rayminator
Registered User
Posts: 310
Joined: Wed Nov 15, 2006 1:37 pm
Name: raymond green
Contact:

Re: Unable to change style - code missing

Post by rayminator »

go to your acp in basic setting and see if you have it set Override user style: to yes or no
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52001
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Unable to change style - code missing

Post by Brf »

Board Settings, like I said.
Crashtester
Registered User
Posts: 202
Joined: Sun Apr 18, 2010 11:57 pm

Re: Unable to change style - code missing

Post by Crashtester »

Sorry guys, I did mention that it works fine on my other styles that I have installed - it's just the prosilver styles are not seeing that option.
Attachments
Board settings.png
Board settings.png (4.95 KiB) Viewed 214 times
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52001
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Unable to change style - code missing

Post by Brf »

Perhaps you have edited ucp_prefs_personal.html
Crashtester
Registered User
Posts: 202
Joined: Sun Apr 18, 2010 11:57 pm

Re: Unable to change style - code missing

Post by Crashtester »

Not deliberately. But if that is the file that contains that page data I will compare it with a clean version from Prosilver..I couldnt find the file I needed. Thanks.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52001
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Unable to change style - code missing

Post by Brf »

That template changed with 3.0.12. If you are using a new template with an old ucp script, it would do that too.
Crashtester
Registered User
Posts: 202
Joined: Sun Apr 18, 2010 11:57 pm

Re: Unable to change style - code missing

Post by Crashtester »

I have checked the code and it is in there for Prosilver and Legacy

Code: Select all

<!-- IF S_STYLE_OPTIONS and S_MORE_STYLES -->
		<dl>
			<dt><label for="style">{L_BOARD_STYLE}:</label></dt>
			<dd><select name="style" id="style">{S_STYLE_OPTIONS}</select></dd>
		</dl>
	<!-- ENDIF -->
About a week ago i upgraded my forum, I upgraded to 3.0.12 but my board is still showing as 3.0.11.

I was going to run the upgrade again from 3.0.11 to 3.0.12 to see if there were any file changes and then apply them.

How can I update the UCP script? I guess something has gone a bit wrong during all the file changes.
Locked

Return to “[3.0.x] Styles Support & Discussion”