Thread display is messing up

For support and discussion related to templates, themes, and imagesets in phpBB 3.0.
Suggested Hosts
Locked
Jaruzzu
Registered User
Posts: 8
Joined: Sun Apr 13, 2014 7:57 pm

Thread display is messing up

Post by Jaruzzu » Fri Sep 09, 2016 5:41 pm

I own an animation forum called thedarkdemon.com, which was made by modifying the we_clearblue theme. We are currently running version 3.0.13-PL1.

The problem I'm experiencing is only on a specific thread, the rest of our threads look fine. The thread contains a lot of "spoilers" and text, so I'm not sure if that's causing the problem. The thread looked fine the other day.

Here is the thread I'm referring to: http://thedarkdemon.com/viewtopic.php?f=16&t=4060

If you scroll down a bit, you can see that member's posts span the entire length of the page rather than just the center part. (View other threads to see what it should look like).

At first I thought it was an issue with the maximum character count per post, so I've tried altering the post setting in the ACP but I've had no luck in fixing it. Any help with this would be greatly appreciated!

User avatar
Brf
Support Team Member
Support Team Member
Posts: 50712
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Thread display is messing up

Post by Brf » Fri Sep 09, 2016 6:00 pm

Well, I am no styles expert, but I can see your <dl>s are not right. They are supposed to be like:

Code: Select all

<dl>
<dt> </dt>
<dd> </dd>
<dd> </dd>
<dd> </dd>
</dl>
and you have them like:

Code: Select all

<dl>
<dt> 
<dd> </dd>
</dt>
<dd> </dd>
<dd> </dd>
</dl>

Jaruzzu
Registered User
Posts: 8
Joined: Sun Apr 13, 2014 7:57 pm

Re: Thread display is messing up

Post by Jaruzzu » Fri Sep 09, 2016 7:16 pm

Thanks for the quick response Brf!

I see the code you are referring to starting on lines 216-234. I compared this to a different thread in which the comments display fine and the coding looks identical. It looks like:

Code: Select all

<dl>
<dt>
<dd> </dd>
</dt>
<dd> </dd>
<dd> </dd>
</dl>
Yet it still displays right. That might be an issue, but I'm not sure if that is the source of this display issue. I'm also not too familiar with styles so I really can't say for sure.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 50712
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Thread display is messing up

Post by Brf » Fri Sep 09, 2016 8:38 pm

Hmmm...
It looks to me that your post content div is closing too early. Maybe something to do with the nested spoiler tags or something.

Jaruzzu
Registered User
Posts: 8
Joined: Sun Apr 13, 2014 7:57 pm

Re: Thread display is messing up

Post by Jaruzzu » Fri Sep 09, 2016 9:48 pm

Thanks again for the help Brf! I was able to fix this. In case you were wondering how...

The person managing the thread set up a list using these tags

Code: Select all

[list][/list]


He started with the opening tag

Code: Select all

[list]
outside of the

Code: Select all

[spoiler][/spoiler]
and ended with the closing tag

Code: Select all

[/list]
inside of a

Code: Select all

[spoiler][/spoiler]
and for some reason phpBB didn't like that.

So all I did was move the [/list] tag outside of the [spoiler][/spoiler] tags and it fixed it.

Locked

Return to “[3.0.x] Styles Support & Discussion”

Who is online

Users browsing this forum: No registered users and 27 guests