Not able to enter Admin CP after installing a new style

For support and discussion related to templates, themes, and imagesets in phpBB 3.0.
Suggested Hosts
Swan
Registered User
Posts: 15
Joined: Sat Jun 16, 2007 6:58 am

Not able to enter Admin CP after installing a new style

Post by Swan »

I am not able to enter the Admin Control Panel after installing a new theme. The theme is 3rd party i saw on a site ( which claimed to be for phpbb3 compatible) . I am able to login as adminstrator. But when clicking the link for admin control panel, and reentering the username and passwords, it shows error on the next page. Saying " You must enter the correct password to get into the Admin control panel ". As if it is not able to recognize the password now . What is the problem ? Help please! :roll:

User avatar
*Christian*
I've Been Banned!
Posts: 884
Joined: Sat Nov 03, 2007 1:35 pm
Location: Location, Location.

Re: Not able to enter Admin CP after installing a new style

Post by *Christian* »

Can we have the exact link of the style you downloaded? (the link you followed to download it)

Thanks :)
Proud owner of Bertie 3.0
:: No support via PM or IM ::

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5444
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Not able to enter Admin CP after installing a new style

Post by Marc »

Do you have other styles installed? (Like subsilver2 or prosilver)

Then access your board like this:

Code: Select all

http://*your forum's address*/index.php?style=1
If style=1 doesn't change anything try using style=2 and so on (depending on how many styles you have installed).

Swan
Registered User
Posts: 15
Joined: Sat Jun 16, 2007 6:58 am

Re: Not able to enter Admin CP after installing a new style

Post by Swan »

Thanks for the response.

The grey theme at : http://www.sarkis-webdesign.com/phpbb3-styles-free.html
Do you have other styles installed? (Like subsilver2 or prosilver)

Then access your board like this:

Code: Select all
http://*your forum's address*/index.php?style=1



If style=1 doesn't change anything try using style=2 and so on (depending on how many styles you have installed).
Yes. They are prosilver and subsilver2. But they are not the defaults. The default one is the grey one.

I would try your suggestion, but just want to repeat my problem:
I am able to login into the board, and the style too is showing, but i am not able to login to the admin cp.

The Error i get is :
General Error

You need to enter your password to access the Administration Control Panel.

Please notify the board administrator or webmaster: admin@something.com
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5444
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Not able to enter Admin CP after installing a new style

Post by Marc »

That is usually what shows up once you try to get into the ACP after having installed an incompatible style on phpbb3. Just try what I suggested, it won't destroy anything. ;)
It doesn't matter if subsilver2 or prosilver are not the default style they just have to be installed.

Swan
Registered User
Posts: 15
Joined: Sat Jun 16, 2007 6:58 am

Re: Not able to enter Admin CP after installing a new style

Post by Swan »

How come is it incompatible. It claims to be for phpbb3.0

and
http://*your forum's address*/index.php?style=1

doesnot help to enter the admin control panel.

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5444
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Not able to enter Admin CP after installing a new style

Post by Marc »

Style=1 or Style =2 should change the style displayed. If it doesn't you don't have prosilver or subsilver2 installed. There should still be a way to edit your main theme by changing something in your database, but I never had to do that so I don't know what to change.

theMezz
Registered User
Posts: 108
Joined: Fri Aug 15, 2003 8:52 pm
Location: Central NY, USA
Contact:

Re: Not able to enter Admin CP after installing a new style

Post by theMezz »

Swan wrote:How come is it incompatible. It claims to be for phpbb3.0

and
http://*your forum's address*/index.php?style=1

doesnot help to enter the admin control panel.


http://*your forum's address*/index.php?style=1 fails for me too

theMezz
Registered User
Posts: 108
Joined: Fri Aug 15, 2003 8:52 pm
Location: Central NY, USA
Contact:

Re: Not able to enter Admin CP after installing a new style

Post by theMezz »

after several attempts using

http://*your forum's address*/index.php?style=1

I WAS able to log on..

if anyone else is having trouble.. try it a few times.. it did work for me

Swan
Registered User
Posts: 15
Joined: Sat Jun 16, 2007 6:58 am

Re: Not able to enter Admin CP after installing a new style

Post by Swan »

theMezz wrote:after several attempts using

http://*your forum's address*/index.php?style=1

I WAS able to log on..

if anyone else is having trouble.. try it a few times.. it did work for me
No luck...I tried several times.

And i am doubtful too... how just using the variable style=1 , would give an entry to admin control panel ? It's impossible logically. :|

User avatar
*Christian*
I've Been Banned!
Posts: 884
Joined: Sat Nov 03, 2007 1:35 pm
Location: Location, Location.

Re: Not able to enter Admin CP after installing a new style

Post by *Christian* »

try:

http://*link to forum*/adm/index.php ;)
Proud owner of Bertie 3.0
:: No support via PM or IM ::

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5444
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Not able to enter Admin CP after installing a new style

Post by Marc »

Swan wrote:
theMezz wrote:after several attempts using

http://*your forum's address*/index.php?style=1

I WAS able to log on..

if anyone else is having trouble.. try it a few times.. it did work for me
No luck...I tried several times.

And i am doubtful too... how just using the variable style=1 , would give an entry to admin control panel ? It's impossible logically. :|
It doesn't give you an entry to your ACP, it just shows you a different style. If you installed a style "a" as default style, which is not gold compatible, you won't be able to login to your ACP. If you have other styles installed and activated (not default), you will be able to access you board by putting "style=1" or "style=2" behind index.php (e.g. .../index.php?style=2). Once you type this in, you will see a different style (e.g. subsilver2 or prosilver). Then you will be able to access you ACP like usually.
I'll show you with the phpBB Community Site:

http://www.phpbb.com/community/index.php?style=1

http://www.phpbb.com/community/index.php?style=2

You will still have to login and you will still have to click on Administration Control Panel.

Swan
Registered User
Posts: 15
Joined: Sat Jun 16, 2007 6:58 am

Re: Not able to enter Admin CP after installing a new style

Post by Swan »

marc1706 wrote:
Swan wrote:
theMezz wrote:after several attempts using

http://*your forum's address*/index.php?style=1

I WAS able to log on..

if anyone else is having trouble.. try it a few times.. it did work for me
No luck...I tried several times.

And i am doubtful too... how just using the variable style=1 , would give an entry to admin control panel ? It's impossible logically. :|
It doesn't give you an entry to your ACP, it just shows you a different style. If you installed a style "a" as default style, which is not gold compatible, you won't be able to login to your ACP. If you have other styles installed and activated (not default), you will be able to access you board by putting "style=1" or "style=2" behind index.php (e.g. .../index.php?style=2). Once you type this in, you will see a different style (e.g. subsilver2 or prosilver). Then you will be able to access you ACP like usually.
I'll show you with the phpBB Community Site:

http://www.phpbb.com/community/index.php?style=1

http://www.phpbb.com/community/index.php?style=2

You will still have to login and you will still have to click on Administration Control Panel.
Ooookay, i got it...thanks for the example links. +rep.
I should try it again. :)

User avatar
evilpeppard
Registered User
Posts: 75
Joined: Wed Jan 30, 2008 6:05 pm
Location: Denver, CO USA

Re: Not able to enter Admin CP after installing a new style

Post by evilpeppard »

marc1706 wrote:Do you have other styles installed? (Like subsilver2 or prosilver)

Then access your board like this:

Code: Select all

http://*your forum's address*/index.php?style=1
If style=1 doesn't change anything try using style=2 and so on (depending on how many styles you have installed).
Thank you so much for this info. I too had installed a third party theme that "said" it was compatible with phpbb3. I used your info above and was able to manually load my site with the original prosilver theme and immediately went into the Style tab, set prosilver back to active and deleted the third party theme.

Thank you again, Marc1706! :)
"My actions are not revenge...they are punishment..."

AkodoJed
Registered User
Posts: 5
Joined: Mon Apr 09, 2007 11:37 pm

Re: Not able to enter Admin CP after installing a new style

Post by AkodoJed »

Yeah, this saved my bacon today. Definitely a good idea to have this somewhere in this forum stickied so that people who get screwed up styles can get out of it without panicing.

--Jed

Locked

Return to “[3.0.x] Styles Support & Discussion”