[2.0.6] Smilies Order

The cleanup is complete. This forum is now read only.
Post Reply

Rating:

Excellent!
37
63%
Very Good
8
14%
Good
7
12%
Fair
2
3%
Poor
5
8%
 
Total votes: 59

AbelaJohnB
Former Team Member
Posts: 5674
Joined: Fri Jul 06, 2001 11:56 pm

[2.0.6] Smilies Order

Post by AbelaJohnB »

MOD Name: Smilies Order
Author: LifeIsPain
MOD Description: Allows for the smilies order to be changed from the admin panel and gives the ability to the Admin to specify if new smilies should be added before or after existing smilies.

MOD Version: 1.0.0


Download File: smilies_order-1_0_0.zip
File Size: 4467 Bytes
Last edited by AbelaJohnB on Mon Apr 30, 2007 12:29 am, edited 1 time in total.

wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Post by wGEric »

Validated/Released!
Eric

Wolvnius
Registered User
Posts: 5
Joined: Sat Nov 01, 2003 9:20 pm
Contact:

Questions

Post by Wolvnius »

I just want to know what file it is needed to edit in order to get the smile order to work.

#-----[ SQL ]------------------------------------------
#
ALTER TABLE phpbb_smilies ADD smilies_order INT( 5 ) NOT NULL;

#
#-----[ SQL ]------------------------------------------
#
INSERT INTO phpbb_config VALUES ('smilies_insert', 1);

Since, I have not done it I get this message:

Couldn't get extreme values from the smilies table

DEBUG MODE

SQL Error : 1054 Unknown column 'smilies_order' in 'field list'

SELECT MAX(smilies_order) AS smilies_extreme FROM phpbb_smilies

Line : 504
File : /homepages/5/d88118566/htdocs/bb/admin/admin_smilies.php

And this one

Couldn't get extreme values from the smilies table

DEBUG MODE

SQL Error : 1054 Unknown column 'smilies_order' in 'field list'

SELECT MIN(smilies_order) AS smilies_extreme FROM phpbb_smilies

Line : 610
File : /homepages/5/d88118566/htdocs/bb/admin/admin_smilies.php

Could someone tell me what file is need to be edited?

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut »

A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

Wolvnius
Registered User
Posts: 5
Joined: Sat Nov 01, 2003 9:20 pm
Contact:

Okay, then.......

Post by Wolvnius »

I had downloaded the phpmyadmin 2.5.4 and this is the program to do query on sql. Thanks for the link, but it doesn't tell me about the smiles; thou it explains how to run queries. That is how it gets done?
Last thing, do you know anything about 'TIKI'. It is very simular to phpbb but in a bigger scale; also I have a problem. Do you know anyone who does know tiki?

Wolvnius
Registered User
Posts: 5
Joined: Sat Nov 01, 2003 9:20 pm
Contact:

dude.......

Post by Wolvnius »

I don't konw how i did it but i done it. I was telling you about 'tiki'......humm my guess that i need to run queries to the sql, because i am getting an error 500: Internal Server Error


The server encountered an unexpected condition which prevented it from fulfilling the request.

my guess is the queries i have not defined. So much for your help, if i get any other question could you assist me with?
Thanks and i appreciate your help!

madnessmotors
Registered User
Posts: 269
Joined: Sun Aug 17, 2003 7:33 pm
Contact:

Post by madnessmotors »

I have this installed and no matter whether I pick before or after the smilies are added to the top.

LifeIsPain
Former Team Member
Posts: 2148
Joined: Tue Oct 01, 2002 7:04 am
Location: Way Way Behind

Post by LifeIsPain »

@madnessmotors: you must click "Change Insert Location" after making the selection.

@Wolvnius: the [ SQL ] action (all actions explained here) means that the lines under it need to be executed inside of phpMyAdmin (or similar). As far as Tiki, you probably would get better support for that at a Tiki page instead of phpBB.com, as more users use it over there.
LifeIsPain - one who needs to be smackedLife is pain, highness! Anyone who says differently is selling something.

Wolvnius
Registered User
Posts: 5
Joined: Sat Nov 01, 2003 9:20 pm
Contact:

Thanks thou!

Post by Wolvnius »

Speaking of smiles, I am trying to send smilies up, down, to the top or to the botton; it doesn't work. I had clicked on the change insert location and nothing. If I go to the Forum index and post somthing I am able to see the changes, but not if I am doing it from Smiles Editing Utility. WHy?

madnessmotors
Registered User
Posts: 269
Joined: Sun Aug 17, 2003 7:33 pm
Contact:

Post by madnessmotors »

I did click change insert location point though.

epolady
Registered User
Posts: 109
Joined: Mon Aug 12, 2002 1:33 am

Post by epolady »

This worked well for me. Good job! I've been wanting to organize my smilies for a while now. :)

Edit: 4 hours later
I didn't want to double post, but I hope the MOD author reads this soon, all of the directional options work fine, but when I add a fresh smilie to the forum, it doesn't show the image, as if I hadn't selected one, but in fact I did. And I had to manually go back and "edit" them all again. Any clues? I had no errors during installation.

Also, about the "Should new smilies be added before or after existing smilies?" feature, I'm not getting that to work at all. Each time I pick "After", it goes to the top. Am I doing this in the wrong order? Here's what I did: I installed the MOD, selected "After" and now each time I add a new smilie, it shoots to the top.

:? Help?

epolady
Registered User
Posts: 109
Joined: Mon Aug 12, 2002 1:33 am

Post by epolady »

..... -bump-.....

madnessmotors
Registered User
Posts: 269
Joined: Sun Aug 17, 2003 7:33 pm
Contact:

Post by madnessmotors »

epolady wrote: This worked well for me. Good job! I've been wanting to organize my smilies for a while now. :)

Edit: 4 hours later
I didn't want to double post, but I hope the MOD author reads this soon, all of the directional options work fine, but when I add a fresh smilie to the forum, it doesn't show the image, as if I hadn't selected one, but in fact I did. And I had to manually go back and "edit" them all again. Any clues? I had no errors during installation.

Also, about the "Should new smilies be added before or after existing smilies?" feature, I'm not getting that to work at all. Each time I pick "After", it goes to the top. Am I doing this in the wrong order? Here's what I did: I installed the MOD, selected "After" and now each time I add a new smilie, it shoots to the top.

:? Help?


I guess, I'm not the only person with this problem.

LifeIsPain
Former Team Member
Posts: 2148
Joined: Tue Oct 01, 2002 7:04 am
Location: Way Way Behind

Post by LifeIsPain »

Ok, I am looking at this a bit more, and my best thought would be that the includes/constants.php file was not updated. This would make it so that the default is always at the end. Another option is that you are on a database that I didn't test on (the code should be valid for all databases though). So if I could get the database type, and just have you confirm that constants.php is updated with the two new constants at the top of the file, that would help.
LifeIsPain - one who needs to be smackedLife is pain, highness! Anyone who says differently is selling something.

epolady
Registered User
Posts: 109
Joined: Mon Aug 12, 2002 1:33 am

Post by epolady »

LifeIsPain wrote: So if I could get the database type, and just have you confirm that constants.php is updated with the two new constants at the top of the file, that would help.


MySQL 4.0.15, yes constants.php was edited.

Code: Select all

// Smilies Order
define('TOP_LIST', -1);
define('BOTTOM_LIST', 1);
Correct?

Any clues on this?
when I add a fresh smilie to the forum, it doesn't show the image, as if I hadn't selected one, but in fact I did. And I had to manually go back and "edit" them all again. Any clues? I had no errors during installation.

Post Reply

Return to “[2.0.x] MOD Database Cleanup”