[2.0.6] Custom Title MOD

The cleanup is complete. This forum is now read only.
bopie64
Registered User
Posts: 15
Joined: Sun May 20, 2007 2:07 am

Re: [2.0.6] Custom Title MOD

Post by bopie64 » Sat Jun 02, 2007 3:55 am

In the board_config_body.tpl and admin_board.php I checked the changes and yes the whole code was inputted. Could you upload those two files (from subsilver) to zshare.net and post the URL so I can see what changes are different? It would be great if you could. Thanks.

Paintballkev812
Registered User
Posts: 12
Joined: Mon Jan 30, 2006 4:48 am

Re: [2.0.6] Custom Title MOD

Post by Paintballkev812 » Mon Jun 18, 2007 7:18 pm

ive installed the 1.0.3 [2.0.20] custom Title Mod using easyMod and get this error whenever I try to view a topic.

DEBUG MODE

SQL Error : 1054 Unknown column 'u.user_custom_title' in 'field list'

SELECT u.username, u.user_scopoints, u.user_id, u.user_posts, u.user_custom_title, u.user_from, u.user_website, u.user_email, u.user_icq, u.user_aim, u.user_yim, u.user_regdate, u.user_msnm, u.user_viewemail, u.user_rank, u.user_sig, u.user_sig_bbcode_uid, u.user_avatar, u.user_avatar_type, u.user_allowavatar, u.user_allowsmile, p.*, pt.post_text, pt.post_subject, pt.bbcode_uid FROM phpbb2_posts p, phpbb2_users u, phpbb2_posts_text pt WHERE p.topic_id = 301 AND pt.post_id = p.post_id AND u.user_id = p.poster_id ORDER BY p.post_time ASC LIMIT 0, 15

Line : 479
File : viewtopic.php

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20430
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [2.0.6] Custom Title MOD

Post by RMcGirr83 » Mon Jun 18, 2007 7:26 pm

3. Place the included title_install.php into your root phpBB directory, and then
run it. This will make the necessary database alterations. When it has
completed, make sure it didn't report any errors, and then delete the file.
WARNING: FAILURE TO DELETE THIS FILE MAY PUT YOUR FORUM, SITE, AND SERVER AT
A POTENTIAL SECURITY RISK.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

ClubMed
Registered User
Posts: 349
Joined: Wed Aug 06, 2003 12:30 pm
Location: Austria

Re: [2.0.6] Custom Title MOD

Post by ClubMed » Sun Jun 24, 2007 9:11 am

Anyone know if there is such a MOD for phpBB3 or whether it can be easily ported?
Do you Ubuntu too?

HobbyIllustrator
Registered User
Posts: 49
Joined: Mon Jun 18, 2007 3:48 am

Re: [2.0.6] Custom Title MOD

Post by HobbyIllustrator » Thu Jul 12, 2007 8:12 am

I got the error I don't think anyone wants to get, only because it mentions SQL. When I change my custom title and click "Submit" at the bottom, I get this one.


Could not update users table

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' user_allowbbcode = 1, user_allow_viewonline = 1, user_notify =

UPDATE phpbb_users SET user_email = 'hk@hobbyillustrator.com', user_icq = '', user_website = '', user_occ = '', user_from = '', user_interests = '', user_custom_title = 'Owner and Resident Superhero', user_sig = '[img:90b13fd7cf]http://card.mygamercard.net/gelsig/blue/bcharlt1.png[/img:90b13fd7cf] [img:90b13fd7cf]http://img340.imageshack.us/img340/836/cmpunkoo1.jpg[/img:90b13fd7cf] [img:90b13fd7cf]http://img528.imageshack.us/img528/8040 ... edykb8.jpg[/img:90b13fd7cf]', user_viewemail = 1, user_aim = '', user_yim = '', user_msnm = '', user_attachsig = 1, user_sig_bbcode_uid = '90b13fd7cf', user_allowsmile = 1, user_allowhtml = 0, user_allowavatar = , user_allowbbcode = 1, user_allow_viewonline = 1, user_notify = 0, user_allow_pm = , user_notify_pm = 1, games_block_pm = , user_birthday = 01081978, user_allowdesc = '', user_allowmoddesc = '', user_showdescriptions = '1', user_showtooltips = '1', user_tooltips_parse = '1', user_tooltips_static = '0', user_toolimg_width = '250', user_toolimg_height = '250', user_popup_pm = , user_lang = 'english', user_style = 1, user_timezone = -5, user_dateformat = 'd M Y h:i a', user_active = , user_rank = WHERE user_id = 2

Line : 622
File : usercp_register.php

HobbyIllustrator
Registered User
Posts: 49
Joined: Mon Jun 18, 2007 3:48 am

Re: [2.0.6] Custom Title MOD

Post by HobbyIllustrator » Thu Jul 12, 2007 8:08 pm

I just realized something. In the manual install file, it says this:
#-----[ FIND ]------------------------------------------
#
$signature = str_replace('
#
#-----[ BEFORE, ADD ]------------------------------------------
#
// Verify the user is allowed to alter their custom title. If not, replace it with their old one.
if ($custom_title_activated == FALSE)
{
$custom_title = addslashes($userdata['user_custom_title']);
}

// Check the length of the custom title. Prevents people from editing the HTML to get a longer one.
if (strlen($custom_title) > $board_config['custom_title_maxlength'])
{
if ($custom_title != addslashes($userdata['user_custom_title'])) {
$custom_title = addslashes($userdata['user_custom_title']);
$error = TRUE;
if (isset($error_msg)) $error_msg .= '<br />';
$error_msg .= $lang['Custom_title_toolong'];
}
}



But mine looks like this (probably due to another mod):


if ($custom_title != addslashes($userdata['user_custom_title'])) {
$custom_title = addslashes($userdata['user_custom_title']);
$error = TRUE;
if (isset($error_msg)) $error_msg .= '<br />';
$error_msg .= $lang['Custom_title_toolong'];
}
}

$signature = (isset($signature)) ? str_replace('<br />', "\n", $signature) : '';
$signature_bbcode_uid = '';


Is that what's causing my SQL 1064 Error???

HobbyIllustrator
Registered User
Posts: 49
Joined: Mon Jun 18, 2007 3:48 am

Re: [2.0.6] Custom Title MOD

Post by HobbyIllustrator » Thu Jul 12, 2007 8:15 pm

Ok nevermind, I was wondering if the lack of a line that says "$signature = str_replace('" might be the problem, but I checked with a buddy and his $signature line looked the same as mine, and he has NO mods yet.

I'm still baffled by this. I've been checking for spelling errors for about ... oh ... 6 hours and I can't find anything. Kinda' makes that 25 minute install time seem funny lol.

HobbyIllustrator
Registered User
Posts: 49
Joined: Mon Jun 18, 2007 3:48 am

Re: [2.0.6] Custom Title MOD

Post by HobbyIllustrator » Fri Jul 13, 2007 7:32 pm

So ... nothin'? Have I stumped everyone?

User avatar
rove
Registered User
Posts: 124
Joined: Thu Jun 24, 2004 4:37 pm

Re: [2.0.6] Custom Title MOD

Post by rove » Fri Jul 13, 2007 8:17 pm

What have you tried so far to debug your error?
What happens if you execute the query in phpmyadmin? Does that work or not?
Do all the field names exists in your users table?
In your query i see that user_allowavatar does not get a value assigned. May be that causes your error.

HobbyIllustrator
Registered User
Posts: 49
Joined: Mon Jun 18, 2007 3:48 am

Re: [2.0.6] Custom Title MOD

Post by HobbyIllustrator » Sat Jul 14, 2007 7:45 pm

What value should user_allowavatar have? Just curious.

Yea, all the fields are present in the file itself as well.



As for executing from the ACP, it says the profile was successfully edited, but the custom title doesn't show up.

HobbyIllustrator
Registered User
Posts: 49
Joined: Mon Jun 18, 2007 3:48 am

Re: [2.0.6] Custom Title MOD

Post by HobbyIllustrator » Sun Jul 15, 2007 6:50 am

Update: This isn't just happening when you change the Custom Title ... it happens now when you do ANYTHING and try to "submit" the changes.


Thoughts? Am I screwed?

User avatar
rove
Registered User
Posts: 124
Joined: Thu Jun 24, 2004 4:37 pm

Re: [2.0.6] Custom Title MOD

Post by rove » Sun Jul 15, 2007 7:37 am

value for user_allowavatar can be 1 or 0.

Best you can do is grab a copy of a clean usercp_register.php and compare that to your file. Most likely there is an error somewhere in your file. If this is the only mod installed you may even consider to start installing this mod with a new clean set of files.

HobbyIllustrator
Registered User
Posts: 49
Joined: Mon Jun 18, 2007 3:48 am

Re: [2.0.6] Custom Title MOD

Post by HobbyIllustrator » Sun Jul 15, 2007 9:04 am

Negative. In a freshly downloaded phpBB2's "included" folder, there is no usercp_register.php file.


I'm still waiting to see if I'm the only one who's gotten the SQL 1064 error. This still isn't fixed.

User avatar
rove
Registered User
Posts: 124
Joined: Thu Jun 24, 2004 4:37 pm

Re: [2.0.6] Custom Title MOD

Post by rove » Sun Jul 15, 2007 9:26 am

HobbyIllustrator wrote:Negative. In a freshly downloaded phpBB2's "included" folder, there is no usercp_register.php file.
Strange, i just downloaded a copy and i found the file /includes/usercp_register.php...
It is a part of a clean phpbb2 installation.

HobbyIllustrator
Registered User
Posts: 49
Joined: Mon Jun 18, 2007 3:48 am

Re: [2.0.6] Custom Title MOD

Post by HobbyIllustrator » Sun Jul 15, 2007 11:09 pm

Ok, I'm going to post this here because others have suggested (on these boards) that this problem is most likely related to my Custom Title mod.

I got the usercp_register problem fixed. I no longer get the SQL error 1064 when I submit a change to my profile, however, now when you click on the "gallery" button, you see the first folder loads fine ... but when you change folders and click "Go", it goes BACK to your profile, and above it, it says "You must fill in the necessary blanks", and your info is all haywire.

Any thoughts on this one? I get the feeling I'm past the dirty work and that this won't be as bad as the usercp_register problem I had lol.

Post Reply

Return to “[2.0.x] MOD Database Cleanup”

Who is online

Users browsing this forum: No registered users and 6 guests

cron