[2.0.6] Custom Title MOD

The cleanup is complete. This forum is now read only.
Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Post by Aexoden » Sat Nov 01, 2003 9:32 pm

The Other Guy: Run title_install.php to make the necessary changes to the database.

rascott: The quotes are required to meet current HTML standards, but old standards didn't require them, and browsers generally don't either. It can't hurt to put them, in any case.

The Other Guy
Registered User
Posts: 33
Joined: Mon Mar 24, 2003 3:55 am
Location: Here
Contact:

Post by The Other Guy » Sun Nov 02, 2003 1:13 am

And where is the title_install.php?
Er... yeah.

Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Post by Aexoden » Sun Nov 02, 2003 6:19 am

The Other Guy wrote: And where is the title_install.php?

It's inside the download package.

User avatar
minike
Registered User
Posts: 13
Joined: Sun Aug 11, 2002 5:07 pm

Post by minike » Sun Nov 02, 2003 4:44 pm

Hey, i have installed the custom user title mod, but it doesn't work :oops: :oops:

When I wanne install it, het gives this error:

Code: Select all

Information
Database type    :: mysql
Aexoden's Custom Title Version:: 1.0.2

This installs the necessary database schema for Aexoden's Custom Title MOD. Currently, only the MySQL aspect has been tested. If you're using any other database, please report your results to Aexoden.

Installing database schema
Progress :: . Done
Result   :: Some queries failed, the statements and errors are listing below 

Error :: alter command denied to user: 'pokgam_l1h_net@localhost' for table 'phpbb_users'
SQL   :: ALTER TABLE phpbb_users ADD COLUMN user_custom_title varchar(255) NULL, ADD COLUMN user_custom_title_status tinyint(1) default '0' not null


An error occured.

Updating data
Progress :: .... Done
Result   :: Some queries failed, the statements and errors are listing below 

Error :: Duplicate entry 'custom_title_days' for key 1
SQL   :: INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_days', 0)


Error :: Duplicate entry 'custom_title_posts' for key 1
SQL   :: INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_posts', 0)


Error :: Duplicate entry 'custom_title_mode' for key 1
SQL   :: INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_mode', 0)


Error :: Duplicate entry 'custom_title_maxlength' for key 1
SQL   :: INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_maxlength', 45)


An error occured. Please PM Aexoden with the details of the error.

Install completed
You should now delete this file. Be sure to visit the Configuration section of General Admin to configure the Custom Title options.
What have i done wrong??

User avatar
minike
Registered User
Posts: 13
Joined: Sun Aug 11, 2002 5:07 pm

Post by minike » Sun Nov 02, 2003 4:45 pm

Hey, i have installed the custom user title mod, but it doesn't work :oops: :oops:

When I wanne install it, het gives this error:

Code: Select all

Information
Database type    :: mysql
Aexoden's Custom Title Version:: 1.0.2

This installs the necessary database schema for Aexoden's Custom Title MOD. Currently, only the MySQL aspect has been tested. If you're using any other database, please report your results to Aexoden.

Installing database schema
Progress :: . Done
Result   :: Some queries failed, the statements and errors are listing below 

Error :: alter command denied to user: 'pokgam_l1h_net@localhost' for table 'phpbb_users'
SQL   :: ALTER TABLE phpbb_users ADD COLUMN user_custom_title varchar(255) NULL, ADD COLUMN user_custom_title_status tinyint(1) default '0' not null


An error occured.

Updating data
Progress :: .... Done
Result   :: Some queries failed, the statements and errors are listing below 

Error :: Duplicate entry 'custom_title_days' for key 1
SQL   :: INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_days', 0)


Error :: Duplicate entry 'custom_title_posts' for key 1
SQL   :: INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_posts', 0)


Error :: Duplicate entry 'custom_title_mode' for key 1
SQL   :: INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_mode', 0)


Error :: Duplicate entry 'custom_title_maxlength' for key 1
SQL   :: INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_maxlength', 45)


An error occured. Please PM Aexoden with the details of the error.

Install completed
You should now delete this file. Be sure to visit the Configuration section of General Admin to configure the Custom Title options.
What have i done wrong??

Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Post by Aexoden » Sun Nov 02, 2003 4:49 pm

The errors you're receiving only indicate title_install.php has already been run. Nothing's wrong there. However, besides that, you need to make modifications to several files, and that's all described in manual_install.txt, I believe. If you've already done that, you should be good to go.

flautist
Registered User
Posts: 50
Joined: Thu Sep 25, 2003 1:10 pm
Location: Illinois
Contact:

Post by flautist » Sun Nov 02, 2003 5:33 pm

Is there any way to make the custom title a different color other than black?
http://www.river-crossing.org - for Christian survivors of sexual and domestic abuse.
River Crossing forums

Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Post by Aexoden » Sun Nov 02, 2003 5:59 pm

flautist wrote: Is there any way to make the custom title a different color other than black?

On an individual basis... it's hard to do without letting everyone have HTML access. If you want to change everyone, it's as simple as adding a tag to change the color around the title in viewtopic_body.tpl.

User avatar
minike
Registered User
Posts: 13
Joined: Sun Aug 11, 2002 5:07 pm

Post by minike » Sun Nov 02, 2003 6:09 pm

no, it was the first time I did use the install file

flautist
Registered User
Posts: 50
Joined: Thu Sep 25, 2003 1:10 pm
Location: Illinois
Contact:

Post by flautist » Sun Nov 02, 2003 6:29 pm

okay, where do I insert the code? I want the color to be #0000FF...
http://www.river-crossing.org - for Christian survivors of sexual and domestic abuse.
River Crossing forums

Xog
Registered User
Posts: 2
Joined: Sun Nov 02, 2003 6:52 pm
Contact:

Post by Xog » Sun Nov 02, 2003 6:57 pm

hello i have a small problem..


---------------------- [ The error ] -----------------------------------
Parse error: parse error, unexpected T_VARIABLE in /var/www/html/phpbb2/admin/admin_users.php on line 659

-------------------------- [ The line ] ----------------------------------

SET " . $username_sql . $passwd_sql . "user_email = '" . str_replace("\'", "''", $email) . "', user_icq = '" . str_replace("\'", "''", $icq) . "', user_website = '" . str_replace("\'", "''", $website) . "', user_occ = '" . str_replace("\'", "''", $occupation) . "', user_from = '" . str_replace("\'", "''", $location) . "', user_interests = '" . str_replace("\'", "''", $interests) ."', user_custom_title = '" . str_replace("\'", "''", $custom_title) . "', user_custom_title_status = '" $custom_title_status "') user_sig = '" . str_replace("\'", "''", $signature) . "', user_viewemail = $viewemail, user_aim = '" . str_replace("\'", "''", $aim) . "', user_yim = '" . str_replace("\'", "''", $yim) . "', user_msnm = '" . str_replace("\'", "''", $msn) . "', user_attachsig = $attachsig, user_sig_bbcode_uid = '$signature_bbcode_uid', user_allowsmile = $allowsmilies, user_allowhtml = $allowhtml, user_allowavatar = $user_allowavatar, user_allowbbcode = $allowbbcode, user_allow_viewonline = $allowviewonline, user_notify = $notifyreply, user_allow_pm = $user_allowpm, user_notify_pm = $notifypm, user_popup_pm = $popuppm, user_lang = '" . str_replace("\'", "''", $user_lang) . "', user_style = $user_style, user_timezone = $user_timezone, user_dateformat = '" . str_replace("\'", "''", $user_dateformat) . "', user_active = $user_status, user_rank = $user_rank" . $avatar_sql . "

----------------- [ End Of Line ] -----------------

Can sombody help me with it?
Sorry i'm not so good in english..

Dortmunder13
Registered User
Posts: 5
Joined: Tue Nov 04, 2003 3:34 pm

Post by Dortmunder13 » Tue Nov 04, 2003 3:35 pm

Hi,

I'm trying to install this with a phpBB from php-nuke. Does it work this way?

Also, when I run the title_install.php, I get a blank screen (I'm opening it in a web browser). Is this normal or am I doing something wrong?

I chmoded it to 777.

THanks

I have the custom title box in my user configuration panel. I set the max length to 255 in the control panel but when I go back after saving changes it just comes up blank.

When I try and change the title I get a message saying that it is too long.

When I try to view a topic, I get this:

Code: Select all

Could not obtain post/user information.

DEBUG MODE

SQL Error : 1054 Unknown column 'u.user_custom_title' in 'field list'

SELECT u.username, u.user_id, u.user_posts, u.user_custom_title, u.user_from, u.user_website, u.user_email, u.user_icq, u.user_aim, u.user_yim, u.user_regdate, u.user_msnm, u.user_viewemail, u.user_rank, u.user_sig, u.user_sig_bbcode_uid, u.user_avatar, u.user_avatar_type, u.user_allowavatar, u.user_allowsmile, p.*, pt.post_text, pt.post_subject, pt.bbcode_uid FROM nuke_bbposts p, nuke_users u, nuke_bbposts_text pt WHERE p.topic_id = 1 AND pt.post_id = p.post_id AND u.user_id = p.poster_id ORDER BY p.post_time ASC LIMIT 0, 20

Line : 435
File : /homepages/23/d88560243/htdocs/modules/Forums/viewtopic.php

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Tue Nov 04, 2003 4:13 pm

@ Dortmunder13 : it looks like you have not run the SQL requests needed by the MOD : check the install file :wink:
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Dortmunder13
Registered User
Posts: 5
Joined: Tue Nov 04, 2003 3:34 pm

Post by Dortmunder13 » Tue Nov 04, 2003 6:19 pm

morpheus2matrix wrote: @ Dortmunder13 : it looks like you have not run the SQL requests needed by the MOD : check the install file :wink:


Okay, I must be missing something obvious here...
b. Manual Installation

As with all MODs, manual installation is possible. If something doesn't work,
or if the directions seem unclear, please let me know.

1. Open the included manual_install.txt. Follow the instructions carefully, and
be sure to read everything. Many common questions asked in the support
thread can be answered simply by reading carefully!
2. Place the included title_install.php into your root phpBB directory, and then
run it. This will make the necessary database alterations. When it has
completed, make sure it didn't report any errors, and then delete the file.
WARNING: FAILURE TO DELETE THIS FILE MAY PUT YOUR FORUM, SITE, AND SERVER AT
A POTENTIAL SECURITY RISK.
3. Follow the Configuration Guide provided below.


I opened manual_install.txt, which was a bunch of find and add code here instructions, which I did. I don't see anything about running SQL requests in that file. I also don't see it in the file I just quoted - when I do step 2, I just get a blank page when I open that php file with my web browser.

Am I missing something obvious here?[/quote]

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Tue Nov 04, 2003 7:00 pm

@ Dortmunder13 : ok, i see why you have not seen the requests : there are not in the install file but in the file title_install.php : upload this file, execute it and then, delete this file. After that, all should be ok.


Bye.
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Post Reply

Return to “[2.0.x] MOD Database Cleanup”