[2.0.6] Rank Images Display Multi. Times

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
7
58%
Very Good
1
8%
Good
2
17%
Fair
1
8%
Poor
1
8%
 
Total votes: 12

arrows10
Registered User
Posts: 133
Joined: Tue Jun 18, 2002 4:19 pm

Post by arrows10 »

u wound need to check with the author of which ever plugin u are wanting to have it work with as i my self dont use that mod

Spif Kewl
Registered User
Posts: 61
Joined: Tue Nov 15, 2005 9:47 am
Location: Grand Forks, ND
Contact:

Post by Spif Kewl »

morpheus2matrix wrote:
dictator wrote:sorry but i still don't understand what is wrong :oops:
i did everything what was said in installation faile
what do you suqest me to do :?:


in phpMyadmin, run this request :

Code: Select all

ALTER TABLE phpbb_ranks ADD `rank_mal` tinyint(2) unsigned NOT NULL default '1' AFTER rank_image;
:wink:

Hi, I'm sorry to make my first post such a newbie question, but I'm stumped on a dumb one here. I'm new to all the phpBB thing and just came across the hack to create ranks earlier tonight. I went through the whole process of editing everything but have hit a brick wall. I get the "SQL Error : 1054 Unknown column 'rank_choose_minimum' in 'field list'

INSERT INTO phpbb_ranks (rank_title, rank_special, rank_min, rank_image, rank_choose_minimum) VALUES ('newbie', 1, -1, '', 0"
error. For the life of me, I cannot figure out where to make this "request" you speak of in the above quoted text. Where do i make this request? The instructions I have told me to do this
[ SQL ]----------------------------------------------
#

ALTER TABLE phpbb_ranks ADD rank_choose_minimum tinyint(1) not null;

I went to the mySQL database and also have searched all over my forum admin page and for the life of me can not figure out where to apply this code or instructions or whatever it is. If you can't tell from my rambling, I have been at this to long and am at my wits end. I would greatly appreicate anyones help in this matter so I can smack myself in the forehead and go to bed. :oops:

-----------------------------------UPDATE---------------------
K, I figured out via the FAQ how to run a query. When i ran the query, it told me this --> MySQL said: Documentation
#1146 - Table 'Spifco.phpbb_ranks' doesn't exist

So, I guess my question now is, how do i create a a 'Spifco.phpbb_ranks' Table ?

Spif Kewl
Registered User
Posts: 61
Joined: Tue Nov 15, 2005 9:47 am
Location: Grand Forks, ND
Contact:

Post by Spif Kewl »

K, I tried creating a table and I'm lost. I've been googling and searchiing FAQ's and cannot find anything about setting a table. Does anyone know of a tutorial or anything that could help me with this. I can't find anything.

--edit--- Holy crap, sorry about the double post, guys. M'bad. I'm going to bed, work on this tomorrow.

arrows10
Registered User
Posts: 133
Joined: Tue Jun 18, 2002 4:19 pm

Post by arrows10 »

they question is when u installed phpbb on ur server what did u tell it to call the prefix for the table u made is it phpbb or something else as thats more than likely why u have a problem

Spif Kewl
Registered User
Posts: 61
Joined: Tue Nov 15, 2005 9:47 am
Location: Grand Forks, ND
Contact:

Post by Spif Kewl »

arrows10 wrote: they question is when u installed phpbb on ur server what did u tell it to call the prefix for the table u made is it phpbb or something else as thats more than likely why u have a problem
Thnx for the response, man. However, I already got it figured out. If you want to see just how much of an idiot I am, read this thread:
http://www.phpbb.com/phpBB/viewtopic.php?t=341654

User avatar
sdgiffin
Registered User
Posts: 13
Joined: Thu Aug 11, 2005 10:01 pm
Location: In Front Of A Computer
Contact:

Post by sdgiffin »

[Deleted]
Last edited by sdgiffin on Fri Mar 17, 2006 3:32 am, edited 1 time in total.

User avatar
sdgiffin
Registered User
Posts: 13
Joined: Thu Aug 11, 2005 10:01 pm
Location: In Front Of A Computer
Contact:

Post by sdgiffin »

I'm having a problem deleting rank themes and I'm not sure what I did wrong. When I click "Delete" it just links to the /admin/ directory, so when I manually make the URL read "Delete" (by using the "Edit" link in a new window and changing "Edit" to "Delete") I get the following Debug Error:

Code: Select all

General Error 
Couldn't delete rank theme data

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 2

DELETE FROM phpbb_rank_themes WHERE rtheme_id = 

Line : 210
File : admin_rank_themes.php
Is this something I overlooked when applying this MOD? I went over the instructions several times and I'm fairly certain I didn't miss anything, and I'm lost now. Is this something I overlooked when applying this MOD? I went over the instructions several times and I'm fairly certain I didn't miss anything, and I'm lost now. I can't delete them unless I go in and manually edit the SQL Tables. :( :?:
"A little knowledge is a dangerous thing."

Alexander Pope (1688-1744) in "An Essay on Criticism," 1709

fishmaker
Registered User
Posts: 23
Joined: Mon Jul 10, 2006 12:35 am

Post by fishmaker »

morpheus2matrix wrote:
dictator wrote:sorry but i still don't understand what is wrong :oops:
i did everything what was said in installation faile
what do you suqest me to do :?:


in phpMyadmin, run this request :

Code: Select all

ALTER TABLE phpbb_ranks ADD `rank_mal` tinyint(2) unsigned NOT NULL default '1' AFTER rank_image;
:wink:


Okay, how do I run this line? I just can't seem to fiure it out.

Derekman007
Registered User
Posts: 10
Joined: Sun Jul 16, 2006 5:26 pm

Post by Derekman007 »

ive installed the mod correctly but when your the board owner and your rank is Site Admin how do you have that rank and another rank under your name for the ones you get for more posts you have?

User avatar
sdgiffin
Registered User
Posts: 13
Joined: Thu Aug 11, 2005 10:01 pm
Location: In Front Of A Computer
Contact:

Post by sdgiffin »

You can't. It has to be one or the other.
"A little knowledge is a dangerous thing."

Alexander Pope (1688-1744) in "An Essay on Criticism," 1709

bwrpaintball
Registered User
Posts: 1
Joined: Tue Mar 14, 2006 10:42 pm
Location: FL
Contact:

Post by bwrpaintball »

Hi all,

Still fairly new to the mods on phpBB, but have done a few without problems. I recently wiped out all of my forums and started over running phpBB 2.0.20

When I try to install this mod, I get the following error:

Critical Error
FIND FAILED: In file [admin/admin_ranks.php] could not find:
"L_RANK_MINIMUM" => $lang['Rank_minimum'],
MOD script line #229 :: FAQ :: Report



Any Suggestions?
Thanks,
Chris

****EDIT****
Well I went through the Mod manually and figured out that it has a repeated section where it does the FIND above twice. After making all the file changes manually and ignoring the repeated section it works now.

AshleyA
Registered User
Posts: 55
Joined: Wed Sep 06, 2006 3:08 pm

Post by AshleyA »

Version of the mod for version 2.0.21 is available?

ashley

Post Reply

Return to “[2.0.x] MOD Database Cleanup”