[2.0.6] Author Hyperlink

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
28
65%
Very Good
10
23%
Good
1
2%
Fair
1
2%
Poor
3
7%
 
Total votes: 43

neilpan
Registered User
Posts: 2
Joined: Sat Oct 09, 2004 10:53 pm

How can I link the Avatar Image to the User Profile ?

Post by neilpan »

I wanna link the Avatar image of the author for each post, to the respective profile. Does any one know how to do it ???

This Mod just links the NAME of the author to the profile, but i want the avatar image to link to the profile ( as you see in vbulletin)

Thanks in advance :D
Bradman
Registered User
Posts: 84
Joined: Mon Nov 11, 2002 6:39 am
Location: Ledyard, CT
Contact:

Post by Bradman »

Hmm, I don't have this mod but I had a similar one on my old 2.0.4 board. I think all you'd have to do is place the anchor around the {postrow.POSTER_AVATAR} instead of the {postrow.POSTER_NAME}.
neilpan
Registered User
Posts: 2
Joined: Sat Oct 09, 2004 10:53 pm

Post by neilpan »

Bradman wrote: Hmm, I don't have this mod but I had a similar one on my old 2.0.4 board. I think all you'd have to do is place the anchor around the {postrow.POSTER_AVATAR} instead of the {postrow.POSTER_NAME}.


Can you explain that a little better ? :? I am a noob in php world :P

Thanks for your help !
Bradman
Registered User
Posts: 84
Joined: Mon Nov 11, 2002 6:39 am
Location: Ledyard, CT
Contact:

Post by Bradman »

Well, no, not really. Like I said, I don't have this particular mod.
dmountford
Registered User
Posts: 8
Joined: Sun Nov 28, 2004 12:02 am

Post by dmountford »

does this work in 2.0.11?
dafunks
Registered User
Posts: 8
Joined: Sun Dec 19, 2004 2:25 am
Location: nono
Contact:

Post by dafunks »

yeah id also like to know the same. And also have a working link to a forum with it if poss :)
andyb
Registered User
Posts: 6
Joined: Tue May 27, 2003 12:53 am

Post by andyb »

Just tried this mod in phpbb v2.011 and yes it works fine.

Andy
Code3TJ
Registered User
Posts: 17
Joined: Mon Jan 26, 2004 9:31 pm
Contact:

Post by Code3TJ »

dmountford wrote: does this work in 2.0.11?

Yes it does. :wink:
btrigueiro
Registered User
Posts: 2
Joined: Wed Jan 26, 2005 9:00 pm

Post by btrigueiro »

I'm using 2.0.11 and i keep getting this kind of error:
Error wrote: btrigueiro');">btrigueiro


btrigueiro is the user name. The first time it appears, its linked to the old javascript(pn) stuff... the second linked to the right place!

Thanks!
awengaf
Registered User
Posts: 1
Joined: Mon Jan 24, 2005 10:32 pm

Post by awengaf »

yup i get same problem, i think it has something to do with this line of code from viewtopic.php.

if ( $show_qr_form )
{
$poster = '<a href="javascript:pn(\''.$poster.'\');">'.$poster.'</a>';

Heres what happens.
Image
btrigueiro
Registered User
Posts: 2
Joined: Wed Jan 26, 2005 9:00 pm

Post by btrigueiro »

i tryed replacing
Original code wrote: $poster = '<a href="javascript:pn(\''.$poster.'\');">'.$poster.'</a>';


with
Mod code wrote: $poster = ( $poster_id != ANONYMOUS ) ? '<a href="' . append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . '=' . $poster_id) . '" class="genmed">' : '';
$poster .= ( $poster_id != ANONYMOUS ) ? $postrow[$i]['username'] : ( ( $postrow[$i]['post_username'] != '' ) ? $postrow[$i]['post_username'] : $lang['Guest'] );
$poster .= ( $poster_id != ANONYMOUS ) ? '</a>' : '';


and it worked great! the nick appears corectly and links to the right place (the users profile)!

CYA!
annab
Registered User
Posts: 50
Joined: Thu Mar 17, 2005 5:17 am

Post by annab »

This mod doesn't work with Online/Offline/Hide mod? It keeps exposing code around the online/offline icon.
kigoobe
Registered User
Posts: 169
Joined: Sat Apr 16, 2005 7:53 am
Location: Paris
Contact:

Re: [2.0.6] Author Hyperlink

Post by kigoobe »

Really great stuff .... and so easy to install ... mind blowing ... great and thanks.
Twiisted_Kaos
Registered User
Posts: 10
Joined: Mon May 02, 2005 9:07 am

Post by Twiisted_Kaos »

** IGNORE POST** fixed the problem
User avatar
Desbrina
Registered User
Posts: 213
Joined: Sat Jun 11, 2005 6:24 pm
Location: Dark Kingdom
Contact:

Post by Desbrina »

I keep getting this with it in the username area. Test is the username.
<a href="profile.php?mode=viewprofile&u=2" class="genmed">test</a>


I have global announcement and admin userlist mods installed
What can i do to fix it?
Post Reply

Return to “[2.0.x] MOD Database Cleanup”