[2.0.6] Per-User Avatar/Sig Disable

The cleanup is complete. This forum is now read only.
Post Reply

Rating:

Excellent!
15
44%
Very Good
9
26%
Good
3
9%
Fair
3
9%
Poor
4
12%
 
Total votes: 34

Extensions Robot
Extensions Robot
Extensions Robot
Posts: 27920
Joined: Sat Aug 16, 2003 7:36 am

[2.0.6] Per-User Avatar/Sig Disable

Post by Extensions Robot » Sun Oct 05, 2003 10:56 pm

MOD Name: Per-User Avatar/Sig Disable
Author: r6untouchable
MOD Description: Allows users to choose to not see avatars/signatures in viewtopic.

MOD Version: 1.0.0


Download File: peruseravatsig.zip
File Size: 2061 Bytes
Last edited by Extensions Robot on Mon Apr 30, 2007 12:29 am, edited 1 time in total.
(this is a non-active account manager for the phpBB Extension Customisations Team)

wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Post by wGEric » Mon Nov 03, 2003 11:07 pm

MOD Validated/Released

There is a bug when you are installing with EasyMOD. So I recommend you install this by hand.
Eric

User avatar
drumstix42
Registered User
Posts: 1100
Joined: Tue Sep 24, 2002 11:01 pm
Location: NJ
Contact:

Post by drumstix42 » Tue Nov 04, 2003 3:36 am

Nice.

I've always wanted this for my forum.

Good job :D
Need a phpBB update or mod installed? PM me for any questions and pricing!
HostMonster.com (Unlimited Space, Unlimited Transfer, Unlimited Domains, $6.95/month )

quentin
Registered User
Posts: 197
Joined: Tue May 20, 2003 7:30 am
Location: Geneva, Switzerland
Contact:

Post by quentin » Wed Nov 05, 2003 7:57 am

very nice tool not to bother too much users with a low bandwidth. Quick SEO question is it possible to force hidden signatures for hidden but identified users such as "googlebot" ?

Quentin
The largest message boards on the web !
Web Design Library (coming soon)
Friends sites: Heroes of might and magic - Biometric security

Fuyutski
Registered User
Posts: 1
Joined: Tue Nov 11, 2003 7:23 am

Post by Fuyutski » Tue Nov 11, 2003 7:45 am

I, don't know if this is the place to put this But I'm having Problems with this mod and i don't fully know how to uninstall it nor understand the Document on how to Uninstall mods. So if you can help tell me what I need to do to uninstall it, I'll be thankful.

janjan1
Registered User
Posts: 25
Joined: Wed Mar 19, 2003 5:58 am

Post by janjan1 » Wed Nov 12, 2003 4:42 pm

I love the idea for this mod, it's really useful :)

But I tried to install this mod on my message board the other day. It gave me some problems so I had to remove it.

I really liked the idea for this mod, so I tried to install it a second time but unfortunately, it gave me the same error.

I thought it was because of the other mods I installed previously, so I tried it on a fresh phpbb 2.0.6, but I got the same error.

About the Error:
I have Gallery Avatars enabled, so my avatar had been chosen from the gallery.
When I tried to change my avatar, and I selected an avatar from the gallery and clicked submit, I got this message:

You must fill in the required fields.

I also noticed that the Date Format was changed to "english"

I think I might be doing something wrong during the installation.
Any help will be appreciated :)

Thank you for this awesome mod :D

Jon2
Registered User
Posts: 51
Joined: Mon Aug 18, 2003 7:11 pm
Contact:

Post by Jon2 » Tue Nov 18, 2003 2:30 am

Does this mod allow an admin/moderator to force sigs on or off for a user? Or is it only to allow a user to turn them on or off?

User avatar
Rat
Registered User
Posts: 102
Joined: Wed Oct 23, 2002 4:46 am
Location: Houston, TX
Contact:

Post by Rat » Fri Nov 21, 2003 6:16 pm

for some reason when i install this with easymod3beta10 it didn't edit the "viewtopic_body.tpl" correctly and cause a booboo so i had to do it manually and it work perfect.

and it didn't even backup the files for me ..errr lucky that i always have second backup for this stuff.

i like this mod options ;) thanks.
Rat

ayn
Registered User
Posts: 7
Joined: Mon Nov 10, 2003 5:02 pm
Location: Austin, TX
Contact:

Post by ayn » Fri Nov 21, 2003 7:14 pm

I installed this mod and the edit user page in Admin shows wrong value of $showsignature... the user profile edit page has the correct value... strangely enough, $showavatar's at both pages are the same and correct... any ideas? thanks!

--Andrew

User avatar
Rat
Registered User
Posts: 102
Joined: Wed Oct 23, 2002 4:46 am
Location: Houston, TX
Contact:

Post by Rat » Fri Nov 21, 2003 8:50 pm

ayn wrote: I installed this mod and the edit user page in Admin shows wrong value of $showsignature... the user profile edit page has the correct value... strangely enough, $showavatar's at both pages are the same and correct... any ideas? thanks!

--Andrew


i notice the same problem, but it doesn't set to NO it just as default the ratio button is go to no when you try to manage user, but if you don't hit apply then in Profile setting will be as user default. but if you leave as NO and hit apply sure in profile will also change to no. so how can we change this so that it will show the default of what user have?
Rat

ayn
Registered User
Posts: 7
Joined: Mon Nov 10, 2003 5:02 pm
Location: Austin, TX
Contact:

Post by ayn » Fri Nov 21, 2003 9:42 pm

that is the EXACT behavior I'm experiencing... I went in there to check if my users were using this new feature, and found out it doesn't really show it there as the default selection... (yes, I can just do a SQL query to find out but that is slightly easier)...

--Andrew
Rat wrote:
ayn wrote:I installed this mod and the edit user page in Admin shows wrong value of $showsignature... the user profile edit page has the correct value... strangely enough, $showavatar's at both pages are the same and correct... any ideas? thanks!

--Andrew


i notice the same problem, but it doesn't set to NO it just as default the ratio button is go to no when you try to manage user, but if you don't hit apply then in Profile setting will be as user default. but if you leave as NO and hit apply sure in profile will also change to no. so how can we change this so that it will show the default of what user have?

sany
Registered User
Posts: 2
Joined: Sun Nov 16, 2003 11:25 pm

Post by sany » Tue Nov 25, 2003 2:51 am

ayn wrote: I installed this mod and the edit user page in Admin shows wrong value of $showsignature... the user profile edit page has the correct value... strangely enough, $showavatar's at both pages are the same and correct... any ideas? thanks!

--Andrew

have noticed this as well.
found typo - now it works.
#
#-----[ FIND ]------------------------------------------
#
$allowsmilies = $this_userdata['user_allowsmile'];
#
#-----[ AFTER, ADD ]------------------------------------------
#
$showavatars = $this_userdata['user_showavatars'];
$showsigatures = $this_userdata['user_showsignatures'];

see, it says "showsigatures" not "showsigNatures.

to fix this, goto admin_users.php
search for "$showsigatures"
and instert the missing "n"
;)

sanyacid - brain-hack.org

User avatar
drumstix42
Registered User
Posts: 1100
Joined: Tue Sep 24, 2002 11:01 pm
Location: NJ
Contact:

Post by drumstix42 » Tue Nov 25, 2003 2:59 am

Wow. Nice eye 8O

Good job :)
Need a phpBB update or mod installed? PM me for any questions and pricing!
HostMonster.com (Unlimited Space, Unlimited Transfer, Unlimited Domains, $6.95/month )

sany
Registered User
Posts: 2
Joined: Sun Nov 16, 2003 11:25 pm

Post by sany » Tue Nov 25, 2003 5:12 pm

i have also did "allow smilies" in topics mod, its almost the same as this,
just had to edit different part in viewtopic. because some users of our
board complained about others using graphical smilies too much.. :P
if anyone interested, i can post it.

sanyacid

User avatar
drumstix42
Registered User
Posts: 1100
Joined: Tue Sep 24, 2002 11:01 pm
Location: NJ
Contact:

Post by drumstix42 » Wed Nov 26, 2003 3:49 am

Please do, I'm interested :)
Need a phpBB update or mod installed? PM me for any questions and pricing!
HostMonster.com (Unlimited Space, Unlimited Transfer, Unlimited Domains, $6.95/month )

Post Reply

Return to “[2.0.x] MOD Database Cleanup”