[2.0.6] RSS Content Syndicator

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
119
64%
Very Good
41
22%
Good
13
7%
Fair
5
3%
Poor
7
4%
 
Total votes: 185

reeait
Registered User
Posts: 1
Joined: Wed Dec 22, 2004 11:25 am
Location: Torino, Italy

Post by reeait »

I wish some css example for this... :-s

Okinesu
Registered User
Posts: 67
Joined: Fri Aug 06, 2004 6:03 am

Post by Okinesu »

Is there any way to create an actual .rss file? I am writing a Widget for Dashboard, and it refuses to use a.php file for aggregating RSS feeds. Is there any way to do this?

User avatar
Holyfrog
Registered User
Posts: 47
Joined: Thu May 01, 2003 6:03 pm
Location: Los Angeles, California
Contact:

Post by Holyfrog »

When using this MOD and reading the results in Thunderbird the date comes out as the date/time the item was downloaded and not the date/time of the post. Any thoughts?
Holyfrog HopsALot
WebMistress - www.Ladies-of-the-Lake.net

kjcdude
Registered User
Posts: 154
Joined: Mon Sep 27, 2004 10:23 pm
Location: Southern California
Contact:

Post by kjcdude »

I get the following error

Code: Select all

XML Parsing Error: not well-formed
Location: http://theocsucks.com/rss.php
Line Number 8, Column 39:	<managingEditor>"The OC Sucks" <Admin@theocsucks.com></managingEditor>
--------------------------------------^
http://theocsucks.com/rss.php

Any help is appreciated

Panama Jack
Registered User
Posts: 9
Joined: Fri May 13, 2005 6:48 am

Announcement and Sticky Support

Post by Panama Jack »

I am surprised no one has ever asked for this before. We have a mod we created that would only display Announcements from a specific forum as news on our main web site http://www.aatraders.com . When I found this RSS mod I wanted to use it just for the news on the main page but couldn't. It would send every message in the forum.

The following mod will allow you to select the topic type to display.

There is a new variable 'tt' for topic type that can be included in your url.

Example: http://forums.aatraders.com/rss.php?f=7&t=1&tt=2

The above will send ONLY Announcement topics instead of all topics.

tt = 0 ; Send just normal topics
tt = 1 ; Send just Sticky topics
tt = 2 ; Send just Announcement topics

Leave tt empty to send all topics as before.

Find:

Code: Select all

if ( $topics_only == 1 )
{
	$sql_topics_only_where = 'AND p.post_id = t.topic_first_post_id';
}
After Add:

Code: Select all

// Return only specific topics.  2 = Ammouncements, 1 = Stickies, 0 = Normal
if ( isset($HTTP_GET_VARS['tt']) && ($HTTP_GET_VARS['tt'] == 0 || $HTTP_GET_VARS['tt'] == 1 || $HTTP_GET_VARS['tt'] == 2))
{
	$sql_topics_only_where .= " AND t.topic_type = '" . $HTTP_GET_VARS['tt'] . "'";
}

webon
Registered User
Posts: 11
Joined: Tue Jan 11, 2005 8:59 am

Thanks for this MOD

Post by webon »

Very Cool ! and i feel different for my site now.

Thanks

basictheory
Registered User
Posts: 3
Joined: Fri Jan 28, 2005 11:09 am

Post by basictheory »

Yo

I have this mod installed on 3 message boards, no problem. But on a new one I am setting up for a friend, SharpReader throws this error:
Error reading URL: The underlying connection was closed: The server committed an HTTP protocol violation.
Please try to validate this feed. If this feed validates as correct RSS, you can send an error report.


here is my forum: http://www.angrypanda.brinkster.net/board/index.php
rss feed: http://www.angrypanda.brinkster.net/board/rss.php
and feed validator: http://feedvalidator.org/check?url=http ... %2frss.php

any help is appreciated. thx

kjcdude
Registered User
Posts: 154
Joined: Mon Sep 27, 2004 10:23 pm
Location: Southern California
Contact:

Post by kjcdude »

kjcdude wrote: I get the following error

Code: Select all

XML Parsing Error: not well-formed
Location: http://theocsucks.com/rss.php
Line Number 8, Column 39:	<managingEditor>"The OC Sucks" <Admin@theocsucks.com></managingEditor>
--------------------------------------^
http://theocsucks.com/rss.php

Any help is appreciated

http://feedvalidator.org/check.cgi?url= ... %2Frss.php
help still needed

Panama Jack
Registered User
Posts: 9
Joined: Fri May 13, 2005 6:48 am

Post by Panama Jack »

You need to go into the Admin area of your forums and select Configuration under General Admin.

Now change your Admin Email Address from

Code: Select all

"The OC Sucks" <Admin@theocsucks.com>
to

Code: Select all

Admin@theocsucks.com
This will fix your problem.

fatlumgair
Registered User
Posts: 2
Joined: Thu Jul 14, 2005 6:25 pm

Post by fatlumgair »

Hello, I've looked through quite a lot of this topic and I haven't found anything about this, so i appologise if it has already been said.

I'm using Safari. Why is it that some peoples RSS feeds can be seen at the right of the address bar.. like this persons..

http://forums.aatraders.com/

and mine and some others dont have it..

http://www.keithandthemarzipansoldiers.co.uk/forum

yet it has an rss feed... It also doesn't subscribe properly on firefox...

http://www.keithandthemarzipansoldiers. ... um/rss.php

can anyone help me?

fatlumgair
Registered User
Posts: 2
Joined: Thu Jul 14, 2005 6:25 pm

Post by fatlumgair »

Ok, I've got it working. I had some of my coding wrong. It needed to be (if anyone else needs it)...

<link rel="alternate" type="application/rss+xml" title="KMS Forum RSS" href="http://keithandthemarzipansoldiers.co.uk/forum/rss.php" />

Mistainu
Registered User
Posts: 44
Joined: Thu Jul 14, 2005 2:57 pm
Location: Nusantara
Contact:

HELP!!!

Post by Mistainu »

HELP!!!
(i've tried several RSS feed hacks n all dun work!!!)
i dunno why but i used fatlumgair's <link thingy in my head...of course i modded the name and the url to the roight place my own rss.php file.
http://unlimitedinfinity.com/rss.php
why doesn't it work? i didn't mod a single thing in the files i dl'ed frm this thread...was tehre anything to mod? plz help am a RSS newbie!!!
fatlumgair, how did u get u'rs working? i'm using Firefox too? so tell me!

maderlock
Registered User
Posts: 2
Joined: Fri Jul 15, 2005 5:11 pm

Post by maderlock »

This mod is getting a little dated now. I implemented a number of the changes suggested on the board, such as the security improvements and multiple forums. I also updated it to RSS 2.0, as others have done (wish I'd read this before). It doesn't take a lot of work to put these things together. How does one get the mod officially updated on the site?

Anyway, apart from the pubDate entry, one can also have an author entry. This is useful if syndicating in something like Thunderbird, where all the entires are listed as being written by the channel by default. I use a single password (admin@blahblah...com) and then put the name of the actual post author in brackets afterwards, giving the following sort of line in the xml file:

<author>admin@blahblah.com (username)</author>

To achieve this, just take a copy of $author in rss.php before it's modified by turning it into a link. Specify this as AUTHORNAME or some such, and then reference this in the template file. Easy.

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP »

I still need help with my problem. This used to work, but now all I get is the following when I click on the RSS link. There has to be an answer and a way to correct it. I'm running phpBB 2.0.16 and RSS Content Syndicator 2.0.2. I also have a heavily modded board, but I wouldn't think that would be an issue with the two included files from this MOD...

Image

:?:

Mistainu
Registered User
Posts: 44
Joined: Thu Jul 14, 2005 2:57 pm
Location: Nusantara
Contact:

Post by Mistainu »

heh...hey NightriderXP...i used the validator...and i have the same prob. it seems it's just THAT ONE LINE. somebody help plz?

Post Reply

Return to “[2.0.x] MOD Database Cleanup”