[2.0.15] Latest active topics on index

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
80
54%
Very Good
41
28%
Good
14
10%
Fair
7
5%
Poor
5
3%
 
Total votes: 147

zparta
Registered User
Posts: 142
Joined: Fri Apr 04, 2003 7:14 am
Location: Sweden
Contact:

Post by zparta » Thu Feb 05, 2004 4:57 am

most problems with this mod should be fixed if the new version is validated

i may have to reconsider to upload it again dont know if it got thru

and no *nuke support you willl have to ask at their site

and to change the amount of topics to show you just change it in configuration in the ACP

sorry for the late answer but i have had alot of other stuff to do

regards ZParta

TammyH
Registered User
Posts: 30
Joined: Thu Dec 11, 2003 4:01 pm
Contact:

Post by TammyH » Fri Feb 06, 2004 11:20 pm

I tried this one, but it didn't want to work for me. I'm not giving anything a "bad" poll ranking though. I'm new to this whole mod thing, so odds are it was my own fault. :)

ddhblt
Registered User
Posts: 57
Joined: Sun Feb 09, 2003 10:09 pm

Post by ddhblt » Sat Feb 07, 2004 12:06 am

I still like this one better...http://www.phpbb.com/phpBB/viewtopic.php?t=105449.

I've had it working on 2.0.4 & 2.0.6 with little install or setup problems. It's no longer in development, but it really doesn't need any. It works just fine.

Magical One
Registered User
Posts: 9
Joined: Sun Feb 01, 2004 12:40 pm

Post by Magical One » Sat Feb 14, 2004 8:32 am

how can i make the background black in color, right now its a off grey?

CrazyICE
Registered User
Posts: 17
Joined: Sat Feb 07, 2004 1:34 pm
Location: Steiermark / AUSTRIA
Contact:

Post by CrazyICE » Tue Feb 17, 2004 12:34 pm

i'm a newb and have two little questions!

1.) marquee on other sites than forum-index:
is it possible to show this marquee on the index page of my website instead of the index page of the forum?
so that the newest posts are shown on the mainpage of my homepage!

2.) functionallity without logging in
is it possible to show the latest threads even if you're not logged in?

please help!
Image

zparta
Registered User
Posts: 142
Joined: Fri Apr 04, 2003 7:14 am
Location: Sweden
Contact:

Post by zparta » Wed Feb 18, 2004 3:24 pm

1.) no you cant this is only for the forum you got topics anywhere for that kind of thing

2.) it shows the latest post on the forums you are able to read so if you let everybody read a forum then it will show when not logged in

CrazyICE
Registered User
Posts: 17
Joined: Sat Feb 07, 2004 1:34 pm
Location: Steiermark / AUSTRIA
Contact:

Post by CrazyICE » Wed Feb 18, 2004 3:29 pm

is there a workaround to show the marquee (with content of course) on other sites than the index_body?
Image

zparta
Registered User
Posts: 142
Joined: Fri Apr 04, 2003 7:14 am
Location: Sweden
Contact:

Post by zparta » Sun Feb 22, 2004 11:59 pm

not that i know of but there is some other mods that puts latest active topics on another page

richard_5421
Registered User
Posts: 521
Joined: Tue Dec 30, 2003 12:57 am

Post by richard_5421 » Fri Feb 27, 2004 12:52 am

Does it scroll automatically like on your forum found [here] :)

Its very useful will be using it soon :wink:

richard_5421
Registered User
Posts: 521
Joined: Tue Dec 30, 2003 12:57 am

Post by richard_5421 » Fri Feb 27, 2004 2:17 am

I've installed it :lol:

But.. it shows topic's that are in the moderators only section, aswell as items that
are in hidden usergroups and private (special access) forums..
Its very good but I dont want people knowing whats going on in these sections :P
This is to normal users that are not moderators and also shows to guests

--

Is there also anyway the active posts box would show to guests but no topics
are shown that request log in because all my forums request log-in except for the rules one.
So is it possible that only the rules one could be shown, as this is view and read to everyone

Please could you tell me how I change it.


Many thanks for the add on mod :)

richard_5421
Registered User
Posts: 521
Joined: Tue Dec 30, 2003 12:57 am

Post by richard_5421 » Sat Feb 28, 2004 6:18 pm

hiya, heres the problem that I have found, and need some help on how to correct it.

For example in the Moderators only section that only moderators can read,
when a guest is on the board (no username) they cannot see the topics scrolling,
that have been posted but when users that have logged in are on the board,
Topics are seen scrolling.. I would like these topics in this section to not come up
in this section, only scroll in this box to moderators

As you can see these are the permissions:

Image


Now another problem when you have a private forum, or usergroup and you
set it as View - Private as seen in the image below only the topics are seen
by members that are allowed in this part of the forum or group

Image

But I would like it so I can have this part as View - All or Reg but guests and
members can not see the topics scrolling in the box, only members of this part
of the forum or group can see them scrolling.

This problem also occurs as posted above when you have a hidden part on the forum


Please could someone help me :)


Many thanks

Einstein
Registered User
Posts: 247
Joined: Sat Oct 18, 2003 9:48 pm
Location: Finland
Contact:

Post by Einstein » Sat Feb 28, 2004 8:00 pm

Richard, I think that my "auth" modification will do the thing ... try it. You will find my posts sent earlier.

richard_5421
Registered User
Posts: 521
Joined: Tue Dec 30, 2003 12:57 am

Post by richard_5421 » Sat Feb 28, 2004 10:54 pm

Einstein wrote: Seems like a lot of people has the same problem so here you go. Try this if your list seems to be empty.

Category Hierachy 2.0.2 patch for Latest Topic on Index MOD 1.1.2
Also other versions may work.

Find:

Code: Select all

$is_auth_ary = array(); 
$is_auth_ary = auth(AUTH_VIEW, AUTH_LIST_ALL, $userdata, $forum_data); 
$auth_view_forum_sql = ''; 
for($i = 0; $i < $total_categories; $i++) 
{ 
$cat_id = $category_rows[$i]['cat_id']; 
$display_forums = false; 
for($j = 0; $j < $total_forums; $j++) 
{ 
if ( $is_auth_ary[$forum_data[$j]['forum_id']]['auth_view'] && $forum_data[$j]['cat_id'] == $cat_id ) 
{ 
$display_forums = true; 
$auth_view_forum_sql .= ($auth_view_forum_sql == '' ? '' : ', ' ) . $forum_data[$j]['forum_id']; 
} 
} 
} 
$auth_view_forum_sql = ($auth_view_forum_sql == '' ? '(0)' : '(' . $auth_view_forum_sql . ')'); 
Replace with:

Code: Select all

$keys = array(); 
$keys = get_auth_keys('Root'); 
$auth_view_forum_sql = ''; 
for ($i=0; $i < count($keys['id']); $i++) 
{ 
   if ($tree['type'][ $keys['idx'][$i] ] == POST_FORUM_URL) 
   { 
      $auth_view_forum_sql .= (($auth_view_forum_sql != '') ? ', ' : '') . $tree['id'][ $keys['idx'][$i] ]; 
   } 
} 
$auth_view_forum_sql = ($auth_view_forum_sql == '' ? '(0)' : '(' . $auth_view_forum_sql . ')');


Is this the one you wanted me to try, have just tried this and when I refreshed
the page I got a blank white one, soo doesnt look like that one works :?

Einstein
Registered User
Posts: 247
Joined: Sat Oct 18, 2003 9:48 pm
Location: Finland
Contact:

Post by Einstein » Sun Feb 29, 2004 12:08 am

richard_5421 wrote: Is this the one you wanted me to try, have just tried this and when I refreshed
the page I got a blank white one, soo doesnt look like that one works :?

Yes, it was that I mean ... but it doesn't seem to work, for you (I have CH installed).

The place to make the correction is the same place.

Code: Select all

$is_auth_ary = auth(AUTH_VIEW, AUTH_LIST_ALL, $userdata, $forum_data);
But don't know what to change. There may be some comments (hints) in this thread.

richard_5421
Registered User
Posts: 521
Joined: Tue Dec 30, 2003 12:57 am

Post by richard_5421 » Sun Feb 29, 2004 12:50 am

Thanks for your help anyway, maybe someone else could tell us what we change :lol:


Thanks again

Post Reply

Return to “[2.0.x] MOD Database Cleanup”