[2.0.8] Forum Permissions List

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
53
67%
Very Good
19
24%
Good
6
8%
Fair
0
No votes
Poor
1
1%
 
Total votes: 79

Jissh
Registered User
Posts: 4
Joined: Fri Jan 30, 2004 9:00 pm

Problem Solved

Post by Jissh » Tue Feb 03, 2004 8:58 am

Problem Solved.
I removed this line that was in the addon file included with the download. Go figgure.
Thanks for taking the time to reply to my post.



#
#-----[ OPEN ]------------------------------------------
#
admin/admin_forumauth_list.php

#
#-----[ FIND ]------------------------------------------
#
$forum_auth_const = array(AUTH_ALL, AUTH_REG, AUTH_ACL, AUTH_MOD, AUTH_ADMIN);

#
#-----[ AFTER, ADD ]---------------------------------------
#
attach_setup_forum_auth($simple_auth_ary, $forum_auth_fields, $field_names);

#
#-----[ SAVE/CLOSE ALL FILES ]------------------------------------------
#
# EoM

Morning
Registered User
Posts: 11
Joined: Fri Dec 26, 2003 2:33 pm

a demo would be nice

Post by Morning » Tue Feb 03, 2004 10:49 am

or some screen shots - i am not sure if tis is what I am looking for!

Graham
Former Team Member
Posts: 8462
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK
Contact:

Post by Graham » Tue Feb 03, 2004 12:46 pm

Yes, you only need that line if you use the Attachment MOD, it is not part of the standard code, hence why it was in the Add-On folder ;)

I haven't posted any screenshots so far, although Itry and sort a few out.
"So Long, and Thanks for All the Fish"

phpBB Useful Links: Knowledge Base | Userguide | Forum Search | MOD Database | Styles Database
My Links: Blog!

User avatar
otseng
Registered User
Posts: 160
Joined: Wed Feb 04, 2004 6:51 pm
Location: Atlanta, GA
Contact:

Post by otseng » Fri Feb 06, 2004 10:15 pm

Ahh... much nicer to admin forums now. Thanks!

Universi Ruler
Registered User
Posts: 18
Joined: Sat Feb 07, 2004 11:08 pm
Location: Rome
Contact:

Post by Universi Ruler » Sat Feb 07, 2004 11:11 pm

Hi guys!

I have installed this grat mod, but I have a question: I have also installed the Global Announcement mod. It let me set the permission to post global announcements in every forum. How can I add another column the forum permission list, showing also the Global Announcement setting?


Thanks

Universi Ruler
Registered User
Posts: 18
Joined: Sat Feb 07, 2004 11:08 pm
Location: Rome
Contact:

Post by Universi Ruler » Sat Feb 07, 2004 11:17 pm

Issue resolved, no problem

chrtad
Registered User
Posts: 130
Joined: Sat Jan 10, 2004 11:59 pm

Post by chrtad » Sat Feb 14, 2004 1:08 pm

I tryed installing this mod a few times now but continue to get the following error when I go to the ACP:
Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/tpbb/language/lang_english/lang_admin.php:799) in /home/public_html/tpbb/admin/index.php on line 582

Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/tpbb/language/lang_english/lang_admin.php:799) in /home/public_html/tpbb/admin/index.php on line 583


I also have installed the admin user list mod and the attachment mod.

Any Suggestions?

Graham
Former Team Member
Posts: 8462
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK
Contact:

Post by Graham » Sat Feb 14, 2004 3:31 pm

It would appear that you have some form or error in lang_admin.php after installing this MOD. First off, just double check that the lines you have put in there exactly match those which were in the instructions and that you have nothing in that file after the final "?>"
"So Long, and Thanks for All the Fish"

phpBB Useful Links: Knowledge Base | Userguide | Forum Search | MOD Database | Styles Database
My Links: Blog!

chrtad
Registered User
Posts: 130
Joined: Sat Jan 10, 2004 11:59 pm

Post by chrtad » Sat Feb 14, 2004 5:38 pm

I did exactly as the mod told me to but it kept giving me the error. I did fix the problem though just by placing all of the information near the end of the file rather than scattered throughout the file.

chrtad
Registered User
Posts: 130
Joined: Sat Jan 10, 2004 11:59 pm

Post by chrtad » Sat Feb 14, 2004 6:19 pm

Having the same problem again. I just created another lang file and included it in the admin_forumauth_list.php. I like the mod but I wish it would work without me having to figure out how to install it.

stueynet
Registered User
Posts: 4
Joined: Mon Feb 23, 2004 6:59 pm

Awesome Mod but I am going insane with this problem

Post by stueynet » Mon Feb 23, 2004 7:02 pm

I have done everything. I have fixed all the problems listed on this board but I am getting something not listed.

Code: Select all

SQL Error : 1054 Unknown column 'auth_globalannounce' in 'field list'

UPDATE phpbb_forums SET auth_view = 0, auth_read = 0, auth_post = 0, auth_reply = 0, auth_edit = 1, auth_delete = 1, auth_sticky = 3, auth_announce = 3, auth_vote = 1, auth_pollcreate = 1, auth_globalannounce = 0 WHERE cat_id = 2

Line : 185
File : /home/httpd/vhosts/barryscabin.com/httpdocs/admin/admin_forumauth_list.php

Any Idea? The list shows up on the admin bar on the left side and when I click it it shows all the perms at a glance but when I try to update this is what happens.

When i view the list it looks like there is an unlabeled column all the way on the right side.

Please help.

Graham
Former Team Member
Posts: 8462
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK
Contact:

Post by Graham » Tue Feb 24, 2004 12:12 pm

You appear to have made changes to the MOD that only apply if you are running the Global Announce MOD, which I assume that you are not.

The MOD should work out of the box on standard configs, so just replace your editing admin_forumauth_list.php file with the one that came in the download and it shold work.
"So Long, and Thanks for All the Fish"

phpBB Useful Links: Knowledge Base | Userguide | Forum Search | MOD Database | Styles Database
My Links: Blog!

stueynet
Registered User
Posts: 4
Joined: Mon Feb 23, 2004 6:59 pm

Post by stueynet » Tue Feb 24, 2004 5:58 pm

Many thanks. I was a bit confused. This Mod rules.

Cheers

DavidJ01
Registered User
Posts: 14
Joined: Mon Feb 23, 2004 5:15 am
Contact:

Post by DavidJ01 » Wed Feb 25, 2004 3:49 am

Edit Mode on: Never mind for now, I think I found my answer :lol: Edit Mode Off:

Thanks,

David....

korko
Registered User
Posts: 29
Joined: Mon Aug 11, 2003 6:11 pm

Post by korko » Thu Feb 26, 2004 2:12 pm

if you have hierarchie mod installed on your board, you have a file called def_auth.php on include repertory.
So i do an add-on for this.

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
admin/admin_forumauth_list.php 

#
#-----[ FIND ]--------------------------------------------
# 
//                View      Read      Post      Reply     Edit     Delete    Sticky   Announce    Vote      Poll
$simple_auth_ary = array(
	0  => array(AUTH_ALL, AUTH_ALL, AUTH_ALL, AUTH_ALL, AUTH_REG, AUTH_REG, AUTH_MOD, AUTH_MOD, AUTH_REG, AUTH_REG),
	1  => array(AUTH_ALL, AUTH_ALL, AUTH_REG, AUTH_REG, AUTH_REG, AUTH_REG, AUTH_MOD, AUTH_MOD, AUTH_REG, AUTH_REG),
	2  => array(AUTH_REG, AUTH_REG, AUTH_REG, AUTH_REG, AUTH_REG, AUTH_REG, AUTH_MOD, AUTH_MOD, AUTH_REG, AUTH_REG),
	3  => array(AUTH_ALL, AUTH_ACL, AUTH_ACL, AUTH_ACL, AUTH_ACL, AUTH_ACL, AUTH_ACL, AUTH_MOD, AUTH_ACL, AUTH_ACL),
	4  => array(AUTH_ACL, AUTH_ACL, AUTH_ACL, AUTH_ACL, AUTH_ACL, AUTH_ACL, AUTH_ACL, AUTH_MOD, AUTH_ACL, AUTH_ACL),
	5  => array(AUTH_ALL, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD),
	6  => array(AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD, AUTH_MOD),
);

$simple_auth_types = array($lang['Public'], $lang['Registered'], $lang['Registered'] . ' [' . $lang['Hidden'] . ']', $lang['Private'], $lang['Private'] . ' [' . $lang['Hidden'] . ']', $lang['Moderators'], $lang['Moderators'] . ' [' . $lang['Hidden'] . ']');

$forum_auth_fields = array('auth_view', 'auth_read', 'auth_post', 'auth_reply', 'auth_edit', 'auth_delete', 'auth_sticky', 'auth_announce', 'auth_vote', 'auth_pollcreate');

$field_names = array(
	'auth_view' => $lang['View'],
	'auth_read' => $lang['Read'],
	'auth_post' => $lang['Post'],
	'auth_reply' => $lang['Reply'],
	'auth_edit' => $lang['Edit'],
	'auth_delete' => $lang['Delete'],
	'auth_sticky' => $lang['Sticky'],
	'auth_announce' => $lang['Announce'], 
	'auth_vote' => $lang['Vote'], 
	'auth_pollcreate' => $lang['Pollcreate']);

$forum_auth_levels = array('ALL', 'REG', 'PRIVATE', 'MOD', 'ADMIN');
$forum_auth_const = array(AUTH_ALL, AUTH_REG, AUTH_ACL, AUTH_MOD, AUTH_ADMIN);

#
#-----[ REPLACE WITH ]------------------------------------
# 
//-- mod : categories hierarchy --------------------------------------------------------------------
//-- delete
// all the preset and auth fields definition has been moved to includes/def_auth.php
//-- add
// auth list : put in this file all the auth fields description
include( $phpbb_root_path . './includes/def_auth.' . $phpEx );

// build an indexed array on field names
@reset($field_names);
$forum_auth_fields = array();
while ( list($auth_key, $auth_name) = @each($field_names) )
{
	$forum_auth_fields[] = $auth_key;
}
//-- fin mod : categories hierarchy ----------------------------------------------------------------

Post Reply

Return to “[2.0.x] MOD Database Cleanup”