[2.0.6] Post icons

The cleanup is complete. This forum is now read only.
Post Reply

Rating:

Excellent!
34
60%
Very Good
12
21%
Good
3
5%
Fair
3
5%
Poor
5
9%
 
Total votes: 57

Extensions Robot
Extensions Robot
Extensions Robot
Posts: 27750
Joined: Sat Aug 16, 2003 7:36 am

[2.0.6] Post icons

Post by Extensions Robot » Tue Oct 28, 2003 10:41 pm

MOD Name: Post icons
Author: Ptirhiik - RPGnet-fr
MOD Description: This mod will add icons in front of the title of messages, and comes with a solid admin interface.

Disclaimer: This MOD has not been Validated by the MOD Team. The MOD has been tested for functionality only. For more information see this topic. However, the author has proven to be trustworthy.

MOD Version: 1.0.1

Download File: mod-post_icons-101.zip
File Size: 48064 Bytes
Last edited by Extensions Robot on Mon Apr 30, 2007 12:30 am, edited 1 time in total.
(this is a non-active account manager for the phpBB Extension Customisations Team)

User avatar
Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Mon Dec 15, 2003 6:21 pm

Again, this MOD was not thoroughly validated, but we are make a one-time exception.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Tue Dec 16, 2003 4:35 am

Note this mod was originaly based on Message Icons by steveurkel <spam@stefand.de> - http://www.austauschforum.de I used as a lot of people, but has been restarted from scratch except the database field, as I needed a solid admin interface and a multi-language/multi-template support :).

User avatar
lozt
Registered User
Posts: 527
Joined: Thu Aug 15, 2002 5:11 am
Location: Paradise

Post by lozt » Wed Dec 17, 2003 5:06 am

i used austauschforum.de on 2.0.4, but if i use your post icon mod, for 2.0.6 would my current posts keep the same icon, or is it a totally different code?

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Wed Dec 17, 2003 5:26 am

As long as you defined your icon list the same than the one hardcoded in your actual forum, you will find back the same icons for topics :). You may want to edit def_icon.php the first time to set the URI of the icons yiu are using currently according to their id, it will be slightly quicker than doing it with the admin interface, as you will probably modify them all. After installation, you will be able to polish this with the admin tool ;).

User avatar
lozt
Registered User
Posts: 527
Joined: Thu Aug 15, 2002 5:11 am
Location: Paradise

Post by lozt » Wed Dec 17, 2003 11:32 am

im having minor problems with this mod -- i tryed to back track and everything seem to be correct according to the instructions. i am still unsure if i installed it wrong, but maybe you can figure it out.

in admin control panal.. .
when i click on Configuration + i get this error message below.
Fatal error: Call to undefined function: mods_settings_get_lang() in /home/public_html/admin/admin_board_extend.php on line 326


when i click on Icons settings it loads just find, but when i tryed to deleted the icons i do not need, it just bring me back to "Icons settings" page with no changes.

for user's setting, when i click on Preferences i get the error below.
Fatal error: Call to undefined function: mods_settings_get_lang() in /home/public_html/profile_options.php on line 373

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Wed Dec 17, 2003 11:39 am

Check you have uploaded all files at their dedicated place : be very carefull of the mod install description : directories structure of the mod is not directories structure of phpBB : you have to follow the install description very preciasly. If all is at the place it has to be, recheck your modifications in functions.php.

User avatar
lozt
Registered User
Posts: 527
Joined: Thu Aug 15, 2002 5:11 am
Location: Paradise

Post by lozt » Wed Dec 17, 2003 11:52 am

copy mod_post_icons.php to includes/mods_settings/mod_post_icons.php


was where i got confused.
i got it working now thank you very much.

User avatar
lozt
Registered User
Posts: 527
Joined: Thu Aug 15, 2002 5:11 am
Location: Paradise

Post by lozt » Wed Dec 17, 2003 11:58 am

in admin control panal.. .
my problem with "Configuration +" is now sloved, but still having problems deleting unused icons

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Wed Dec 17, 2003 12:07 pm

Take a look at the CHMOD asked (same old mod install description you know ;)).

stefan2k1
Registered User
Posts: 168
Joined: Thu Sep 06, 2001 11:16 am
Location: Germany
Contact:

Post by stefan2k1 » Wed Dec 17, 2003 12:08 pm

Hi,

any way to display the msg icons also in index.php and viewtopic.php ? Maybe also on Ezportal ?
Last edited by stefan2k1 on Wed Dec 17, 2003 12:28 pm, edited 1 time in total.

User avatar
lozt
Registered User
Posts: 527
Joined: Thu Aug 15, 2002 5:11 am
Location: Paradise

Post by lozt » Wed Dec 17, 2003 12:10 pm

oh, i had forgot to look at the "Author Notes"
Thanks for the quick reply!
:D

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Wed Dec 17, 2003 12:11 pm

stefan2k1 wrote: Hi,

any way to display the msg icons also in index.php and viewtopic.php ? Maybe also on Ezportal ?
This is only a matter of calling with the post icon id the good function : take a look at viewforum ie.

quentin
Registered User
Posts: 197
Joined: Tue May 20, 2003 7:30 am
Location: Geneva, Switzerland
Contact:

Post by quentin » Wed Dec 17, 2003 12:32 pm

Nice to see this validated ! thought we would have to wait until 2.2 :-p.
Very cool mod anyway.

Quentin
The largest message boards on the web !
Web Design Library (coming soon)
Friends sites: Heroes of might and magic - Biometric security

User avatar
Aahz
Registered User
Posts: 39
Joined: Sun Nov 02, 2003 9:44 pm
Location: ...Behind The Curtain
Contact:

Post by Aahz » Thu Dec 18, 2003 3:14 pm

I know these were only "pre-screened", but aren't all released MODs supposed to be EasyMod compliant?

This one's not.

Code: Select all

#-----[ COPY ]------------------------------------------------
#
# icons
#
copy icon/*.* to images/icon/*.*
#
EasyMod 0.0.11 cannot use *.*

Code: Select all

#-----[ COPY ]------------------------------------------------
#
# Lang settings
#
copy lang_settings/lang_extend_mac.php to includes/lang_extend_mac.php
#
should read

Code: Select all

#-----[ COPY ]------------------------------------------------
#
# Lang settings
#
copy mod-lang_settings/lang_extend_mac.php to includes/lang_extend_mac.php
#
-Aahz

Post Reply

Return to “[2.0.x] MOD Database Cleanup”

Who is online

Users browsing this forum: No registered users and 18 guests