[2.0.8] Faq Editor

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
66
80%
Very Good
10
12%
Good
2
2%
Fair
1
1%
Poor
4
5%
 
Total votes: 83

User avatar
ZGJ
Registered User
Posts: 27
Joined: Sun Aug 20, 2006 12:07 am

Post by ZGJ » Wed Sep 20, 2006 6:01 pm

there are TWO faq mods:

[2.0.8] Faq Editor http://www.phpbb.com/phpBB/viewtopic.ph ... hlight=faq
[2.0.6] faq admin mod http://www.phpbb.com/phpBB/viewtopic.ph ... hlight=faq

what is the difference between them?

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Post by igorw » Wed Sep 20, 2006 8:51 pm

As far as i know the faq admin mod puts the whole FAQ into the database and the Faq Editor (this MOD) edits the language files.

Faq Editor is much simpler imo, and also very compatible with other MODs. It was so simple to make it work with my rules page MOD. The FAQ admin mod on the other hand was a pain.

Faq editor is also newer, but that doesn't always mean better. I prefere it though ;)
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three

Selven
Registered User
Posts: 291
Joined: Fri Nov 08, 2002 7:28 am

Post by Selven » Thu Sep 21, 2006 7:37 pm

As already described by eviL<3 the main difference beetween faq editor e faq admin is the way they works:
  • Faq Editor
    • Pro:
      • Really easy to install (it can be installed simply by uloading files in root directory)
      • No db addiction (size and query)
      • No touch original phpbb code, more compatible with other mod.
      • Work
    • Against:
      • Not support BBcode
      • Require write permission on faq_ files (chmod 666 or higer)
  • Faq Admin
    • Pro:
      • Support BBcode
      • Not require write permission of any type
    • Against:
      • Installation really difficult
      • Hardly change to faq system (difficult to integrate with other mod)
      • Increasing database size and query
      • No more supported
      • Not work for what i know
No-more supporting phpBB

User avatar
mfrankena
Registered User
Posts: 128
Joined: Sun Apr 17, 2005 3:11 pm

Post by mfrankena » Mon Nov 06, 2006 5:57 pm

hmm can you guys help me out,

suddenly my board rules page, doesn't function/display properly.
The FAQ editor in the ACP is working fine, i can see and modify everything on both the FAQ and the Rules pages.
But when i select the rules page on index, i only see the top part of the page where all is listed. The second half of the page doesn't display anymore.

Any idea what could cause this ?????
Regards,
Martin

Sites: BF2CC Admin // 2142CC Admin // M.B.T. Admin // Homepage

User avatar
Roks
Registered User
Posts: 119
Joined: Thu Sep 14, 2006 1:15 am

Post by Roks » Mon Nov 06, 2006 11:36 pm

How did you get the Rules Page editing link in Admin cPanel. I have tried all means, but I cldn't see Rules Page editing link there in Admin CP.

I have contacted Evil also, about that, as I am using his Rules Page MOD, but nothing happened.

User avatar
mfrankena
Registered User
Posts: 128
Joined: Sun Apr 17, 2005 3:11 pm

Post by mfrankena » Tue Nov 07, 2006 12:05 pm

Roks wrote: How did you get the Rules Page editing link in Admin cPanel. I have tried all means, but I cldn't see Rules Page editing link there in Admin CP.

I have contacted Evil also, about that, as I am using his Rules Page MOD, but nothing happened.


read a few pages back and you will see a couple of postings with the solution.
You need to make some changes manually in the files.

see my post HERE ;-)
Regards,
Martin

Sites: BF2CC Admin // 2142CC Admin // M.B.T. Admin // Homepage

Selven
Registered User
Posts: 291
Joined: Fri Nov 08, 2002 7:28 am

Post by Selven » Wed Nov 08, 2006 5:04 am

mfrankena wrote: Any idea what could cause this ?????

no link of page?
I have contacted Evil also, about that, as I am using his Rules Page MOD, but nothing happened.

have you applied the change in contrib folder of rules page mod?
No-more supporting phpBB

User avatar
mfrankena
Registered User
Posts: 128
Joined: Sun Apr 17, 2005 3:11 pm

Post by mfrankena » Wed Nov 08, 2006 2:40 pm

Oh yes, no problem:
BF2CC rules page

Yup, it worked fine untill recently. The FAQ page and the FAQ editor both seem work fine...
Regards,
Martin

Sites: BF2CC Admin // 2142CC Admin // M.B.T. Admin // Homepage

Selven
Registered User
Posts: 291
Joined: Fri Nov 08, 2002 7:28 am

Post by Selven » Wed Nov 08, 2006 4:53 pm

can you zip your theme and rules page please seems an problem of template check if subsilver works 8O
No-more supporting phpBB

User avatar
mfrankena
Registered User
Posts: 128
Joined: Sun Apr 17, 2005 3:11 pm

Post by mfrankena » Sun Nov 12, 2006 11:22 am

Hi Selven,

send you a pm ;-)
No, isn't working with subsilver either. so there must be another issue...
Regards,
Martin

Sites: BF2CC Admin // 2142CC Admin // M.B.T. Admin // Homepage

for1lonestar
Registered User
Posts: 59
Joined: Tue Nov 21, 2006 12:01 pm

Installed MOD but now can't access FAQ

Post by for1lonestar » Fri Nov 24, 2006 2:05 am

Let me give you my background with phpbb, I have none! I am a total newbie so please don't get angry with me. I installed this MOD using easymod because I read that it could be installed that way.

Now when I or my members try to look at the FAQ we get this message:


Could not query faq entries

DEBUG MODE

SQL Error : 1146 Table 'mysqle0f84bb8e4576240ede5a70f7e6.phpbb_faq' doesn't exist

SELECT faq_id, faq_title FROM phpbb_faq WHERE lang_id = 'english' ORDER BY faq_id

Line : 216
File : faq.php

I know I must need to upload some files but I don't know what. I did download another copy of phpbb and uploaded the faq.php the general error mentions but that didn't do anything.

I only know how to upload files by ftp and how to use easymod. I don't know how to go in and edit files to install MODs manuallly.

Thanks for any help you all can offer.
Jonny

for1lonestar
Registered User
Posts: 59
Joined: Tue Nov 21, 2006 12:01 pm

Never mind

Post by for1lonestar » Fri Nov 24, 2006 6:47 am

Never mind, I figured it out.

I had installed both the fag admin and faq edit (thought I was reinstalling admin to see if it would correct the missing FAQ.)

Anyway, I uninstalled "faq admin" (manually, I am so proud of myself) and reinstalled the files having to do with the FAQ and all is back to normal now and fag edit works great.
Jonny

Selven
Registered User
Posts: 291
Joined: Fri Nov 08, 2002 7:28 am

Post by Selven » Sat Nov 25, 2006 2:44 pm

good :wink:
No-more supporting phpBB

for1lonestar
Registered User
Posts: 59
Joined: Tue Nov 21, 2006 12:01 pm

[SOLVED] well.......

Post by for1lonestar » Sat Nov 25, 2006 2:53 pm

Actually, it won't let me delete or edit anything. It is there to use but when I try I get the error message:

You must make the language file in language/lang_english/ or equivilent writeable to use this control panel. On UNIX, this means running chmod 666 filename. Most FTP clients can do through the properties sheet for a file, otherwise you can use telnet or SSH.

DEBUG MODE

Line : 497
File : admin_faq_editor.php

And my FTP won't recognize the change as to writable. I am so new to this it may be hopeless.
Jonny
Last edited by for1lonestar on Mon Nov 27, 2006 9:02 am, edited 1 time in total.

Selven
Registered User
Posts: 291
Joined: Fri Nov 08, 2002 7:28 am

Post by Selven » Sun Nov 26, 2006 1:46 pm

no know your ftp client but generally there are an part can permit to set the permission of files...
No-more supporting phpBB

Post Reply

Return to “[2.0.x] MOD Database Cleanup”