[2.0.6] Prune User Posts

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
21
66%
Very Good
5
16%
Good
3
9%
Fair
0
No votes
Poor
3
9%
 
Total votes: 32

User avatar
Gideon5L2F
Registered User
Posts: 242
Joined: Thu Oct 09, 2003 6:33 pm
Location: New Zealand
Contact:

Re: Feature request

Post by Gideon5L2F »

dzm wrote: I know the nobody is actively working on this, but if there WERE I'd ask for this enhancement:

Provide a "save" checkbox for all individual messages (which by default inherit the state of their parent thread) visible to me and mods when viewing the contents of threads. Allow me to purge everyone older than a certain date EXCEPT the items that have Save checked.


:idea: :idea: Yes please! :idea: :idea:

This is a fantastic idea. Now we are talking intelligent pruning.
Alex Zuyev
Registered User
Posts: 32
Joined: Sun Dec 28, 2003 1:47 pm
Location: Moscow
Contact:

pure counter

Post by Alex Zuyev »

Is it possible to see the result counter? EX:

Code: Select all

Pured 5 topics, 10 messages deleted.
Best wishes,
Alex
deadjdona
Registered User
Posts: 8
Joined: Tue Feb 28, 2006 9:09 am

Post by deadjdona »

Is there ALL forums checkbox? I use Categories Hierarchy mod but old version, and Prune Posts don't show me some of subforums (((
Hedonist
Registered User
Posts: 13
Joined: Sat Mar 25, 2006 6:11 pm

Post by Hedonist »

Hello Here's my problem. I've prune 2 users on my message board.
When I search for their messages it says no messages found.

Yet when I follow the members' link. There I can read :
X 114 messages
X 24 messages

Why does the number of messages still appear whereas all their posts have been deleted?

Is this a bug of the script?

I've put yes for both:
Adjust Post Counts? Oui
Update Search Tables? Oui

I have 2.20 message board and I think I'm using 1.2 version of this mod.
CrayfishAssociation
Registered User
Posts: 6
Joined: Sat May 27, 2006 1:09 pm

Post by CrayfishAssociation »

again well done mate on the mod.

had some trouble resyncing but not worried about it at all. just think it is when you remove a topic starters post it messes it up. but the db remains stable on 2.20

Thanks for your efforts

edited to add - forgot to mention that I use a database management mod (cant remember the name of it) but it fixes any issues when removing posts etc with this mod. Especially when you remove a few thousand in one hit lol
Hedonist
Registered User
Posts: 13
Joined: Sat Mar 25, 2006 6:11 pm

Post by Hedonist »

Could someone tell me if this is normal the numbers of messages after pruning posts does not change...
Thank you
dcz
Registered User
Posts: 787
Joined: Sun Feb 13, 2005 5:37 am
Contact:

Post by dcz »

Coagulant wrote: In admin/admin_prune_user_posts.php
// Mark posts in topic for deletion (if there are other posts in this thread)
if($posts[$i]['topic_last_post_id'] != $posts[$i]['topic_last_post_id'])

Looks like a bug to me, should be
// Mark posts in topic for deletion (if there are other posts in this thread)
if($posts[$i]['topic_first_post_id'] != $posts[$i]['topic_last_post_id'])



This maybe ?

phpBB SEO || phpBB3 SEO Premod || SEO phpBB3
GYM Sitemaps & RSS for phpBB3: GYM Sitemaps & RSS
hm2k
Registered User
Posts: 108
Joined: Mon Jun 09, 2003 2:04 pm
Location: UK
Contact:

Post by hm2k »

Can someone display a demo or screenshots of this and put them in the first posts, thanks.
who_am_i
Registered User
Posts: 2
Joined: Wed Sep 01, 2004 4:59 am

Multiple Users support for "Prune Users Posts" MOD

Post by who_am_i »

Hi,

It would be great if you can support for multiple users. It could be a text box where users can just paste a username in each line.

PHPBB Forums are being spammed in large amount. People can easily copy and paste multiple users in this text box and delete their posts.

Thanks for your cool MOD.

Regards,
GJ
kjnpf
Registered User
Posts: 104
Joined: Tue Apr 29, 2003 9:27 am
Location: Cheshire, England
Contact:

Post by kjnpf »

Will this mod work with version 2.0.21 ?
Keith Jordan
Neptune Pink Floyd
Fyrmn472
Registered User
Posts: 40
Joined: Sun Jun 15, 2003 3:58 pm
Location: Auburn, WA
Contact:

Post by Fyrmn472 »

Using v2.0.19

Code: Select all

Warning: main(../includes/functions_search.php): failed to open stream: No such file or directory in /home/addicted/public_html/modules/Forums/admin/admin_prune_user_posts.php on line 78

Warning: main(../includes/functions_search.php): failed to open stream: No such file or directory in /home/addicted/public_html/modules/Forums/admin/admin_prune_user_posts.php on line 78

Warning: main(): Failed opening '../includes/functions_search.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/addicted/public_html/modules/Forums/admin/admin_prune_user_posts.php on line 78

Fatal error: Call to undefined function: remove_search_post() in /home/addicted/public_html/modules/Forums/admin/admin_prune_user_posts.php on line 970
Image
kjnpf
Registered User
Posts: 104
Joined: Tue Apr 29, 2003 9:27 am
Location: Cheshire, England
Contact:

Post by kjnpf »

Did you upload the files to the correct folders?
Keith Jordan
Neptune Pink Floyd
Fyrmn472
Registered User
Posts: 40
Joined: Sun Jun 15, 2003 3:58 pm
Location: Auburn, WA
Contact:

Post by Fyrmn472 »

kjnpf wrote: Did you upload the files to the correct folders?

My phpbb is in my nuke-evolution so the path may be different. I see the Prune Posts option under "User Admin". When I open the page, I see this at the top:

Code: Select all

Warning: main(../includes/functions_search.php): failed to open stream: No such file or directory in /home/addicted/public_html/modules/Forums/admin/admin_prune_user_posts.php on line 78

Warning: main(../includes/functions_search.php): failed to open stream: No such file or directory in /home/addicted/public_html/modules/Forums/admin/admin_prune_user_posts.php on line 78

Warning: main(): Failed opening '../includes/functions_search.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/addicted/public_html/modules/Forums/admin/admin_prune_user_posts.php on line 78
Line 78:

Code: Select all

include($phpbb_root_path . 'includes/functions_search.'.$phpEx);
My forum is: /home/addicted/public_html/modules/Forums
My functions_search.php is: /home/addicted/public_html/includes/function_search.php

Can I edit line 78 to poin to the correct functions_search.php?
Image
Fyrmn472
Registered User
Posts: 40
Joined: Sun Jun 15, 2003 3:58 pm
Location: Auburn, WA
Contact:

Post by Fyrmn472 »

I got some help from someone at nuke-evolution. I changed line 78 to:

Code: Select all

include('../../../includes/functions_search.'.$phpEx); 
Now the mod works great! Hopefully this helps someone in the future...
Image
e-mo
Registered User
Posts: 90
Joined: Tue Oct 01, 2002 2:54 pm

Post by e-mo »

Hi there...

how is the feedback for that?! should it be changed as advised?

e-mo
dcz wrote:
Coagulant wrote:In admin/admin_prune_user_posts.php
// Mark posts in topic for deletion (if there are other posts in this thread)
if($posts[$i]['topic_last_post_id'] != $posts[$i]['topic_last_post_id'])

Looks like a bug to me, should be
// Mark posts in topic for deletion (if there are other posts in this thread)
if($posts[$i]['topic_first_post_id'] != $posts[$i]['topic_last_post_id'])



This maybe ?
...with great power...comes great responsibilities...

Looking help for this Mod Problem: http://www.phpbb.com/community/viewtopi ... &start=165
Post Reply

Return to “[2.0.x] MOD Database Cleanup”