[2.0.16] Abnormal posts widening fix

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
25
63%
Very Good
3
8%
Good
3
8%
Fair
2
5%
Poor
7
18%
 
Total votes: 40

User avatar
-=ET=-
Registered User
Posts: 799
Joined: Sun May 25, 2003 5:32 pm

Post by -=ET=- »

MaddoxX wrote: Does this work for the attachment mod ?

Yes it is :wink:
Eternal newbie
BondGamer
Registered User
Posts: 436
Joined: Mon Dec 15, 2003 7:49 pm
Contact:

Post by BondGamer »

I just installed this mod the other day, and it fixed the width problem for pictures. But it also caused the Edit, Quote, IP, Etc. buttons to become "unstuck" from the right side of the post (in every thread). I added some widths to the table data to make sure it would be as far right as possible. It works perfectly for me. You can see exactly what I did below:

Code: Select all

<td>
				<table width="100%" border="0" cellspacing="0" cellpadding="0">
				<tr>
				<td width="95%">
					<a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" border="0" /></a>
					<span class="postdetails">{L_POSTED}: {postrow.POST_DATE}<span class="gen">&nbsp;</span>&nbsp; &nbsp;{L_POST_SUBJECT}: {postrow.POST_SUBJECT}</span>
				</td>
				<td valign="top" nowrap="nowrap" aligh="right" width="5%">
					{postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} {postrow.IP_IMG}
				</td>
				</tr>
				</table>
			</td>
If anyone else has this problem they might want to try this.
User avatar
-=ET=-
Registered User
Posts: 799
Joined: Sun May 25, 2003 5:32 pm

Post by -=ET=- »

BondGamer wrote: If anyone else has this problem they might want to try this.

Use the last release (DL in my sig) :wink:
The one validated on phpBB.com is too old.
Eternal newbie
User avatar
-=ET=-
Registered User
Posts: 799
Joined: Sun May 25, 2003 5:32 pm

Post by -=ET=- »

The last release of this MOD (1.0.3) is phpBB 2.0.10 compliant! :D

Note: I'll ask the phpBB MOD team to ensure that the last release this MOD is in the MOD queue for validation. If not, it's an oversight and I'll submit it soon.
Eternal newbie
mattbugz
Registered User
Posts: 97
Joined: Wed Jun 30, 2004 2:24 pm

Does this work for HTML Table tags

Post by mattbugz »

I have a need to support HTML tables in my forums. I was wondering if this would also solve the abnormal table sizes that HTML table tags introduce?

Thanks!
--
Regards,
Matt
SAJcreations
Registered User
Posts: 10
Joined: Thu Jun 03, 2004 4:34 am

Post by SAJcreations »

I've installed the mod and it works great with text -- but I'm still having a problem with graphics. Some of the graphics we use make it abnormally wide, even when the graphic doesn't require it.

Is there a way to fix that?
User avatar
-=ET=-
Registered User
Posts: 799
Joined: Sun May 25, 2003 5:32 pm

Post by -=ET=- »

mattbugz wrote: I have a need to support HTML tables in my forums. I was wondering if this would also solve the abnormal table sizes that HTML table tags introduce?

I don't know I've never installed such a feature :(
SAJcreations wrote: I've installed the mod and it works great with text -- but I'm still having a problem with graphics. Some of the graphics we use make it abnormally wide, even when the graphic doesn't require it.

This MOD has no effect on text!
For pictures, have you a link to see the issue?
Eternal newbie
kalten
Registered User
Posts: 32
Joined: Wed Nov 19, 2003 4:14 pm

Post by kalten »

-=ET=- wrote: The last release of this MOD (1.0.3) is phpBB 2.0.10 compliant! :D

Note: I'll ask the phpBB MOD team to ensure that the last release this MOD is in the MOD queue for validation. If not, it's an oversight and I'll submit it soon.


Is MOD (1.0.3) out yet? I only see 1.0.2 linked on the first page.
PeterPaul
Registered User
Posts: 29
Joined: Thu Aug 12, 2004 3:52 pm
Location: Malaysia
Contact:

it doesn't work

Post by PeterPaul »

I'm running template beats 101.

have installed abnormal_posts_widening_fix_1.0.3em

But I get no result at all, oversized pics are still widening my forum. How to resolve please?

Here my viewtopic_body.tpl

Code: Select all

<table width="100%" cellspacing="2" cellpadding="2" border="0">
  <tr> 
	<td align="left" valign="bottom" colspan="2"><a class="maintitle" href="{U_VIEW_TOPIC}">{TOPIC_TITLE}</a><br />
	  <!-- Start add - Topic in Who is online MOD -->
	  <span class="gensmall"><b><br/>{TOTAL_USERS_ONLINE}<br/>{LOGGED_IN_USER_LIST}</b></span></td>
<!-- End add - Topic in Who is online MOD -->
	  <!-- Start replacement - Topic in Who is online MOD -->
	  	<td align="right" valign="bottom" nowrap="nowrap"><span class="gensmall"><b>{PAGINATION}</b></span></td>
	  </tr>
<!-- End replacement - Topic in Who is online MOD -->
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0">
  <tr> 
	<td align="left" valign="bottom" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" style="filter:alpha(opacity=65)" onMouseOver="this.filters.alpha.opacity=100" onMouseOut="this.filters.alpha.opacity=65" /></a>   <a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" style="filter:alpha(opacity=65)" onMouseOver="this.filters.alpha.opacity=100" onMouseOut="this.filters.alpha.opacity=65" /></a></span></td>
	<td align="left" valign="middle" width="100%"><span class="nav">   <a href="{U_INDEX}" class="nav">{L_INDEX}</a> 
	  -> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td>
  </tr>
</table>
<table width="100%" cellspacing="0" cellpadding="0" border="0" align="center"> 
			<tr>
		<td valign="middle" background="templates/beats101/images/cellpic3.gif" width="100%" height="20"></a></td>
	</tr>

<table class="forumline" width="100%" cellspacing="1" cellpadding="3" border="0">
	<tr align="right">
		<td class="catHead" colspan="2" height="28"><span class="nav"><a href="{U_VIEW_OLDER_TOPIC}" class="nav">{L_VIEW_PREVIOUS_TOPIC}</a> :: <a href="{U_VIEW_NEWER_TOPIC}" class="nav">{L_VIEW_NEXT_TOPIC}</a>  </span></td>
	</tr>
	{POLL_DISPLAY} 
	<tr>
		<th class="thLeft" width="150" height="26" nowrap="nowrap">{L_AUTHOR}</th>
		<th class="thRight" nowrap="nowrap">{L_MESSAGE}</th>
	</tr>
	<!-- BEGIN postrow -->
	<tr> 
		<td width="150" align="left" valign="top" class="{postrow.ROW_CLASS}"><span class="name"><a name="{postrow.U_POST_ID}"></a><b>{postrow.POSTER_NAME}</b></span><br /><span class="postdetails">{postrow.POSTER_RANK}<br />{postrow.RANK_IMAGE}{postrow.POSTER_AVATAR}<br /><br />{postrow.POSTER_JOINED}<br />{postrow.POSTER_POSTS}<br /><span class="postdetails">{L_JOBS}: {postrow.JOBS}<br />{postrow.POSTER_KARMA} <a href="{postrow.U_APPLAUD}">{postrow.APPLAUD_IMG}</a><a href="{postrow.U_SMITE}">{postrow.SMITE_IMG}</a><br />{postrow.POSTER_FROM}{postrow.POSTER_VAULT}<br />{postrow.CASH}<br /><a href="{postrow.ITEMSNAME}">Items</a>{postrow.ITEMS}</span><br /></td>
		<td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0">
			<tr>
				<td width="100%"><td><table width="100%" border="0" cellspacing="0" cellpadding="0"><tr><a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" border="0" /></a><span class="postdetails">{L_POSTED}: {postrow.POST_DATE}<span class="gen"> </span>   {L_POST_SUBJECT}: {postrow.POST_SUBJECT}</span></td>
				<td valign="top" nowrap="nowrap">{postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} {postrow.IP_IMG}</td></tr></table></td>
			</tr>
			<tr> 
				<td colspan="2"><hr /></td>
			</tr>
			<tr>
				<td colspan="2"><span class="postbody">{postrow.MESSAGE}</span>{postrow.ATTACHMENTS}<span class="postbody">{postrow.SIGNATURE}</span><span class="gensmall">{postrow.EDITED_MESSAGE}</span></td>
			</tr>
		</table></td>
	</tr>
	<tr> 
		<td class="{postrow.ROW_CLASS}" width="150" align="left" valign="middle"><span class="nav"><a href="#top" class="nav">{L_BACK_TO_TOP}</a></span></td>
		<td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="bottom" nowrap="nowrap"><table cellspacing="0" cellpadding="0" border="0" height="18" width="18">
			<tr> 
				<td valign="middle" nowrap="nowrap">{postrow.PROFILE_IMG} {postrow.BUDDY_IMG} {postrow.PM_IMG} {postrow.EMAIL_IMG} {postrow.WWW_IMG} {postrow.AIM_IMG} {postrow.YIM_IMG} {postrow.MSN_IMG}<script language="JavaScript" type="text/javascript"><!-- 

	if ( navigator.userAgent.toLowerCase().indexOf('mozilla') != -1 && navigator.userAgent.indexOf('5.') == -1 && navigator.userAgent.indexOf('6.') == -1 )
		document.write(' {postrow.ICQ_IMG}');
	else
		document.write('</td><td>&nbsp;</td><td valign="top" nowrap="nowrap"><div style="position:relative"><div style="position:absolute">{postrow.ICQ_IMG}</div><div style="position:absolute;left:3px;top:-1px">{postrow.ICQ_STATUS_IMG}</div></div>');
				
				//--></script><noscript>{postrow.ICQ_IMG}</noscript></td>
			</tr>
		</table></td>
	</tr>
	<tr> 
		<td valign="middle" colspan="2" background="templates/beats101/images/cellpic4.gif" width="100%" height="20"></a></td>
	</tr>
	<!-- END postrow -->
	<tr align="center"> 
		<td class="catBottom" colspan="2" height="28"><table cellspacing="0" cellpadding="0" border="0">
			<tr><form method="post" action="{S_POST_DAYS_ACTION}">
				<td align="center"><span class="gensmall">{L_DISPLAY_POSTS}: {S_SELECT_POST_DAYS} {S_SELECT_POST_ORDER} <input type="submit" value="{L_GO}" class="liteoption" name="submit" /></span></td>
			</form></tr>
		</table></td>
	</tr>
</table>
<table width="100%" cellspacing="0" cellpadding="0" border="0" align="center"> 
			<tr>
		<td valign="middle" colspan="2" background="templates/beats101/images/cellpic4.gif" width="100%" height="20"></a></td>
	</tr>

<table width="100%" cellspacing="2" cellpadding="2" border="0" align="center">
  <tr> 
	<td align="left" valign="middle" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" style="filter:alpha(opacity=65)" onMouseOver="this.filters.alpha.opacity=100" onMouseOut="this.filters.alpha.opacity=65" /></a>   <a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" style="filter:alpha(opacity=65)" onMouseOver="this.filters.alpha.opacity=100" onMouseOut="this.filters.alpha.opacity=65" /></a></span></td>
	<td align="left" valign="middle" width="100%"><span class="nav">   <a href="{U_INDEX}" class="nav">{L_INDEX}</a> 
	  -> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td>
	<td align="right" valign="top" nowrap="nowrap"><span class="gensmall">{S_TIMEZONE}</span><br /><span class="nav">{PAGINATION}</span> 
	  </td>
  </tr>
  <tr>
	<td align="left" colspan="3"><span class="nav">{PAGE_NUMBER}</span></td>
  </tr>
</table>

<table width="100%" cellspacing="2" border="0" align="center">
  <tr> 
	<td width="40%" valign="top" nowrap="nowrap" align="left"><span class="gensmall">{S_WATCH_TOPIC}</span><br />
	   <br />
	  {S_TOPIC_ADMIN}{QUICK_REPLY_FORM}</td>
	<td align="right" valign="top" nowrap="nowrap">{JUMPBOX}<span class="gensmall">{S_AUTH_LIST}</span></td>
  </tr>
</table>
lkl
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

kalten wrote:
-=ET=- wrote:The last release of this MOD (1.0.3) is phpBB 2.0.10 compliant! :D

Note: I'll ask the phpBB MOD team to ensure that the last release this MOD is in the MOD queue for validation. If not, it's an oversight and I'll submit it soon.


Is MOD (1.0.3) out yet? I only see 1.0.2 linked on the first page.

http://www.golfexpert.net/phpbb/ down load it there
Whos missing up my sig?
mobo49
Registered User
Posts: 24
Joined: Fri May 28, 2004 12:28 am
Location: Drowning in syntax
Contact:

Post by mobo49 »

-=ET=- wrote: Nothing.

Once again it's not this fix concern!
Other MODs exist to resize images, cut urls, limit the table width or anything you may want to do for your style design.

But this MOD is only a fix for the abnormal empty space created between the right border of large images and the right border of the post table by the original code of the subSilver template.



Do you happen to have a link to the mod to cut urls in the event they run on and extend paged beyond thier norm ?????
User avatar
Khurram
Registered User
Posts: 60
Joined: Sat Dec 11, 2004 2:09 pm
Contact:

Post by Khurram »

anyone tried this with 2.0.11 ?
mattbugz
Registered User
Posts: 97
Joined: Wed Jun 30, 2004 2:24 pm

Post by mattbugz »

Khurram wrote: anyone tried this with 2.0.11 ?


Yes, it works. (On an upgraded phpBB from 2.0.8 anyway)
--
Regards,
Matt
User avatar
Khurram
Registered User
Posts: 60
Joined: Sat Dec 11, 2004 2:09 pm
Contact:

Post by Khurram »

yeps.. after reading and installing this mod, since its just the modification of html coding.. so the 1.0.3em version of this mod works perfectly fine on phpBB 2.0.13 as well (with attachment mod, merge threads mod, and several others mods installed on the board).

thanks for this.. Great mod !
MuddHarryS
Registered User
Posts: 40
Joined: Sat Jun 07, 2003 2:37 pm

Post by MuddHarryS »

I have always wondered why the devlopers never addressed the widening problem making these changes in the original code it has been an issue since I started using the board.

I'll have to try this mod and see if I get better results than the others I tried in the past that only provided a fix some of the time.

- Jim
Post Reply

Return to “[2.0.x] MOD Database Cleanup”