[2.0.7] Announces Suite

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
37
44%
Very Good
22
26%
Good
9
11%
Fair
4
5%
Poor
12
14%
 
Total votes: 84

Aliniuz
Registered User
Posts: 310
Joined: Fri Jun 23, 2006 6:12 am
Contact:

Post by Aliniuz » Sat Feb 17, 2007 3:06 pm

Ptirhiik wrote: Topic not read !

I readed the whole topic and i didn't found a solve at my problem !
Galati - The Galati City Board

User avatar
Jadestone
Registered User
Posts: 630
Joined: Tue May 24, 2005 12:54 am
Location: Juno Beach, FL
Contact:

Post by Jadestone » Mon Feb 19, 2007 8:47 pm

well i am redoing my boards and i had this same problem last time i installed this mod, i fixed it before but i cant remember what it was.

the problem im having is that when i submit a new topic or edit a topic it wont input the global announcement into the table. it submits it as a normal post.

the sticky and announcement works fine, just not the global announcement. When i go to the database and change it to a 3 in the topic type it works fine, so the probelm is in the submit area...

i looked and i cant seem to find the error anywhere.... any ideas?

nevermind i fixed it again.
this was the problem

Code: Select all

#
#-----[ OPEN ]------------------------------------------------
#
posting.php
#
#-----[ FIND ]------------------------------------------
#
$topic_type = ( in_array($topic_type, array(POST_NORMAL, POST_STICKY, POST_ANNOUNCE, )) ) ? $topic_type : POST_NORMAL;
#
#-----[ REPLACE WITH ]------------------------------------------
# 
$topic_type = ( in_array($topic_type, array(POST_NORMAL, POST_STICKY, POST_ANNOUNCE, POST_GLOBAL_ANNOUNCE)) ) ? $topic_type : POST_NORMAL;
# 
#-----[ SAVE/CLOSE ALL FILES ]------------------------------------------ 
# 
# EoM 
not sure if anyone else had this problem but just in case.
My Mods In Development: MPS Mod

MPS Support Site: Click Here

User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Post by Renodil » Thu Feb 22, 2007 4:29 am

Does it do it like the guy at this board? http://rpgnet.clanmckeen.com/demo/

phatchopolis
Registered User
Posts: 166
Joined: Mon May 29, 2006 11:40 pm

Post by phatchopolis » Sat Feb 24, 2007 1:23 am

I see on the first page a fix for phpBB 2.0.18. If I apply that fix into this mod will it be compatible with 2.0.22? Thanks.

phatchopolis
Registered User
Posts: 166
Joined: Mon May 29, 2006 11:40 pm

Post by phatchopolis » Mon Mar 05, 2007 2:19 pm

Have applied all changes and get this when loading my forum. Any ideas?

Fatal error: Cannot redeclare load_bbcode_template() (previously declared in /home/phatchop/public_html/forum/includes/bbcode.php:45) in /home/phatchop/public_html/forum/includes/bbcode.php on line 43

danb00
Registered User
Posts: 1025
Joined: Sun Dec 15, 2002 9:41 pm
Location: Inside Mod:Extreme PHPBB
Contact:

Post by danb00 » Sat Mar 10, 2007 1:48 pm

i have this annoying issue.
it's with the config new setting in the ACP
For a start the link is set to Configuration extend
looks like its missing some lang

The when inside i see a setting say:
Display announcement dates
with
Yes No
--------------------------------------------------------------------------------
: Yes No

I have all files uplaoded in the correct areas but i dont see any lang enterys in there
phpBBModded.com - Modding phpBB

User avatar
Shaythong
Registered User
Posts: 48
Joined: Sun May 22, 2005 1:57 am

Post by Shaythong » Sat Mar 10, 2007 8:43 pm

Dan, it's Shaythong.

It works for my site. I used Easymod, then uninstalled, then tried Manually by hand, still works. :wink:

seasoning
Registered User
Posts: 4
Joined: Thu May 17, 2007 9:24 am

Re: [2.0.7] Announces Suite

Post by seasoning » Thu May 17, 2007 11:08 am

how can i fix this error??

Code: Select all

Error:
Unexpected or unknown attribute "AFTER AUTH_ANNOUNCE", in "auth_global_announce TINYINT(1) NOT NULL AFTER auth_announce", statement: 2, table: "phpbb_auth_access"

SQL:
ALTER TABLE phpbb_auth_access ADD auth_global_announce TINYINT(1) NOT NULL AFTER auth_announ

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [2.0.7] Announces Suite

Post by lefty74 » Sat May 19, 2007 9:39 am

seasoning wrote:how can i fix this error??

Code: Select all

Error:
Unexpected or unknown attribute "AFTER AUTH_ANNOUNCE", in "auth_global_announce TINYINT(1) NOT NULL AFTER auth_announce", statement: 2, table: "phpbb_auth_access"

SQL:
ALTER TABLE phpbb_auth_access ADD auth_global_announce TINYINT(1) NOT NULL AFTER auth_announ
try this

Code: Select all

ALTER TABLE phpbb_auth_access ADD auth_global_announce TINYINT(1) NOT NULL;
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

User avatar
eym0
Registered User
Posts: 4
Joined: Mon May 21, 2007 12:11 am
Location: Germany, Dresden

Re: [2.0.7] Announces Suite

Post by eym0 » Mon May 21, 2007 7:08 am

I have spent 5h :( installing this mod and debugging my install^^ @ great thx to Ptirhiik for creating this mod!!! If u as a user, like I did, have problems installing it - it is probably due to some error in reading the Install-Scripts^^ that is often teadious if u work like me 2 a clock in the morning on the install... ---> these errors which eventually show up in so many posts above this one are a results of comments beeing posted in a variable declaration! Here i have to point out the good programming style Ptirhiik follows here!! :!: *thumbs up* to comment all changes like that makes debugging really easy and this documentation inside the code is awesome :o !
Here is the problem as not everybody is comfortable with the INSTALL commands (that the next ADD AFTER means outside the previous FIND INLINE) it is a good idea for most users to just leave away all the commands! I had several occasions where i thought the line to be over but i did the following mistake:

Code: Select all

#
#-----[ IN-LINE FIND ]---------------------------------------- 
#
		AND t.topic_type <> " . POST_ANNOUNCE . "
#
#-----[ IN-LINE AFTER, ADD ]---------------------------------- 
#
 AND t.topic_type <> " . POST_GLOBAL_ANNOUNCE . "
#
#-----[ AFTER, ADD ]------------------------------------------
#
//-- fin mod : announces ---------------------------------------------------------------------------
I did that while i posted the //-- fin mod : announces --------------------------------------------------------------------------- inside the $sql declaration which ended up in an error... so post after the ;!!
My recommandation for beginners:
Where it says:

Code: Select all

#-----[ AFTER, ADD ]------------------------------------------
#
//-- fin mod : announces ---------------------------------------------------------------------------
#
Skip this step u could also skip more but then u would need to differentiate between comments only and mixed code - which makes everything more complicated!
[/color]
I know this is bad style but it solves most of the problems which are posted here - and gets rid of the long proof-read period in the end^^
**********************************************
Important even for the latest release and not just for 2.0.18 like indicated on the first page:
Ptirhiik wrote:Important notice for phpBB 2.0.18 users

Code: Select all

#
#---[ OPEN ]--------------
#
posting.php
#
#---[ FIND ]------------------
#
$topic_type = ( in_array($topic_type, array(POST_NORMAL, POST_STICKY, POST_ANNOUNCE)) ) ? $topic_type : POST_NORMAL;
#
#---[ REPLACE WITH ]-----------------
#
//--- mod : Announces suite ----------------------------
//-- delete
/*
$topic_type = ( in_array($topic_type, array(POST_NORMAL, POST_STICKY, POST_ANNOUNCE)) ) ? $topic_type : POST_NORMAL;
*/
//-- add
$topic_type = ( in_array($topic_type, array(POST_NORMAL, POST_STICKY, POST_ANNOUNCE, POST_GLOBAL_ANNOUNCE)) ) ? $topic_type : POST_NORMAL;
//--- fin mod : Announces suite ------------------------
Also important and hidden on page 9 (thx to vinzphua :!:):
vinzphua wrote:I noticed the mod missed out something. It does not set the default permissions for global announce properly when you create a new forum.

If you want to correct this, open admin/admin_forums.php, and look for $forum_auth_ary near the top of the file and then alter as below. Note:
- Do at your own risk.
- Remember to back up your files.
- I did this on phpBB2 2.0.6.
- This part is not validated by the phpBB team.

Code: Select all

$forum_auth_ary = array(
	"auth_view" => AUTH_ALL,
	"auth_read" => AUTH_ALL,
	"auth_post" => AUTH_ALL,
	"auth_reply" => AUTH_ALL,
	"auth_edit" => AUTH_REG,
	"auth_delete" => AUTH_REG,
	"auth_sticky" => AUTH_MOD,
//-- mod : announces (fix) -------------------------------------------------------------------------------
//-- add
	"auth_global_announce" => AUTH_ADMIN,
//-- fin mod : announces (fix) -------------------------------------------------------------------------------
	"auth_announce" => AUTH_MOD,
	"auth_vote" => AUTH_REG,
	"auth_pollcreate" => AUTH_REG
);
One additionnal cool thing i spotted on the pages before:
01satkins wrote: how to stop normal announcements showing up in the global announcement box on teh index page:

Code: Select all

#
#---[ OPEN ]--------------
#
includes/functions_announces.php
#
#---[ FIND ]------------------
#
find:
   if (!empty($tree_forum_ids))
   {
      $sql_where .=
#
#---[ REPLACE WITH ]-----------------
#
   if (!empty($tree_forum_ids))
   {
   //   $sql_where .= 
//--- fin mod : Announces suite ------------------------ 
Fixing Style and columns of announce display (Customizing)
The most of u guys complained about the wrong style of the global announcement and the unnecessary columns in the end:
here a screenie of what I did:
Image

for that you have to open your viewforum_body.tpl of your installed skin and copy the following equivalent to a editor:

Code: Select all

<!-- selfEdit -->
  <span class="forumline">
  {BOARD_ANNOUNCES}
  </span>
  <!-- fin selfdit -->
  <table border="0" cellpadding="4" cellspacing="1" width="100%" class="forumline">
	<tr>
	  <th colspan="2" align="center" height="25" class="thCornerL" nowrap="nowrap">&nbsp;{L_TOPICS}&nbsp;</th>
	  <th width="50" align="center" class="thTop" nowrap="nowrap">&nbsp;{L_REPLIES}&nbsp;</th>
	  <th width="100" align="center" class="thTop" nowrap="nowrap">&nbsp;{L_AUTHOR}&nbsp;</th>
	  <th width="50" align="center" class="thTop" nowrap="nowrap">&nbsp;{L_VIEWS}&nbsp;</th>
	  <th align="center" class="thCornerR" nowrap="nowrap">&nbsp;{L_LASTPOST}&nbsp;</th>
	</tr>
	<!-- BEGIN topicrow -->
	<tr>
I added a span arround the {BOARD_ANNOUNCES} which may not be necessary but the next alteration is important:

open topics_list_box.tpl:
the following codes show the final code---> as u can see i commented some of the HTML code to not display certain columns: &&&& also i added some height values and class declarations to recieve the final design (to fit into the nice theme from spleen --> xand)

Code: Select all

<table border="0" cellpadding="4" cellspacing="1" width="100%" class="forumline">
<tr>
	<th colspan="{topics_list_box.row.header_table.COLSPAN}" align="center" height="25" class="thCornerL" nowrap="nowrap">&nbsp;{topics_list_box.row.L_TITLE}&nbsp;</th>
         <!--
         <th width="50" align="center" nowrap="nowrap">&nbsp;{topics_list_box.row.L_REPLIES}&nbsp;</th>
         -->
	<th width="100" align="center" height="25" class="thTop" nowrap="nowrap">&nbsp;{topics_list_box.row.L_AUTHOR}&nbsp;</th>
         <!--
	<th width="50" align="center" nowrap="nowrap">&nbsp;{topics_list_box.row.L_VIEWS}&nbsp;</th>
	<th width="150" align="center" nowrap="nowrap">&nbsp;{topics_list_box.row.L_LASTPOST}&nbsp;</th>
         -->
	<!-- BEGIN multi_selection -->
	<th width="20" align="center" nowrap="nowrap"><input type="checkbox" name="all_mark_{topics_list_box.row.header_table.BOX_ID}" value="0" onClick="check_uncheck_all_{topics_list_box.row.header_table.BOX_ID}();" /></th>
	<!-- END multi_selection -->
</tr>
here the same:

Code: Select all

			{topics_list_box.row.TOPIC_NAV_TREE}
			<!-- END nav_tree -->
		</span>
	</td>
         <!--
	<td class="row2" align="center" valign="middle"><span class="postdetails">{topics_list_box.row.REPLIES}</span></td>
         -->
	<td class="row3" align="center" valign="middle"><span class="name">{topics_list_box.row.TOPIC_AUTHOR}</span></td>
         <!--
	<td class="row2" align="center" valign="middle"><span class="postdetails">{topics_list_box.row.VIEWS}</span></td>
	<td class="row3" align="center" valign="middle" nowrap="nowrap"><span class="postdetails">{topics_list_box.row.LAST_POST_TIME}<br />{topics_list_box.row.LAST_POST_AUTHOR} {topics_list_box.row.LAST_POST_IMG}</span></td>
         -->
	<!-- BEGIN multi_selection -->
	<td class="row2"
Ex of "outcommenting":

Code: Select all

         <!--
	<td class="row2" align="center" valign="middle"><span class="postdetails">{topics_list_box.row.REPLIES}</span></td>
         -->
Ex of fixing style

Code: Select all

<th width="100" align="center" height="25" class="thTop" nowrap="nowrap">
where the height="25" class="thTop" was added like seen/deduced from the code copied from the file viewforum_body.tpl


I hope with this huge post i combined the best from the last 30 pages ;) and made it easier for u guys to use that great MOD... :geek:
cheers eym0


btw this was done with phpBB 2.0.22 ^^
"Playfully doing something difficult, whether useful or not, that is hacking." [rms]

User avatar
phorum.ws
Registered User
Posts: 108
Joined: Fri Jul 20, 2007 1:00 pm
Location: Australia
Name: Jay
Contact:

Re: [2.0.7] Announces Suite

Post by phorum.ws » Wed Aug 01, 2007 1:30 am

I have decided to remove this mod, as there is no support for one, and it does not work on my forum, I have Easy Sub-Forums installed, and Report Posts 1.2.3c and Card Hack, all latest as forum has only been up for 1 week and is latest phpBB2.

It does install and no errors but here are the problems i am getting:

It will only list the first ever Global Announcement I post
it does NOT list them in forums that DO NOT have the Easy Sub-Forums MOD installed.
It dispays fine in all forums with Easy Sub-Forums MOD - perfectly, but i cannot create any new Global Announcements, it does actual make them, but they are not displayed, they are only dosplayed as normal topics in the forum which they where made in....

if anyone has this same problem, please let me know (with the same hacks installed) or if there is any support guys - i will pay to get this fixed!

I WILL PAY TO FIX THIS - to anyone who knows PHP, i am familiar, but cant troubleshoot much at all, i need a pro.

Everything is installed correctly, have check and checked and triple checked. uploaded and re-uploaded.

Thanks All, please hurry, as i am getting ready to remove this within a few days!
Learning CSS, jQuery, Javascript - A Project Manager @Code_Collective Community-Based Dev Collaborative

User avatar
xmenfile
Registered User
Posts: 163
Joined: Sun Apr 22, 2007 10:32 pm

Re: [2.0.7] Announces Suite

Post by xmenfile » Wed Aug 01, 2007 6:33 pm

Hi there,

can anyone help me? I installed Part 1, 2 and 3 (I dont have Categories hierarchy v 2.0.4 or greater or Split Topic v 2.0.0 or greater installed) and now my ACP left side is black. Do I miss anything?

User avatar
xmenfile
Registered User
Posts: 163
Joined: Sun Apr 22, 2007 10:32 pm

Re: [2.0.7] Announces Suite

Post by xmenfile » Wed Aug 01, 2007 10:50 pm

Never mind. I solved the ACP, but I have other error.
What is the different between Announcement and Global Announcement? showhow when I choose Global Announcement, it does not show on Index or Forum. but if I choose Announcement, it shows on Index and other Forums except the original forum that I create the announcement. Also the original forum split into 2 announcements. I hope I don't confuse you.

like this right next to each other:
Announcement: dasf asfsdf
Announcement: dasf asfsdf

Here is my ACP set up:
Display announcement dates Yes No
Display board announcements on index Yes No
Display board announcements on forums Yes No
Split announcement type in the board announcement box Yes No
Display the forum name under the announcement title in the board announcement box Yes No
Announcement duration
This is the number of days an announcement remains. Use -1 in order to set it permanent
Announcement prune strategy
This is what will be the type of the announcement topic after being pruned NormalSticky

User avatar
eym0
Registered User
Posts: 4
Joined: Mon May 21, 2007 12:11 am
Location: Germany, Dresden

Re: [2.0.7] Announces Suite

Post by eym0 » Fri Aug 03, 2007 6:16 pm

vinzphua wrote:I noticed the mod missed out something. It does not set the default permissions for global announce properly when you create a new forum.

If you want to correct this, open admin/admin_forums.php, and look for $forum_auth_ary near the top of the file and then alter as below. Note:
- Do at your own risk.
- Remember to back up your files.
- I did this on phpBB2 2.0.6.
- This part is not validated by the phpBB team.

Code: Select all
$forum_auth_ary = array(
"auth_view" => AUTH_ALL,
"auth_read" => AUTH_ALL,
"auth_post" => AUTH_ALL,
"auth_reply" => AUTH_ALL,
"auth_edit" => AUTH_REG,
"auth_delete" => AUTH_REG,
"auth_sticky" => AUTH_MOD,
//-- mod : announces (fix) -------------------------------------------------------------------------------
//-- add
"auth_global_announce" => AUTH_ADMIN,
//-- fin mod : announces (fix) -------------------------------------------------------------------------------
"auth_announce" => AUTH_MOD,
"auth_vote" => AUTH_REG,
"auth_pollcreate" => AUTH_REG
);


@xmenfile: think that is the sol to ur prob - just read my big post carefully it should lead to an succ install! :geek: :geek: (i think i had kind of the same prob
"Playfully doing something difficult, whether useful or not, that is hacking." [rms]

Sheldon469
Registered User
Posts: 128
Joined: Wed Jan 28, 2004 2:32 am
Location: USA
Contact:

Re: [2.0.7] Announces Suite

Post by Sheldon469 » Tue Aug 07, 2007 3:06 am

So is this the lates version of this mod for download?

I would like to add this to my board. Thanks.
Alpine Talk For the Alpine Enthaustist in you!

Post Reply

Return to “[2.0.x] MOD Database Cleanup”

Who is online

Users browsing this forum: No registered users and 5 guests