Page 1 of 2

[2.0.6] Page ID Extension

Posted: Wed Nov 26, 2003 11:34 am
by Extensions Robot
MOD Name: Page ID Extension
Author: Graham
MOD Description: Provides a simple means for MOD Authors to add new page ID's for use in their MODs to provide more accurate session tracking without the need for each MOD to alter constants.php, viewonline.php and admin/index.php

MOD Version: 1.0.0


Download File: Page_ID_Extension_1.0.0.zip
mods overview page: View
File Size: 6997 Bytes

Support for this MOD needs to be asked within this topic. The phpBB Teams are not responsible or required to give anyone support for this MOD. By installing this MOD, the phpBB Support Team or phpBB MODifications Team may not be able to provide support.

This MOD has only been tested by the phpBB MOD Team with the phpBB version in the topic title. It may not work in any other versions of phpBB.

Posted: Fri Nov 28, 2003 10:22 pm
by wGEric
MOD Validated/Released

Posted: Fri Nov 28, 2003 10:41 pm
by ElizabeththeGrey
but doesn't each potential user have to have this mod installed for a MOD author to use the system?

Posted: Fri Nov 28, 2003 11:33 pm
by morpheus2matrix
ElizabeththeGrey wrote: but doesn't each potential user have to have this mod installed for a MOD author to use the system?


i don' t understand what you want to say :roll:

Posted: Sat Nov 29, 2003 1:00 am
by drumstix42
Well, to just answer her:

You would just put in your notes 'This MOD requires this MOD'

Basically like the whole BBCode thing.

In the long run it helps out :)

Posted: Sat Nov 29, 2003 4:36 pm
by Graham
Thanks to the MOD Team for validating this one.

As for the other point, yes you would need to have it installed in order to use it from within a MOD. However, I'm not sure at the moment if MODs with dependencies are being accepted into the MOD DB or not, hence the classification as a MOD Development Tool. But if you wanted to do it like the BBCode one, then yes you could put that requirement in the notes I guess.

I cannot install the file

Posted: Sun Dec 28, 2003 8:04 pm
by chunhung
It said I don't have .net framwork or things like that.

I am using Win XP

Re: I cannot install the file

Posted: Mon Dec 29, 2003 5:47 pm
by wGEric
chunhung wrote: It said I don't have .net framwork or things like that.

I am using Win XP


What?

Posted: Wed Apr 07, 2004 2:37 am
by Merri
So... is this somewhat done in phpBB 2.2, thus providing easier MOD porting from phpBB 2.0.x, or is this just one of those things to forget? Looks like there is no huge interest on even pushing people to use this MOD. My MOD at the moment edits only the three files plus one another (can't remember which one it was), other than that it is individual, yet able to integrate well.

Posted: Fri Jul 30, 2004 7:05 am
by markus_petrux
Hi, Graham!

Really wise MOD, IMO. ;)
Graham wrote: As for the other point, yes you would need to have it installed in order to use it from within a MOD. However, I'm not sure at the moment if MODs with dependencies are being accepted into the MOD DB or not, hence the classification as a MOD Development Tool. But if you wanted to do it like the BBCode one, then yes you could put that requirement in the notes I guess.
Page_ID_Extension_1.0.0.zip->readme.html wrote: What values can I use for the ID value?

The phpBB MOD Team have defined a range of values which are available for use by MOD authors who are only creating MODs for use on a single site, and you are able to use any value from within this range. Any new MODs which are submitted to the phpBB MOD DB after the start of November should not use any values in this reserved range, as the MOD Team are allocating reserved ranges to each MOD Author who requires them for MODs which will be released at phpBB.com. It is still possible, that older MODs you may have installed will use a value in this range, which you can check by looking in contants.php for any "define('PAGE_" lines, in which case you should not use that value.

Full details on this can be found here: http://www.phpbb.com/kb/article.php?article_id=149

If you plan to release your MOD in the phpBB MOD DB, then you will need to obtain a reserved value for your MOD, and will have to make the required changed to the relevant files, as the MOD Team will currently not validate and release any MODs which depend on having other MODs installed.


Can any member of the MOD-Team confirm this, please? :)

In short, does another MOD depending on Graham's PageID tool have any chance to be validated?

If so, suggestion: Add a reference to this MOD in the above mentioned KB article.

:roll:

Posted: Fri Jul 30, 2004 4:09 pm
by wGEric
markus_petrux wrote: Hi, Graham!

Really wise MOD, IMO. ;)

...

Can any member of the MOD-Team confirm this, please? :)

In short, does another MOD depending on Graham's PageID tool have any chance to be validated?

If so, suggestion: Add a reference to this MOD in the above mentioned KB article.

:roll:


Since his MOD is in the Database, your MOD can require it and still get validated.

Posted: Fri Jul 30, 2004 4:19 pm
by markus_petrux
Very good to know!

Thanks again, Eric. :)

Posted: Thu Nov 18, 2004 6:52 pm
by KISS News
OK, it basically works, but something must be wrong with this code:
#-----[ OPEN ]------------------------------------------
#
admin/index.php

#
#-----[ FIND ]------------------------------------------
#
default:
$location = $lang['Forum_index'];
$location_url = "index.$phpEx?pane=right";
#
#-----[ AFTER, ADD ]------------------------------------------
#
$page_id_count = count($page_id);
for ($i=0; $i<$page_id_count; $i++)
{
if ($page_id[$i]['CONSTANT_VALUE'] == $onlinerow_reg[$i]['user_session_page'])
{
$location = $lang[$page_id[$i]['LANG_STRING']];
break;
}
}
#
#-----[ FIND ]------------------------------------------
#
default:
$location = $lang['Forum_index'];
$location_url = "index.$phpEx?pane=right";
#
#-----[ AFTER, ADD ]------------------------------------------
#
$page_id_count = count($page_id);
for ($i=0; $i<$page_id_count; $i++)
{
if ($page_id[$i]['CONSTANT_VALUE'] == $onlinerow_guest[$i]['session_page'])
{
$location = $lang[$page_id[$i]['LANG_STRING']];
break;
}
}

the admin/index.php in the ACP doesn't show up with this code...

Posted: Wed Jun 07, 2006 10:55 am
by sarahara
hello.

could some be so nice and link an install instruction for this one, i need it for the wordgraph mod from pentapenguin.

can't find any install instruction. weird.


sarah.

Re: [2.0.6] Page ID Extension

Posted: Wed Nov 07, 2007 12:02 am
by cunyalen
Is it also working for phpbb3?