Page 11 of 15

Posted: Thu Sep 29, 2005 2:27 pm
by Griswald
Q: Has anyone modified the mod so that the order of categories and FAQ entries can be controlled? It would be a most valuable addition to an already excellent mod.

Posted: Thu Sep 29, 2005 2:28 pm
by rolltidega
I figured out my problem. I have multiple PHP files trying to call the same function name. Once I renamed the functions in the proper files so that they did not conflict that allowed me to add the English FAQ questions back. Thanks!

Posted: Fri Oct 07, 2005 12:08 pm
by Chicken Boy
I install this mod and know when I go to the administration panel I can't see left side.

Image

What I do wrong?

Posted: Mon Oct 31, 2005 10:50 am
by tyldem
I get the same problem. It comes when i add the two php files to the admin section. I have several other mods, but they shouldn't affect it. The panel goes blank so it must not like the code for some reason. What should i do to debug it or is their a sollution.

Posted: Thu Nov 03, 2005 11:10 am
by mwx
i get

Couldn't get list of Languages

DEBUG MODE

SQL Error : 1146 Table 'way2evil.FAQ_TABLE' doesn't exist

SELECT lang_id, count(faq_id) AS faq_count FROM FAQ_TABLE GROUP BY lang_id

Line : 57
File : admin_faq_inst.php

Posted: Fri Jan 13, 2006 6:10 pm
by 2bjenn
Awesome MOD! :cool:

I was mainly nervous about the database where I had to manually create tables and I don't know the code well. Fortunately someone provided what needs to be entered in there and I was able to do it.

The only thing that I wish it had was the ability to move categories up and down like the forums -- I saw that someone posted that and the reply - so I should have planned the order better beforehand. :roll:

I did find an alternate way to organize it the way I want after all the info has already been entered. Just create a new category (with a similar name - I'm not sure if it will let you create a duplicate and it will be easier if it's not exactly the same anyway) then "delete" the original category and move all the posts to the new one from the drop down box (then change the name to what it was previously if you want). It's not as easy as simply moving the categories around, but at least you won't have to reenter all the posts - only the category name and you'll have them right where you want them. Hope that helps a little if no one thought of it. And if it was already posted - sorry about that!

Anyway KUDOS to the creator! I love it!

Blank panel issue:

Posted: Wed Jan 18, 2006 9:56 am
by StormeRider
Open up admin_faq.php and replace get_info with faq_get_info everywhere. Replace get_list with faq_get_list everywhere. In vi:

:1,$s/get_info/faq_get_info/
:1,$s/get_list/faq_get_list/

Open up admin_faq_inst.php and replace get_list with faq_get_list everywhere. In vi:

:1,$s/get_list/faq_get_list/

This will fix the issue where the admin panel left navigation pane turns white.

zparta, can you fix this and update the mod?

Posted: Thu Jan 26, 2006 3:36 pm
by Inkrat
MentalMaze wrote:
mjatas wrote:It finally worked. Still one other problem, though! I am trying to edit the FAQ page and when I do and I can see the FAQ page being changed in the acp, however when I go to the FAQ page on the main page it is the same FAQ page as I was always getting. Why isn't it changing?


Are you using a cache system? If not it may not be actually writing it to the db. The issue is either a permissions issue or a cache issue I would think. Or the edits! I believe in includes/constants.php


Can anyone elaborate on this?

I managed to straighten out about 2 or 3 errors with the help of this thread but I can't actually get my changes to show up in the FAQ even though the ACP is giving me the impression it has changed.

It is writing to my database as I checked on phpmyadmin and the record for the table phpbb_faq changed from 6 to 7, and last updated time was the time I made the change. Refreshing the page doesn't seem to help.

Posted: Wed Feb 01, 2006 1:52 pm
by Inkrat
Anyone?

Posted: Sun Mar 12, 2006 10:49 pm
by tensuke

Code: Select all

Fatal error: Cannot redeclare get_lang_list() in /home/tensuke/public_html/forums/admin/admin_faq_inst.php on line 52
I did everything fine,but I have this error...

Posted: Fri Mar 24, 2006 6:01 pm
by DRXT
^^^^^ yea i got the same thing

Posted: Fri Mar 24, 2006 6:39 pm
by DRXT
sorry about the double post

missing tables in FAQ admin...?

Posted: Tue Mar 28, 2006 4:52 am
by Rusty Dogg
Hi

I installed FAQ admin a while back and it didn't work (missing tables error); so I recently upgraded from PHPBB 2.0.18 to 2.0.19 and I get the same errors. I believe I installed from EasyMod.

Here's the "missing table errors I get for each of the 3 FAQ admin choices:

===================================

Under BBCODE ADMIN I get this:

Couldn't get list of Languages
DEBUG MODE
SQL Error : 1146 Table 'bb.BBCODE_TABLE' doesn't exist
SELECT lang_id, count(faq_id) AS faq_count FROM BBCODE_TABLE GROUP BY lang_id
Line : 177
File : admin_faq.php



Under FAQ ADMIN, I get this:


Couldn't get list of Languages
DEBUG MODE
SQL Error : 1146 Table 'bb.FAQ_TABLE' doesn't exist
SELECT lang_id, count(faq_id) AS faq_count FROM FAQ_TABLE GROUP BY lang_id
Line : 177
File : admin_faq.php



Under FAQ Lang Installer, I get this:


Couldn't get list of Languages
DEBUG MODE
SQL Error : 1146 Table 'bb.FAQ_TABLE' doesn't exist
SELECT lang_id, count(faq_id) AS faq_count FROM FAQ_TABLE GROUP BY lang_id
Line : 57
File : admin_faq_inst.php

==============================

Thanks for any help with this; I'm not too technically adept, but I have tweaked stuff under PHPADMIN before, but I'm groping and fumbling (and praying alot!) when I do it..!!

Rusty

missing tables in FAQ admin...?

Posted: Tue Mar 28, 2006 4:58 am
by Rusty Dogg
(** oops - duplicated post by accident *** deleted! ** )

Posted: Sat Apr 15, 2006 7:40 pm
by seg
I just moved my site to a PHP 5 server. Similar to earlier posts the left nav pane in Admin is blank. Did anyone get this fixed?