[2.0.6] faq admin mod

The cleanup is complete. This forum is now read only.
Post Reply

Rating:

Excellent!
27
56%
Very Good
11
23%
Good
3
6%
Fair
4
8%
Poor
3
6%
 
Total votes: 48

MattInVegas
Registered User
Posts: 18
Joined: Sun Apr 18, 2004 7:38 pm
Contact:

Post by MattInVegas » Tue May 11, 2004 2:09 pm

dennistt wrote:
FWGaming wrote:(I have problems w/the whole SQL thing)


http://phpbb.com/kb/article.php?article_id=151


My phpBB files/Board isn't listed on any of the menu's in phpMyAdmin. (RE: Step 2)
It's installed directly on my Server. How would 'I' go about installing this Mod? What would I do with the SQL Create Table command in the Mod?
I'm pretty NEW to all of this.

MattInVegas
Registered User
Posts: 18
Joined: Sun Apr 18, 2004 7:38 pm
Contact:

Post by MattInVegas » Wed May 12, 2004 12:41 pm

What I most need to know, is: Where do THESE go if I have to install this mod the HARD way?

Code: Select all

# 
#-----[ SQL ]------------------------------------------ 
# 
CREATE TABLE `phpbb_faq` (
  `lang_id` varchar(50) NOT NULL default 'english',
  `faq_id` tinyint(11) NOT NULL default '0',
  `faq_title` varchar(255) NOT NULL default '',
  PRIMARY KEY  (`faq_id`,`lang_id`)
) TYPE=MyISAM;

# 
#-----[ SQL ]------------------------------------------ 
# 
CREATE TABLE `phpbb_faq_text` (
  `lang_id` varchar(50) NOT NULL default 'english',
  `q_id` tinyint(11) NOT NULL default '0',
  `faq_id` tinyint(11) NOT NULL default '0',
  `q` text NOT NULL,
  `a` text NOT NULL,
  PRIMARY KEY  (`q_id`,`lang_id`)
) TYPE=MyISAM;

# 
#-----[ SQL ]------------------------------------------ 
# 
CREATE TABLE `phpbb_bbcode` (
  `lang_id` varchar(50) NOT NULL default 'english',
  `faq_id` tinyint(11) NOT NULL default '0',
  `faq_title` varchar(255) NOT NULL default '',
  PRIMARY KEY  (`faq_id`,`lang_id`)
) TYPE=MyISAM;

# 
#-----[ SQL ]------------------------------------------ 
# 
CREATE TABLE `phpbb_bbcode_text` (
  `lang_id` varchar(50) NOT NULL default 'english',
  `q_id` tinyint(11) NOT NULL default '0',
  `faq_id` tinyint(11) NOT NULL default '0',
  `q` text NOT NULL,
  `a` text NOT NULL,
  PRIMARY KEY  (`q_id`,`lang_id`)
) TYPE=MyISAM;
Because, Nothing was imported to my database like the Mod says it will be.
Thanks.

crazee_canuck
Registered User
Posts: 7
Joined: Wed Dec 18, 2002 11:15 pm

Post by crazee_canuck » Thu May 13, 2004 3:15 am

MattInVegas wrote: What I most need to know, is: Where do THESE go if I have to install this mod the HARD way?


Here's a complete walkthrough from a mysql prompt:

Code: Select all

$ mysql -u root -p yourdatabasename
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 33801 to server version: 4.0.18-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> #-----[ SQL ]------------------------------------------
mysql> #
mysql> CREATE TABLE `phpbb_faq` (
    ->   `lang_id` varchar(50) NOT NULL default 'english',
    ->   `faq_id` tinyint(11) NOT NULL default '0',
    ->   `faq_title` varchar(255) NOT NULL default '',
    ->   PRIMARY KEY  (`faq_id`,`lang_id`)
    -> ) TYPE=MyISAM;

#
#-----[ SQL ]------------------------------------------
Query OK, 0 rows affected (0.02 sec)

mysql> 
mysql> #
mysql> #-----[ SQL ]------------------------------------------
mysql> #
mysql> CREATE TABLE `phpbb_faq_text` (
    ->   `lang_id` varchar(50) NOT NULL default 'english',
    ->   `q_id` tinyint(11) NOT NULL default '0',
    ->   `faq_id` tinyint(11) NOT NULL default '0',
    ->   `q` text NOT NULL,
    ->   `a` text NOT NULL,
    ->   PRIMARY KEY  (`q_id`,`lang_id`)
    -> ) TYPE=MyISAM;
Query OK, 0 rows affected (0.00 sec)

mysql> 
mysql> #
mysql> #-----[ SQL ]------------------------------------------
mysql> #
mysql> CREATE TABLE `phpbb_bbcode` (
    ->   `lang_id` varchar(50) NOT NULL default 'english',
    ->   `faq_id` tinyint(11) NOT NULL default '0',
    ->   `faq_title` varchar(255) NOT NULL default '',
    ->   PRIMARY KEY  (`faq_id`,`lang_id`)
    -> ) TYPE=MyISAM;
Query OK, 0 rows affected (0.00 sec)

mysql> 
mysql> #
mysql> #-----[ SQL ]------------------------------------------
mysql> #
mysql> CREATE TABLE `phpbb_bbcode_text` (
    ->   `lang_id` varchar(50) NOT NULL default 'english',
    ->   `q_id` tinyint(11) NOT NULL default '0',
    ->   `faq_id` tinyint(11) NOT NULL default '0',
    ->   `q` text NOT NULL,
    ->   `a` text NOT NULL,
    ->   PRIMARY KEY  (`q_id`,`lang_id`)
    -> ) TYPE=MyISAM; 
Query OK, 0 rows affected (0.00 sec)

mysql> 
Pick your database from the dropdown, then paste the SQL code in...

MattInVegas
Registered User
Posts: 18
Joined: Sun Apr 18, 2004 7:38 pm
Contact:

Post by MattInVegas » Thu May 13, 2004 9:03 am

The way MY copy of phpBB was installed, it isn't on the drop down menu. That's why I was asking. If it was, I would have this mod installed already.
But, thanks for trying to help me.

LoudStealth
Registered User
Posts: 1
Joined: Tue Jul 29, 2003 12:52 pm

No Language in the Drop Down

Post by LoudStealth » Sun Jun 27, 2004 5:34 am

I had no languages listed in the drop down list, so I dug in the code and found that on the admin_faq_editor.php page I had to make the following change to get this mod to work:

On Line 151 change
'LANGUAGE_SELECT' => language_select($board_config['default_lang'], 'language', $phpbb_realpath.'language'),
to
'LANGUAGE_SELECT' => language_select($board_config['default_lang'], 'language', $phpbb_root_path.'language'),


Also, if anyone is trying to running this mod in phpNuke they may need to make the following change in the same file:

Line 137 change
include($phpbb_root_path."includes/functions_selects.$phpEx");
to
include($phpbb_root_path."../../includes/functions_selects.$phpEx");

Great mod!
Kristin

rick.stijnman
Registered User
Posts: 14
Joined: Thu Jun 10, 2004 12:14 pm

Post by rick.stijnman » Mon Jul 05, 2004 3:16 pm

I have done al SQLquery's, edit the files.
But now when I click on the FAQ its a white page.

Someone has this problem too ?

antoonvdr
Registered User
Posts: 84
Joined: Sat Mar 20, 2004 11:11 pm

Post by antoonvdr » Tue Jul 06, 2004 2:55 am

odie3 wrote: I lost my Attachment MOD FAQ's. I believe this happened when the fag.php was changed.

I figured there would by a way via the ACP but the install does not pick up the lang_faq_attach.php as a vaild file to install.

Does any one know how to get lang_faq_attach.php back in after using appling this MOD?

Thanks for any help!

I have same problem. Anybody found a solution yet?

[LoD]Forage
Registered User
Posts: 1
Joined: Sat Aug 07, 2004 5:59 am

faq admin

Post by [LoD]Forage » Sat Aug 07, 2004 6:26 am

Can anyone tell me what I need to change/modify/remove/chmod to fix this issue?

Fatal error: Cannot redeclare get_info() in /home/forums/public_html/forums/admin/admin_faq.php on line 69


I have tried a few different things and the current fix was by renaming the file. If anyone else has coem across this issue and fixed it please let me know.

ACherki
Registered User
Posts: 24
Joined: Wed Dec 11, 2002 11:47 am
Location: Europa Universalis

Hello!

Post by ACherki » Sat Aug 14, 2004 3:33 pm

I just came across one small thingie which annoys me very much with this mod.

I have installed it, no prob. I have created SQL tables in my DB, no prob - but when i try to get to Admin panel i find the following:

If the file admin_faq.php is in my admin folder - i got my left frame panel just blank.

If i remove it from admin folder - the frame panel apears.

And it concerns only this admin_faq.php file, the other one admin_faq_inst.php shows nicely and i have no problem with it. So can anyone make a guess what causes this trouble?

Thanks in advance for any help
Any amusing deaths lately?

bedee
Registered User
Posts: 28
Joined: Fri Jul 23, 2004 6:52 pm

everything fine until...

Post by bedee » Sat Aug 21, 2004 9:23 pm

Code: Select all

Fatal error: Call to a member function on a non-object in /includes/page_header.php on line 66
does anybody knows this problem? i´ve got only german language pack installed
or
how can i uninstall the sql - statements?
edited 10min after just droped the tables phpbb_faq / phpbb_faq_text / phpbb_bbcode / phpbb_bbcode_text

thanx
bedee

Nexela
Registered User
Posts: 4
Joined: Sun Oct 27, 2002 4:37 am

Post by Nexela » Fri Aug 27, 2004 11:59 am

Ok Since I have seen this question asked a efw times with no answer I figured out how to add the attachment mod faq to Faq Admin Db.

Code: Select all

##############################################################
#Add the Attachment Mod FAQ to the FAQ admin MOD
############################################################## 
## Before Adding This MOD To Your Forum, You Should Back Up All Files Related To This MOD 
############################################################## 
#-----[ OPEN ]------------------------------------------
#
admin/admin_faq_inst.php
#
#-----[ FIND ]------------------------------------------
#
include($phpbb_root_path . 'language/lang_' . $HTTP_POST_VARS['slang'] . '/lang_faq.' .$phpEx);
		$inserts_faq = insert_faq($faq, FAQ_TABLE, FAQ_TEXT_TABLE, $HTTP_POST_VARS['slang']);
		unset($faq);
#
#-----[ AFTER, ADD ]------------------------------------------
#
include($phpbb_root_path . 'language/lang_' . $HTTP_POST_VARS['slang'] . '/lang_faq_attach.' .$phpEx);
		$inserts_faq = insert_faq($faq, FAQ_TABLE, FAQ_TEXT_TABLE, $HTTP_POST_VARS['slang']);
		unset($faq);
#
#-----[ SAVE/CLOSE ALL FILES ]------------------------------------------
#
Afterwards goto the faq lang installer in the ACP and delete and then add your language to get the faq in the db.

shortbus
Registered User
Posts: 32
Joined: Sun Dec 21, 2003 3:19 am
Contact:

Post by shortbus » Fri Sep 03, 2004 5:48 pm

great work guys!

especially the forethought to add the faq by language -- that would have been lots of cut and paste otherwise.

MissK
Registered User
Posts: 4
Joined: Fri Sep 17, 2004 7:15 pm
Contact:

Post by MissK » Sun Sep 19, 2004 11:50 pm

ok i'm having the same problem an above poster, he fixed it but i didn't see where he posted it

Code: Select all

Couldn't get list of Languages

DEBUG MODE

SQL Error : 1146 Table 'mystic_khanbb.FAQ_TABLE' doesn't exist

SELECT lang_id, count(faq_id) AS faq_count FROM FAQ_TABLE GROUP BY lang_id

Line : 57
File : /home/mystic/public_html/khanforum/admin/admin_faq_inst.php
i'm getting this same type of error for each FAQ option(only pasted one)
i've checked the code (line by line even) and its all copied correctly, and i checked my data base and the tables are all there.

And running the SQL commands a second time just gives me an error that they already exist.

The mod was installed manually and the sql was done via phpMyAdmin
phpbb version is 2.0.10

Greener
Registered User
Posts: 41
Joined: Mon Dec 01, 2003 11:01 pm
Location: Mission, Kansas
Contact:

Post by Greener » Tue Sep 28, 2004 11:36 am

This mod say 2.0.6, does it work fine on 2.0.10?

And this mod is not EMC as of this date correct? No problem if its not just curious.

MissK
Registered User
Posts: 4
Joined: Fri Sep 17, 2004 7:15 pm
Contact:

Post by MissK » Wed Sep 29, 2004 12:51 am

i found some one to help me with this

apparently the sql command created the table as phpbb_faq and the file changes referred to FAQ_TABLE.

after i changed them all it worked fine. odd actually.

Post Reply

Return to “[2.0.x] MOD Database Cleanup”