Page 1 of 15

[2.0.6] faq admin mod

Posted: Fri Nov 28, 2003 10:57 pm
by Extensions Robot
MOD Name: faq admin mod
Author: zparta
MOD Description: This MOD will put the faq in the database and make it editable from the ACP

MOD Version: 1.4.6


Download File: faq_admin_1_4_6.zip
File Size: 11712 Bytes

Posted: Sat Nov 29, 2003 3:39 am
by wGEric
MOD Validated/Released

There is another FAQ editor in the MOD Database. Use this one if you would like to have your FAQs in your database. Use the other if you would rather have your FAQs still in their .php files.

Posted: Sat Nov 29, 2003 11:10 am
by zparta
when installing this mod there wont be any faq's in the database and you can import the ones you got in your .php files, you can also uninstall the installed languages from the same page.

the faq page that people see is the same as the original one.

and thnx for the release :)

ohh i almost forgot it supports multilanguage :)

Posted: Sat Nov 29, 2003 9:55 pm
by FWGaming
Is this EMC? It looks like it, so how would I manually install it? (I have problems w/the whole SQL thing)

Posted: Sun Nov 30, 2003 7:02 am
by dennistt
FWGaming wrote: (I have problems w/the whole SQL thing)


http://phpbb.com/kb/article.php?article_id=151

Posted: Sun Nov 30, 2003 11:03 am
by wanted
Thanks zparta, your mod is great!!! :D

Posted: Sun Nov 30, 2003 7:26 pm
by zparta
thnx for the nice comments :) i have been working on this mod for a coupel of month nice to see that someone like it :)

Posted: Mon Dec 01, 2003 4:32 pm
by Me2U
It is indeed a great MOD. I think it works right but there is an error given in the Admin Panel ( In the BBcode/FAQ Admin ):

Code: Select all

Warning: ob_start(): output handler 'ob_gzhandler' cannot be used twice in /opt/guide/www.me2u.nl/HTML/forum/admin/page_header_admin.php on line 44
Maybe there is an FIX for that :roll:

Posted: Mon Dec 01, 2003 5:34 pm
by Diskmaster
Me2U wrote: It is indeed a great MOD. I think it works right but there is an error given in the Admin Panel ( In the BBcode/FAQ Admin ):

Code: Select all

Warning: ob_start(): output handler 'ob_gzhandler' cannot be used twice in /opt/guide/www.me2u.nl/HTML/forum/admin/page_header_admin.php on line 44
Maybe there is an FIX for that :roll:


What version of php are you running on your server / host's server? If it's 4.3.1 or higher, there's an article in the Knowldege Base that may solve your problem.

Posted: Mon Dec 01, 2003 6:54 pm
by Me2U
I guess that is not the fix to solve it cause:

It is for the page_header.php in the Includes map

And it is about that i cannot be loaded twice

:roll:

Posted: Mon Dec 01, 2003 8:17 pm
by zparta
that problem has never occured for me it might be another mod you have installed that has changed that file because that error seam to be before my mod is loaded

Posted: Mon Dec 01, 2003 8:53 pm
by Me2U
I think it has to do with GZIP.. i have it enabled

More info:
Server is running PHP version: 4.3.4
phpBB version: 2.0.6

But while there is an error i still can do anything the MOD should do :roll:

Posted: Mon Dec 01, 2003 9:52 pm
by rocker
This worked for me had the same problem


Open the file /includes/page_header.php PLUS /admin/page_header_admin.php

Find this code




Code:

//
// gzip_compression
//
$do_gzip_compress = FALSE;
if ( $board_config['gzip_compress'] )
{
$phpver = phpversion();

$useragent = (isset($_SERVER["HTTP_USER_AGENT"]) ) ? $_SERVER["HTTP_USER_AGENT"] : $HTTP_USER_AGENT;

if ( $phpver >= '4.0.4pl1' && ( strstr($useragent,'compatible') || strstr($useragent,'Gecko') ) )
{
if ( extension_loaded('zlib') )
{
ob_start('ob_gzhandler');
}
}
else if ( $phpver > '4.0' )
{
if ( strstr($HTTP_SERVER_VARS['HTTP_ACCEPT_ENCODING'], 'gzip') )
{
if ( extension_loaded('zlib') )
{
$do_gzip_compress = TRUE;
ob_start();
ob_implicit_flush(0);

header('Content-Encoding: gzip');
}
}
}
}



And replace with this code


Code:
//
// gzip_compression
//
$do_gzip_compress = FALSE;
if ( $board_config['gzip_compress'] )
{
$phpver = phpversion();

$useragent = (isset($_SERVER["HTTP_USER_AGENT"]) ) ? $_SERVER["HTTP_USER_AGENT"] : $HTTP_USER_AGENT;

if ( $phpver >= '4.0.4pl1' && ( strstr($useragent,'compatible') || strstr($useragent,'Gecko') ) )
{
if ( extension_loaded('zlib') )
{
ob_end_clean();
ob_start('ob_gzhandler');
}
}
else if ( $phpver > '4.0' )
{
if ( strstr($HTTP_SERVER_VARS['HTTP_ACCEPT_ENCODING'], 'gzip') )
{
if ( extension_loaded('zlib') )
{
$do_gzip_compress = TRUE;
ob_start();
ob_implicit_flush(0);

header('Content-Encoding: gzip');
}
}
}
}


I found this on a google search yesterday

Posted: Tue Dec 02, 2003 6:37 am
by Me2U
Thanks!!!

That worked indeed!! 8) 8)

Error Msg

Posted: Wed Dec 03, 2003 1:41 am
by twinsdaily
General Error
Couldn't get list of Languages

DEBUG MODE

SQL Error : 1146 Table 'weilik_beta.FAQ_TABLE' doesn't exist

SELECT lang_id, count(faq_id) AS faq_count FROM FAQ_TABLE GROUP BY lang_id

Line : 57
File : /home2/weilik/public_html/beta/admin/admin_faq_inst.php

Can anyone please help me with those errors in my Admin Panel on the FAQ Installation? Thx very much. I'm using phpBB 2.0.6. :wink: