[2.0.6] Allow Moderators to See Invisible

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
13
59%
Very Good
6
27%
Good
3
14%
Fair
0
No votes
Poor
0
No votes
 
Total votes: 22

User avatar
Force
Registered User
Posts: 22
Joined: Fri Apr 11, 2003 3:25 am
Location: USA, Pennsylvania

Post by Force » Thu Apr 27, 2006 6:29 pm

Works like a charm asaan... using phpBB 2.0.20.
Look in... to the eye of the storm
Look out... for the force without form

mnp13
Registered User
Posts: 268
Joined: Fri Jan 06, 2006 11:48 pm
Contact:

Post by mnp13 » Sat Sep 09, 2006 9:03 pm

I just installed this, and it is only working on the "last visit" list of users, not the current list of people online.

I'm using .21

Thanks.
Michelle

kissels
Registered User
Posts: 44
Joined: Tue Feb 06, 2007 8:54 pm

Nothing happens

Post by kissels » Wed Feb 07, 2007 7:56 pm

I modified the page header as instructed and uploaded the change, but nothing seems to happen. I don't see anything changed. Where am I supposed to be able to see the hidden user info?

Any help would be appreciated.

Thanks!
Kim

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf » Wed Feb 07, 2007 8:00 pm

Hidden users are shown in italics in the WhoIsOnline section at the bottom of index.

kissels
Registered User
Posts: 44
Joined: Tue Feb 06, 2007 8:54 pm

Post by kissels » Wed Feb 07, 2007 8:07 pm

Brf wrote: Hidden users are shown in italics in the WhoIsOnline section at the bottom of index.


Mine shows just this:
In total there are 2 users online :: 0 Registered, 1 Hidden and 1 Guest [ Administrator ] [ Moderator ]

I thought this MOD would show the "username" or more information about the hidden user(s). Is that incorrect?

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf » Wed Feb 07, 2007 8:14 pm

It does, if you have done the edit properly, and you are logged in as a moderator.

kissels
Registered User
Posts: 44
Joined: Tue Feb 06, 2007 8:54 pm

Post by kissels » Wed Feb 07, 2007 9:01 pm

So... won't show if logged in as administrator... or is there an edit to make that happen as well?

Thanks by the way for your help!

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf » Wed Feb 07, 2007 9:13 pm

Invisible always shows when you are logged in as an administrator. You dont need a mod for that.

kissels
Registered User
Posts: 44
Joined: Tue Feb 06, 2007 8:54 pm

Post by kissels » Wed Feb 07, 2007 9:27 pm

Hmm... just can't figure out why I don't see the hidden users info. Here is the section of the ..includes/page_header.php file with the change made (bolding added for your benefit, not in actual code, obviously). I added the code before and after as well so you could see that no changes were made before or after the "replace" change.


$user_online_link = '<a href="' . append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=" . $row['user_id']) . '"' . $style_color .'><i>' . $row['username'] . '</i></a>';
$logged_hidden_online++;
}

if ( $row['user_allow_viewonline'] || $userdata['user_level'] == ADMIN || $userdata['user_level'] == MOD )

{
$online_userlist .= ( $online_userlist != '' ) ? ', ' . $user_online_link : $user_online_link;
}
}



I don't see anything wrong and, unless the problem has something to do with my version of php (4.4.2) or something similar, I can't figure out what is causing it to not work.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf » Wed Feb 07, 2007 9:32 pm

I am not even seeing your online userlist there.... it should at least say "Registered Users: None"

kissels
Registered User
Posts: 44
Joined: Tue Feb 06, 2007 8:54 pm

Post by kissels » Wed Feb 07, 2007 9:36 pm

Could this/these problems be caused by the Cracker Tracker MOD I installed this morning, before installing the See Invisible. I did read something (not sure where now) that said there was an issue with installing MODs after Cracker Tracker was installed... something about it seeing them as attacks???

kissels
Registered User
Posts: 44
Joined: Tue Feb 06, 2007 8:54 pm

Post by kissels » Wed Feb 07, 2007 9:38 pm

And I also just got a "Security Alert" from Cracker Tracker when trying to access (click on link) for Group Admin -> Management.

kissels
Registered User
Posts: 44
Joined: Tue Feb 06, 2007 8:54 pm

Post by kissels » Wed Feb 07, 2007 9:39 pm

kissels wrote: And I also just got a "Security Alert" from Cracker Tracker when trying to access (click on link) for Group Admin -> Management.


Actually that was when I clicked the "Create New Group" button after accessing that Management page.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf » Wed Feb 07, 2007 9:48 pm

Does your template even have the "Registered Users" line at the bottom of WhoIsOnline?

kissels
Registered User
Posts: 44
Joined: Tue Feb 06, 2007 8:54 pm

Post by kissels » Thu Feb 08, 2007 12:13 am

Yes, it does. Here's that section. It appears than, in the first line, I'm not showing up in the count as a registered user, but rather, as a hidden person. Hmm. Don't know why that's happening.

In total there are 3 users online :: 0 Registered, 1 Hidden and 2 Guests [ Administrator ] [ Moderator ]
Most users ever online was 45 on 22 Oct 2006 03:44 pm
Registered Users: CWDAdmin

Post Reply

Return to “[2.0.x] MOD Database Cleanup”