[2.0.7] Animated New Message Icon Mod

The cleanup is complete. This forum is now read only.
Post Reply

Rating:

Excellent!
17
57%
Very Good
5
17%
Good
4
13%
Fair
1
3%
Poor
3
10%
 
Total votes: 30

PaperShark
Registered User
Posts: 43
Joined: Fri Nov 05, 2004 1:06 am
Location: Somewhere in the Pacific Ocean
Contact:

Post by PaperShark »

I am having the same problem with it saying I have 1 inread message when in fact I do not. Checked the files and all seems fine?

Here is my board: http://www.whitepapersource.com/forum/privmsg.php.

Any suggestions? Should I revert back to the original PHP?

PaperShark
vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker »

If it doesn't work properly you probably missed something or made a typo.
User avatar
GurlzLubme
Registered User
Posts: 880
Joined: Wed Sep 01, 2004 11:21 am
Location: New York

Post by GurlzLubme »

vHiker wrote: Yes. If you want it to flash when you have unread messages just set...

$images['pm_unread_msg'] = $images['pm_new_msg'];


works just the way i wanted it to. thank you! =)
PaperShark
Registered User
Posts: 43
Joined: Fri Nov 05, 2004 1:06 am
Location: Somewhere in the Pacific Ocean
Contact:

Post by PaperShark »

Decided to remove this as it was installed correctly yet still the problem was not resolved. Thanks!
maharajah
Registered User
Posts: 6
Joined: Fri Dec 17, 2004 1:56 am

Post by maharajah »

My last part on Morpheus theme is:

Code: Select all

	<?php if($this->vars['CA_NEW_MSGS'] && $this->vars['PRIVATE_MESSAGE_INFO'] !== $this->vars['CA_L_NO_MSG'] && !defined('CA_POPUP_SHOWED')) { ?>
	<div id="newmsgs"><a href="{U_PRIVATEMSGS}" class="newmsgs"><img src="{PRIVMSG_IMG}" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO_UNREAD}</a></div>
	<?php define('CA_POPUP_SHOWED', true); } ?>
After i added

Code: Select all

<img src="{PRIVMSG_IMG}" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO_UNREAD}
But it doesnt have a icon next to the new messages.

Any help please.
andyb
Registered User
Posts: 6
Joined: Tue May 27, 2003 12:53 am

Post by andyb »

A nice mod. Works fine with phpbb version 2.0.11

Andy
Druid_YGM
Registered User
Posts: 40
Joined: Tue Dec 21, 2004 9:24 am

Post by Druid_YGM »

Edit : Please ignore this post. Sorted it another way.
User avatar
Brenakie
Registered User
Posts: 77
Joined: Mon Mar 15, 2004 12:08 am
Location: Pascoag, RI - USA
Contact:

Post by Brenakie »

Nice MOD, I have the images for subTrail if anyone needs them....
kylewitt
Registered User
Posts: 34
Joined: Tue Mar 29, 2005 1:52 am

Does This Work For All Skins?

Post by kylewitt »

Im not sure,but does this mod work for all the skins or just the sub silver?
vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker »

all skins, but you may need to make your own icon
sandspit
Registered User
Posts: 34
Joined: Sun Mar 20, 2005 12:42 am

Warning: Wrong parameter count

Post by sandspit »

To all,

MOD works perfect!

One weird thing - that doesn't seem to have an effect on other
functions but that I'd like not to see . . . although there must be
a problem somewhere since this error message is displayed.

Warning: Wrong parameter count for usort() in /home/amzzk/public_html/Forum/privmsg.php on line 1145

Warning: Cannot modify header information - headers already sent by (output started at /home/amzzk/public_html/Forum/privmsg.php:1145) in /home/amzzk/public_html/Forum/includes/page_header.php on line 535

Warning: Cannot modify header information - headers already sent by (output started at /home/amzzk/public_html/Forum/privmsg.php:1145) in /home/amzzk/public_html/Forum/includes/page_header.php on line 537

Warning: Cannot modify header information - headers already sent by (output started at /home/amzzk/public_html/Forum/privmsg.php:1145) in /home/amzzk/public_html/Forum/includes/page_header.php on line 538

I receive this message at the top of index page after I pm someone.

after a couple of seconds I'm automatically returned to the index page
and the error message is gone.

Please advice.

Thanx in advance!

(((sandspit)))
Duxa
Registered User
Posts: 35
Joined: Sun Apr 03, 2005 10:24 am

Post by Duxa »

doesnt work in EOS skin =/
inhellfire
Registered User
Posts: 26
Joined: Sun Apr 24, 2005 10:48 pm

Was working fine, now won't show up..

Post by inhellfire »

nevermind.. seeing old posts not answered i switched back to the original..
vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker »

Sorry, I can't respond immediately to every post, particularly since phpbb blocks my work IP for some unknown reason. I also can't read minds. It helps to be specific... :D
vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Re: Warning: Wrong parameter count

Post by vHiker »

sandspit wrote: Warning: Wrong parameter count for usort() in /home/amzzk/public_html/Forum/privmsg.php on line 1145

I'm not sure. It is likely due to some other mod you made. This mod doesn't affect any lines of code that use the usort function. What is line 1145 of your privmsg.php?
Post Reply

Return to “[2.0.x] MOD Database Cleanup”