[2.0.7] Memberlist_Hidden_User_MOD

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
1
25%
Very Good
1
25%
Good
1
25%
Fair
1
25%
Poor
0
No votes
 
Total votes: 4

Extensions Robot
Extensions Robot
Extensions Robot
Posts: 27954
Joined: Sat Aug 16, 2003 7:36 am

[2.0.7] Memberlist_Hidden_User_MOD

Post by Extensions Robot » Thu Jan 08, 2004 5:13 am

MOD Name: Memberlist_Hidden_User_MOD
Author: N3cr0shark
MOD Description: Adds the ability to hide users in the Memberslist via ACP 'Manage User'

MOD Version: 1.0.0

Download File: Memberlist Hidden User MOD.mod
mods overview page: View
File Size: 7887 Bytes

Security Score:
Last edited by Extensions Robot on Mon Apr 30, 2007 12:27 am, edited 1 time in total.
(this is a non-active account manager for the phpBB Extension Customisations Team)

wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Post by wGEric » Tue Jul 27, 2004 9:43 pm

MOD Validated/Released

Notes:
This MOD lets the admin make it so certain users won't be shown in the memberlist.

pinafore
Registered User
Posts: 2
Joined: Fri Jul 05, 2002 10:44 pm

blank memberlist

Post by pinafore » Thu Jul 29, 2004 10:23 pm

i installed this mod but when i click my memberlist icon then, i get a blank page.

any help?

User avatar
N3cr0shark
Registered User
Posts: 7
Joined: Mon Jan 05, 2004 8:28 pm
Contact:

Post by N3cr0shark » Wed Aug 18, 2004 3:36 am

Sorry, I just found out that the mod actually got approved. :oops:

If you get a blank page, it sounds like the default entry in the database did not get set as null (or 0). Just a suggestion without having anymore details....

Do you still get the normal PHPBB header and footer info or just a blank page?

frdm
Registered User
Posts: 3
Joined: Fri Sep 03, 2004 10:02 pm
Location: France
Contact:

Memberlist_Hidden_User parse error, unexpected T_LOGICAL_AND

Post by frdm » Fri Sep 03, 2004 10:30 pm

After installing Memberlist_Hidden_User_MOD with EasyMod,
I get a totally blank page with this when opening the Memberlist:

Parse error: parse error, unexpected T_LOGICAL_AND in /data/www/fr/o/s/asso.fr/r/e/analyser/htdocs/fora/memberlist.php on line 296

The line 296 seems to be the one containing "and show_in_memberlist <> 0";" in the following lines :

if ( $mode != 'topten' || $board_config['topics_per_page'] < 10 )
{
$sql = "SELECT count(*) AS total
FROM " . USERS_TABLE . "
WHERE user_id <> " . ANONYMOUS;

and show_in_memberlist <> 0";
// Memberlist Hidden User MOD

I hope I'm giving usefull details for my question.
frdm
(first language : French)

Peaches21
Registered User
Posts: 2
Joined: Sun Sep 05, 2004 6:31 am

I too am getting the same error

Post by Peaches21 » Sun Sep 05, 2004 7:13 am

Please Help I'm getting the same error. I have looked and looked all over the place to try and fix it and i'm not find anything. Everything is coded right. Here is the error

Parse error: parse error, unexpected T_LOGICAL_AND in /home/akyla/public_html/operation/memberlist.php on line 309

And on the line 309 it shows this

and show_in_memberlist <> 0";

Please help.

Peaches21
Registered User
Posts: 2
Joined: Sun Sep 05, 2004 6:31 am

here is what some one told me to do

Post by Peaches21 » Sun Sep 05, 2004 1:13 pm

i went and asked some one else to see if they could help out. and this is what they had me do
$sql = "SELECT count(*) AS total
FROM " . USERS_TABLE . "
WHERE user_id <> " . ANONYMOUS;
and show_in_memberlist <> 0";


..replace with..
$sql = "SELECT count(*) AS total
FROM " . USERS_TABLE . "
WHERE user_id <> " . ANONYMOUS ."
and show_in_memberlist <> 0";

User avatar
N3cr0shark
Registered User
Posts: 7
Joined: Mon Jan 05, 2004 8:28 pm
Contact:

Post by N3cr0shark » Thu Sep 16, 2004 3:30 am

Peaches,

Thanks for the post....and the research...


Ok...upon review I see there is a couple of typos in the script due to MOD editing for posting here I think

So, Replace the orignal piece in the MOD script:
#
#-----[ FIND ]-----------------------------------------
#
$sql = "SELECT count(*) AS total
FROM " . USERS_TABLE . "
WHERE user_id <> " . ANONYMOUS;

#
#-----[ AFTER, ADD ]-----------------------------------------

and show_in_memberlist <> 0";
// Memberlist Hidden User MOD


With the following:
#
#-----[ FIND ]-----------------------------------------
#
$sql = "SELECT count(*) AS total
FROM " . USERS_TABLE . "
WHERE user_id <> " . ANONYMOUS;

#
#-----[ REPLACE WITH ]-----------------------------------------
#
$sql = "SELECT count(*) AS total
FROM " . USERS_TABLE . "
WHERE user_id <> " . ANONYMOUS . "
and show_in_memberlist <> 0";
// Memberlist Hidden User MOD


Somehow the WHERE command difference was missed when we adjusted this from the Replace With to the after add syntax for easymod. This makes sense if you look at frdm's and peaches post where they indicates an unexpected 'and' function (thanks for that)!

I will look at updating the download....
Last edited by N3cr0shark on Thu Sep 16, 2004 4:09 am, edited 2 times in total.

User avatar
N3cr0shark
Registered User
Posts: 7
Joined: Mon Jan 05, 2004 8:28 pm
Contact:

Post by N3cr0shark » Thu Sep 16, 2004 3:42 am

Note: If anyone needs help, please also feel free to email me. I've added it to my profile (but it's also in the MOD script). I try to hit this site about once - twice a week....but as you can see, it's not perfect.

zamba
Registered User
Posts: 1
Joined: Sat Nov 09, 2002 8:04 am
Location: Sydney, Australia
Contact:

Post by zamba » Sat Aug 20, 2005 7:00 am

I have just installed this mod on 2.0.17 and get this error when I click on members while logged in as Site Admin:

Could not query users

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '/ Memberlist Hidden User MOD ORDER BY user_regdate ASC LIMIT

SELECT username, user_id, user_viewemail, user_posts, user_regdate, user_from, user_website, user_email, user_icq, user_aim, user_yim, user_msnm, user_avatar, user_avatar_type, user_allowavatar, user_allow_viewmemberlist, user_group_allow_viewmemberlist FROM phpbb_users WHERE user_id <> -1 AND 1 = 1 and show_in_memberlist <> 0 // Memberlist Hidden User MOD ORDER BY user_regdate ASC LIMIT 0, 50

Line : 192
File : memberlist.php

I've corrected the later typo, have I missed something here?

Regards,

Tony Page :?:
[ZambaGrafix]
<websites that work>
tel: +61 2 9953 4425
fax: +61 2 9909 8534
http://www.zambagrafix.com

Webby
Registered User
Posts: 91
Joined: Tue May 21, 2002 9:28 am
Location: Hannover, Germany
Contact:

sql error

Post by Webby » Thu Sep 22, 2005 2:43 pm

Sigh, this is just the mod im looking for but im getting an error on the first stage.

In phpmyadmin I inserted the sql...
ALTER TABLE phpbb_users ADD show_in_memberlist TINYINT(1) NULL Default(1);

And got a syntax error...
#1064 - Fehler in der Syntax bei '(1)' in Zeile 1.

Which means in english a systax error by '(1)'

Mysql server is:
MySQL 4.0.24_Debian-10-log

Any ideas?
Alan

User avatar
3Di
Former Team Member
Posts: 14071
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: sql error

Post by 3Di » Thu Sep 22, 2005 3:58 pm

Webby wrote: Sigh, this is just the mod im looking for but im getting an error on the first stage.

In phpmyadmin I inserted the sql...
ALTER TABLE phpbb_users ADD show_in_memberlist TINYINT(1) NULL Default(1);

And got a syntax error...
#1064 - Fehler in der Syntax bei '(1)' in Zeile 1.

Which means in english a systax error by '(1)'

Mysql server is:
MySQL 4.0.24_Debian-10-log

Any ideas?
Alan


try this SQL (make a backup first)

Code: Select all

ALTER TABLE phpbb_users ADD show_in_memberlist TINYINT(1) DEFAULT 1 NULL;
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

Webby
Registered User
Posts: 91
Joined: Tue May 21, 2002 9:28 am
Location: Hannover, Germany
Contact:

Post by Webby » Thu Sep 22, 2005 4:20 pm

Thanks!
Will give it a try. Dont like the sound of 'make a backup first' mind lol.

Cheers
Alan

Webby
Registered User
Posts: 91
Joined: Tue May 21, 2002 9:28 am
Location: Hannover, Germany
Contact:

Post by Webby » Thu Sep 22, 2005 4:23 pm

Well i got no errors and calling the page works. Now to see if the mod works.

Alan

User avatar
3Di
Former Team Member
Posts: 14071
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Post by 3Di » Thu Sep 22, 2005 4:29 pm

Webby wrote: Thanks!
Will give it a try. Dont like the sound of 'make a backup first' mind lol.

Cheers
Alan

I strongly suggest to make a backup for security reasons. ;)

I didn't tried the MOD itself, the query i suggested it works (no errors given) but this it is not meaning also the MOD will work as expected after that..

BTW, this query adds a key field that can easily dropped down simply doing:

Code: Select all

ALTER TABLE phpbb_users DROP show_in_memberlist
also that key field does not harm your board if not dropped.

As i can see this MOD seems abandoned.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

Post Reply

Return to “[2.0.x] MOD Database Cleanup”