[2.0.7] Username Color

The cleanup is complete. This forum is now read only.
Post Reply

Rating:

Excellent!
16
44%
Very Good
8
22%
Good
4
11%
Fair
2
6%
Poor
6
17%
 
Total votes: 36

Extensions Robot
Extensions Robot
Extensions Robot
Posts: 27988
Joined: Sat Aug 16, 2003 7:36 am

[2.0.7] Username Color

Post by Extensions Robot » Mon Apr 05, 2004 11:13 pm

MOD Name: Username Color
Author: Famitsu
MOD Description: This mod will show username into viewtopic with profile link and color rank (only ADMIN or MOD).
If the viewing user has admin rigths then the link redirect to the administration profile panel of that user.
Also add user's color rank everywhere (index, viewforum, memberlist...).

MOD Version: 1.1.1 (Updated 07/27/04)



Download File: username_color_1.1.1em.zip
mods overview page: View
File Size: 6353 Bytes

Security Score:
Last edited by Extensions Robot on Mon Apr 30, 2007 12:30 am, edited 1 time in total.
(this is a non-active account manager for the phpBB Extension Customisations Team)

wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Post by wGEric » Tue Jul 27, 2004 9:55 pm

MOD Validated/Released

Notes:
This MOD will color the names of the Moderators and Administrators throughout your board. This will make it easier for users to know if the user is a Moderator or Administrator.

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu » Tue Jul 27, 2004 10:44 pm

Thanks for released it
But i already submitted it in a new name and a new version:
Username Color v1.1.1 - username_color_1.1.1em.zip (in the MODs queue)

Could you update it or remove it from queue? Then i will submit new version?


Maybe you can lock this development topic ?
-> http://www.phpbb.com/phpBB/viewtopic.ph ... 470#795470

MOD in is version 1.1.1 is also compatible with phpBB 2.0.10 :)
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Post by wGEric » Tue Jul 27, 2004 11:01 pm

MOD Updated to version 1.1.1
See first post for Download Link

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu » Tue Jul 27, 2004 11:03 pm

so fast

Thanks again
and keep the good work :)
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Post by wGEric » Tue Jul 27, 2004 11:03 pm

Famitsu wrote: Thanks for released it
But i already submitted it in a new name and a new version:
Username Color v1.1.1 - username_color_1.1.1em.zip (in the MODs queue)

Could you update it or remove it from queue? Then i will submit new version?


Maybe you can lock this development topic ?
-> http://www.phpbb.com/phpBB/viewtopic.ph ... 470#795470

MOD in is version 1.1.1 is also compatible with phpBB 2.0.10 :)


All fixed now. Again sorry about this. I didn't relize there was a new version of this MOD in the Queue.

I locked that development topic for you.
Eric

munkyxtc
Registered User
Posts: 218
Joined: Sat Aug 14, 2004 7:53 pm
Location: Pennsylvania
Contact:

Post by munkyxtc » Mon Aug 16, 2004 9:41 pm

I just installed this mod -- I haven't run into any errors when browsing the forums, I'll let you know of any that I come across.

Just a note for the author -- the 10-20 min estimate, I think that should be up'd as it took me nearly twice as long...the intall.txt file is pretty long. I would say 30mins is a better estimate. If anyone wants to see this MOD in action, you can see it here:

www.munkyxtc.com/forums

USER- test
PW - test

Thanks.

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu » Mon Aug 16, 2004 11:09 pm

munkyxtc wrote: I just installed this mod -- I haven't run into any errors when browsing the forums, I'll let you know of any that I come across.
wrong :lol:
it seems you have an error in groupcp and search :P

munkyxtc wrote: Just a note for the author -- the 10-20 min estimate, I think that should be up'd as it took me nearly twice as long...the intall.txt file is pretty long. I would say 30mins is a better estimate.
it's an approx time
the long part is for groupcp, others files are similarly

With EM, that will be 10 seconds
Positive points are:
- 0 query added
- you can choose different username's color per template :)
- adds an admin profile link in viewtopic for Admin management
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

munkyxtc
Registered User
Posts: 218
Joined: Sat Aug 14, 2004 7:53 pm
Location: Pennsylvania
Contact:

Post by munkyxtc » Tue Aug 17, 2004 12:16 am

Famitsu wrote:
munkyxtc wrote:I just installed this mod -- I haven't run into any errors when browsing the forums, I'll let you know of any that I come across.
wrong :lol:
it seems you have an error in groupcp and search :P

munkyxtc wrote: Just a note for the author -- the 10-20 min estimate, I think that should be up'd as it took me nearly twice as long...the intall.txt file is pretty long. I would say 30mins is a better estimate.
it's an approx time
the long part is for groupcp, others files are similarly


yeah, I was just coming back to post about the groupcp, and search errors...any ideas on them? I re-did those file 2 more times, and am still getting the error messages. Anyone wanna take a look at them.

As far as the time estimate...I know it's just an estimate -- I guess I'm just slow :?

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu » Tue Aug 17, 2004 3:11 pm

PM me your file into a ZIP archive !!!
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

munkyxtc
Registered User
Posts: 218
Joined: Sat Aug 14, 2004 7:53 pm
Location: Pennsylvania
Contact:

Post by munkyxtc » Wed Aug 18, 2004 12:32 am

Famitsu wrote: PM me your file into a ZIP archive !!!


How can I PM a file to you?

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu » Wed Aug 18, 2004 12:38 am

munkyxtc wrote:
Famitsu wrote:PM me your file into a ZIP archive !!!


How can I PM a file to you?
Upload your file on any server you have access
give the link to this archive to download it
then i will check your file to find where is the error :idea:
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

munkyxtc
Registered User
Posts: 218
Joined: Sat Aug 14, 2004 7:53 pm
Location: Pennsylvania
Contact:

Post by munkyxtc » Wed Aug 18, 2004 2:28 am

ok, Sorry, I miss understood what you wanted me to do -- I took it as you wanted me to PM you via these boards.

Download can be found here:

http://www.munkyxtc.com/downloads/colormod.zip

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu » Thu Aug 19, 2004 12:19 pm

OK you have 2 errors in groupcp.php

Code: Select all

				//'U_VIEWPROFILE' => append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=$user_id"))
Should be

Code: Select all

				//'U_VIEWPROFILE' => append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=$user_id")
				)
same error few lines below

Code: Select all

					//'U_VIEWPROFILE' => append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=$user_id"))
Should be

Code: Select all

					//'U_VIEWPROFILE' => append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=$user_id")
					)

and finally in search.php, you have a common error

at these lines you added the code

Code: Select all

									$folder_alt = ( $searchset[$i]['topic_status'] == TOPIC_LOCKED ) ? $lang['Topic_locked'] : $lang['No_new_posts'];

									$folder_image = $folder;
									$folder_alt = $folder_alt;
									$newest_post_img = '';
								}

							}
but that was not the right line
this line (very similar) is few lines below in search.php
see the full line to FIND :wink:
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

munkyxtc
Registered User
Posts: 218
Joined: Sat Aug 14, 2004 7:53 pm
Location: Pennsylvania
Contact:

Post by munkyxtc » Thu Aug 19, 2004 1:57 pm

Thanks for the reply, i'm actually going to edit the files now, and post to the web, I'll post mind findings here.

Thanks again.

Post Reply

Return to “[2.0.x] MOD Database Cleanup”