[2.0.13] SpellingCow Spell Checker

The cleanup is complete. This forum is now read only.
Post Reply

Rating:

Excellent!
56
49%
Very Good
17
15%
Good
6
5%
Fair
6
5%
Poor
29
25%
 
Total votes: 114

Extensions Robot
Extensions Robot
Extensions Robot
Posts: 27918
Joined: Sat Aug 16, 2003 7:36 am

[2.0.13] SpellingCow Spell Checker

Post by Extensions Robot » Thu Jul 08, 2004 7:43 pm

MOD Name: SpellingCow Spell Checker
Author: Nuttzy99
MOD Description: SpellingCow is a super easy to install, resource light, and FREE forum spell checker! SpellingCow spell checks over 1.2 million words per day from the 6000+ sites in the SpellingCow network.

The highlights:
  • Support for over 75 languages!!! Now in the Options menu of the spell checker you can set your default language or dialect. For English, there is even choice of UK, US, and CA! Check the complete list of supported languages.
  • Ridiculously easy installation that will work for any web form!! - Just drop in a file, make a few edits, and go!
  • Personal and portable dictionaries, usable from ANY site running SpellingCow!
  • Optional ability to automatically spell check prior to posting
  • Easy to maintain - most upgrades will be automatic without requiring any changes to your server! There have been numerous such updates in the 6+ months since the previous release and no one had to touch their config!
  • Customizable! You can choose from 3 different styles or with a licensed version, you can make your own style!
Updating current installs:
Firstly, updating is a breeze! Simply drop in the new spell-gw.php file. That's it! No editing! Or use the included update MOD with EasyMOD. Here are some reasons to update:
  • With the 75+ languages, you can set the default lang for your board (otherwise US English is default). So if you are in the UK, simply edit the default setting in the gw file, and you spell color with a "u" and authorization with an "s" ;)
  • Faster loading! For posts under 450 characters, an entire step is now skipped, saving several seconds in some cases!
  • Fix for several connectivity issues
  • Fix for several Macintosh issues
  • Includes several methods for disabling the auto spell check feature
Demo+Details+Support: http://www.spellingcow.com

Notes:
FYI, the SpellingCow service does display some unobtrusive ads on the checker and requires a link back. It's no biggie IMO, but look at the demo and see for yourself!

Enjoy!


MOD Version: 1.6.0 (Updated 03/16/05)

Download File: SpellingCow_1-6-0.zip
mods overview page: View
File Size: 19893 Bytes

Security Score: 0
Last edited by Extensions Robot on Mon Apr 30, 2007 12:30 am, edited 1 time in total.
(this is a non-active account manager for the phpBB Extension Customisations Team)

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Fri Jul 09, 2004 12:43 am

MOD Validated/Released

Notes:
Clearly one of the best MODs of all-time... okay maybe I'm biased ;) I think if you have a need for spell checking (even if it's not phpBB) then Spelling Cow should be a pretty good solution :mrgreen:

Enjoy!
-Nuttzy :cool:

User avatar
lightdarkness
Registered User
Posts: 254
Joined: Fri Nov 21, 2003 1:13 am
Contact:

Post by lightdarkness » Fri Jul 09, 2004 1:15 am

WORKS GREAT!

Thank you so much *bows to the mod god*

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Fri Jul 09, 2004 12:55 pm

Hehe, good to know, thanks!

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
lightdarkness
Registered User
Posts: 254
Joined: Fri Nov 21, 2003 1:13 am
Contact:

Post by lightdarkness » Sat Jul 10, 2004 12:48 am

does this mean my mod will be validated quicker ;)

just kidding.

greatness
Registered User
Posts: 107
Joined: Tue Jul 06, 2004 5:31 pm

Post by greatness » Sat Jul 10, 2004 8:29 am

How does one uninstall the spellcow? Its causing a DEBUG mode on registration on my forum. Thank you :)

Merlin Sythove
Registered User
Posts: 2339
Joined: Tue Mar 16, 2004 7:42 am

Post by Merlin Sythove » Sat Jul 10, 2004 12:08 pm

This looks interesting, but I have a Dutch board. Any ideas if and when Dutch will be available?

Thanks,
Dennis

User avatar
pettalk
Registered User
Posts: 24
Joined: Fri Jun 04, 2004 9:09 am
Contact:

Post by pettalk » Sat Jul 10, 2004 12:32 pm

again...


how do I edit this,
-----[ SQL ]---------------------------------
#
# NOTE: if you don't want the checker to be on by default, change "DEFAULT '1';" to "DEFAULT '0';"
#
ALTER TABLE `phpbb_users` ADD `user_autospell` TINYINT( 1 ) DEFAULT '1';


I know where, but what is actually going after then phpbb_user.. the `user_autospell`only or all `user_autospell` TINYINT( 1 ) DEFAULT '1';


and should is be a space between the _user and _autospell?

User avatar
pettalk
Registered User
Posts: 24
Joined: Fri Jun 04, 2004 9:09 am
Contact:

Post by pettalk » Sat Jul 10, 2004 12:37 pm

I get this after I have added it

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'TINYINT( 1 ) DEFAULT '1'' at line 1

greatness
Registered User
Posts: 107
Joined: Tue Jul 06, 2004 5:31 pm

Post by greatness » Sat Jul 10, 2004 1:02 pm

DEBUG MODE

SQL Error : 1054 Unknown column 'user_autospell' in 'field list'

INSERT INTO phpbb2_users (user_id, username, user_regdate, user_password, user_email, user_icq, user_website, user_occ, user_from, user_interests, user_sig, user_sig_bbcode_uid, user_avatar, user_avatar_type, user_viewemail, user_aim, user_yim, user_msnm, user_attachsig, user_allowsmile, user_autospell, user_allowhtml, user_allowbbcode, user_allow_viewonline, user_notify, user_notify_pm, user_popup_pm, user_timezone, user_dateformat, user_lang, user_style, user_level, user_allow_pm, user_active, user_actkey) VALUES (217, '*****', 1089464314, '6531401f9a6807306651b87e44c05751', '******@aol.com', '', '', '', '', '', '', '', '', 0, 0, '', '', '', 1, 1, 1, 1, 1, 1, 0, 1, 1, 2, 'D M d, Y g:i a', 'english', 4, 0, 1, 0, '2172cbe')

Line : 547
File : /forum/phpBB2/includes/usercp_register.php


Thsi is what people get when they register on my board.

I have installed all the files correct and checked everything....

The red below shows what I have at line 547. I hope someone with some brains can figure this out as I have people waiting to join. Thanks :)
$sql .= "1, '')";
}

if ( !($result = $db->sql_query($sql, BEGIN_TRANSACTION)) )
{
message_die(GENERAL_ERROR, 'Could not insert data into users table', '', __LINE__, __FILE__, $sql);
}

$sql = "INSERT INTO " . GROUPS_TABLE . " (group_name, group_description, group_single_user, group_moderator)
VALUES ('', 'Personal User', 1, 0)";
if ( !($result = $db->sql_query($sql)) )


Well I tried re-installing spellcow as it seems there are a few bugs in the one I have and last week a new one was released.

Above is what I have at line:
Line : 543
File : /forum/phpBB2/includes/usercp_register.php

greatness
Registered User
Posts: 107
Joined: Tue Jul 06, 2004 5:31 pm

Post by greatness » Sat Jul 10, 2004 1:04 pm

pettalk wrote: I get this after I have added it

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'TINYINT( 1 ) DEFAULT '1'' at line 1


Sounds like what I have!

greatness
Registered User
Posts: 107
Joined: Tue Jul 06, 2004 5:31 pm

Post by greatness » Sat Jul 10, 2004 1:11 pm

pettalk wrote: again...


how do I edit this,
-----[ SQL ]---------------------------------
#
# NOTE: if you don't want the checker to be on by default, change "DEFAULT '1';" to "DEFAULT '0';"
#
ALTER TABLE `phpbb_users` ADD `user_autospell` TINYINT( 1 ) DEFAULT '1';


I know where, but what is actually going after then phpbb_user.. the `user_autospell`only or all `user_autospell` TINYINT( 1 ) DEFAULT '1';


and should is be a space between the _user and _autospell?


YOu need to open your phpmyadmin adn open the database for your board, then find phpbb_user and add a new field..... then in the field type the info.

The only thing is it comes up as an error as in my board when people try to register or change their profile if already a member...

Im wondering if where it is placed in the table makes a difference as I justa dded the use_autospell at the end of the phpbb_user table.

User avatar
pettalk
Registered User
Posts: 24
Joined: Fri Jun 04, 2004 9:09 am
Contact:

Post by pettalk » Sat Jul 10, 2004 1:14 pm

Ok thanks I did Add the code for that and it worked, but now I came across something odd..

greatness
Registered User
Posts: 107
Joined: Tue Jul 06, 2004 5:31 pm

Post by greatness » Sat Jul 10, 2004 1:23 pm

pettalk wrote: Ok thanks I did Add the code for that and it worked, but now I came across something odd..


go on what have you found.... all of this will help the people when they log on later.

Ive also noticed that in the DEBUG error the user_autospell isnt even listed....

Syntax error by the way means a writing error so perhaps its spelled wrong in one of the bits we had to add to one of the php files or a ; missing or something simple.

User avatar
pettalk
Registered User
Posts: 24
Joined: Fri Jun 04, 2004 9:09 am
Contact:

Post by pettalk » Sat Jul 10, 2004 1:54 pm

Well I cant add this code.

// SPELLINGCOW - begin
$lang['Always_spellcheck'] = 'Always check Spelling before posting';
// SPELLINGCOW - end

in

# NOTE - the complete line to find is:
# $lang['Always_smile'] = 'Always enable Smilies';
#
$lang['Always_smile']

Sorry this is the code that I am sppse to enter after... "
$lang['Always_smile'] = 'Always enable Smilies';"
the // is that suppose to be with the code or not, and also should I press space after the ] or putt the mouse right after and press enter?


the page goes banana :cry: , is it suppose to be with the // and is it after as in space or enter???

and my Admin link on the main page goes off
Last edited by pettalk on Sat Jul 10, 2004 1:57 pm, edited 1 time in total.

Post Reply

Return to “[2.0.x] MOD Database Cleanup”