[2.0.13] SpellingCow Spell Checker

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
56
49%
Very Good
17
15%
Good
6
5%
Fair
6
5%
Poor
29
25%
 
Total votes: 114

halochat
Registered User
Posts: 29
Joined: Tue Aug 24, 2004 12:41 am
Contact:

Post by halochat »

Installed it, along with a ton of other mods - works great, except for one minor problem - the user cannot change the setting in their profile to on/off... Any suggestions?
[HC]D-Man
Owner/Chief Admin of HaloChat
www.halochat.net
User avatar
James78
Registered User
Posts: 811
Joined: Sat Jul 30, 2005 4:54 pm
Location: Washington, USA
Contact:

Post by James78 »

LukeSkiewalker wrote: from spelling_cow_1-6-0.txt:

Code: Select all

#
#-----[ SQL ]---------------------------------
#
# NOTE: if you don't want the checker to be on by default, change "DEFAULT '1';" to "DEFAULT '0';"
#    or you can use the spellingcow_auto_off.txt MOD to turn it off by default at any time
#
ALTER TABLE `phpbb_users` ADD `user_autospell` TINYINT( 1 ) DEFAULT '1';


Thanks. The reason I didn't see that is because I got this auto-installed with easymod
User avatar
LukeSkiewalker
Registered User
Posts: 10
Joined: Wed Aug 03, 2005 11:00 pm

Post by LukeSkiewalker »

:?: since when does easymod create sql tables? :?
Orchid
Registered User
Posts: 5
Joined: Fri May 03, 2002 3:54 pm
Contact:

Post by Orchid »

LukeSkiewalker wrote: :?: since when does easymod create sql tables? :?


I'm not sure when they started as I never used it before last night - but in all my mods it created SQL tables. This one was VERY EASY to install with it - and the only problem I had was with the default being set to ON for all users. I went in and edited it ... now it's great! Would be nice to be able to add words through the MOD to the word table without having to sign up via spellcow.com but for a free service it's exceptional.

BTW, I istalled it with EZ Mod 0.2.1a on phpBB 2.0.17 and everything is working wonderfully.
"We do not have to visit a madhouse to find disordered minds; our planet is the mental institution of the universe."
-Johann von Goethe
User avatar
The Suite
Registered User
Posts: 617
Joined: Sat Jul 30, 2005 11:11 am
Location: NYC, USA
Contact:

Post by The Suite »

LukeSkiewalker wrote: :?: since when does easymod create sql tables? :?


EM Rox :-)
Much appreciloved,

The Suite
Thank you :-)
The IT Security Information Center
User avatar
LukeSkiewalker
Registered User
Posts: 10
Joined: Wed Aug 03, 2005 11:00 pm

Post by LukeSkiewalker »

That would explain it. I have Version 0.1.13 Guess it is time to upgrade...
User avatar
JooK
Registered User
Posts: 28
Joined: Sun Oct 05, 2003 4:55 pm
Location: LA, CA, USA
Contact:

Post by JooK »

Guys, is there a way to disable this mod, deactivate it somehow. I find that window that pops up really annoying, and now that i have the mod installed, I dont know how to disable/uninstall it for all the users on the board as a general preference.

Any clue? any way?
Last edited by JooK on Tue Aug 30, 2005 10:26 pm, edited 1 time in total.
.: TheJooK :.
User avatar
JooK
Registered User
Posts: 28
Joined: Sun Oct 05, 2003 4:55 pm
Location: LA, CA, USA
Contact:

Post by JooK »

Shameful bump.
.: TheJooK :.
User avatar
LukeSkiewalker
Registered User
Posts: 10
Joined: Wed Aug 03, 2005 11:00 pm

Post by LukeSkiewalker »

LukeSkiewalker wrote: from spelling_cow_1-6-0.txt:

Code: Select all

#
#-----[ SQL ]---------------------------------
#
# NOTE: if you don't want the checker to be on by default, change "DEFAULT '1';" to "DEFAULT '0';"
#    or you can use the spellingcow_auto_off.txt MOD to turn it off by default at any time
#
ALTER TABLE `phpbb_users` ADD `user_autospell` TINYINT( 1 ) DEFAULT '1';
3cog
Registered User
Posts: 37
Joined: Sat Jun 04, 2005 11:50 am
Location: LRC forums
Contact:

Spelling Cow

Post by 3cog »

Jonny123 wrote: Anyways, I've notice since then that now the smilies javascript is failing to work properly - when making a post and clicking on a smilie to have the system automatically enter that smilies BBcode into the text box, it now instead does nothing. The smilies can still be used, but just have to be entered manually.


:arrow: I'm getting the same exact error too. in addition it also messed up highlighting texts etc.
No errors pop up, it's just fails to add the code with the smiley click. Sorry if this has been covered...but there's 21 pages already. Ever heard of this? I'm sure this is relateed directly to my installation since every SpellingCow code was placed around the smilies' codes...


:arrow: NO it hasnt been coverd in the '23' pages actually untill i came across ur post and no one seems to know how to deal with the smilies java.
Any help is appreciated! I'll be looking into it in the meantime.


:arrow: Temporarly i have deleted the codes in posting_body.tpl and it solved the porblem, for now, but i need 2 get that java smilie error resolved as i really need a spell-checker on my boards.

:arrow: Can someone help? Nuttzy hasn't replied in ages and i really dont want to uninstall this excellent mod. Even if i had to uninstall it, i might face other porblems i dont need.

:arrow: anyone? :?
Koyaanis
Registered User
Posts: 74
Joined: Sun Sep 04, 2005 3:05 pm

Privacy Issues

Post by Koyaanis »

I'm just posting this out of concern that others might not have considered. Every time you use this mod it sends ALL the text in any post, public or private, to a 3rd party. In order to check the spelling, it has to run every word and link through their Spelling-Cow's servers. Surely they're not doing this out of the goodness of their hearts and to put an inobtrusive ad on your screen.

Has anyone considered what kinds of privacy issues might be being violated by this? I see the potential of spelling-cow to be a huge violation of privacy for all kinds of information and email addresses for spamming.

I personally value the privacy of others, and my own. After installing this and seeing how it worked, I quickly uninstalled it. I would NEVER allow some other organization to have complete access to anything anyone posts on my forums. I respect people more than that.

Until someone comes up with a better spell-check mod for phpBB, my users will just have to rely on things like the built-in spell-checker in Opera browser and other utilities.

In case you are wondering ... I don't have problems with paranoia. I just have a huge problem with the less intelligent that think our right to privacy is no longer an inalienable right.
Last edited by Koyaanis on Wed Sep 07, 2005 11:52 pm, edited 1 time in total.
3cog
Registered User
Posts: 37
Joined: Sat Jun 04, 2005 11:50 am
Location: LRC forums
Contact:

Post by 3cog »

That's it. this mod is going 2 be trashed. I'll use this instead. http://toolbar.google.com/ :roll:
giger
Registered User
Posts: 15
Joined: Sat Aug 20, 2005 3:48 pm

Post by giger »

this is greate and all besides the ads...I personally won't be using this, ever.. :?
oasis.alex
Registered User
Posts: 6
Joined: Fri Jul 30, 2004 11:22 am

Post by oasis.alex »

something seems to have happened to my board, i get this error now when click submit on the spellcheck :(
General Error

Error loading spelling words info

DEBUG MODE

SQL Error : 1062 Duplicate entry '16777215' for key 1

INSERT INTO phpbb_spelling_words ( spell_id, word, position, suggestions, checked) VALUES ( 3563666, 'erm', 0, 'Erma, REM, Rem, rem, EM, Em, em, ER, Er, rm, arm, Perm, berm, germ, perm, term, elm, ERA, Erl, Erv, era, ere, erg, err, Er''s', 0)

Line : 1118
File : /usr/local/www/data-dist/spell/public_html/phpBB2/spell.php
User avatar
-=SFV=-Killzone
Registered User
Posts: 11
Joined: Wed Sep 07, 2005 8:36 pm

Won't allow others to register in forum.

Post by -=SFV=-Killzone »

I've install this forum twice and keep having the same problem after installing the cow. I can log in as admin and the spell check does work perfectly. The registration permission config is by admin only.

I ran a test without the cow loaded and several test registrations worked fine, it was only after I installed the cow it won't let others register. Current site location is http://www.forum.sfviper.com/forum/

DEBUG MODE

Could not insert data into users table

SQL Error : 1054 Unknown column 'user_autospell' in 'field list'

INSERT INTO phpbb_users (user_id, username, user_regdate, user_password,
user_email, user_icq, user_website, user_occ, user_from, user_interests, user_sig, user_sig_bbcode_uid,
user_avatar, user_avatar_type, user_viewemail, user_aim, user_yim, user_msnm, user_attachsig, user_allowsmile,
user_autospell, user_allowhtml, user_allowbbcode, user_allow_viewonline, user_notify, user_notify_pm, user_popup_pm,
user_timezone, user_dateformat, user_lang, user_style, user_level, user_allow_pm, user_active, user_actkey) VALUES
(3, '-=SFV=-Fubar', 1126122970, 'f7217b1da3fabc0d26414a2e4d2dde90', 'name@hotmail.com', '', '', '', '', '', '', '', '', 0,
0, '', '', '', 1, 1, 1, 1, 1, 1, 0, 1, 1, -12, 'D M d, Y g:i a', 'english', 2, 0, 1, 0, 'a46bc86713717c5d25')

Line : 608
File : usercp_register.php
Post Reply

Return to “[2.0.x] MOD Database Cleanup”